Micro

1.83 installed now i cant connect

14 posts in this topic

Mac sierra as server

windows 10 64 as client

 

ERROR: eof violates ssl protocol

 

I get ssl erros. How do I reset everything and start over?

 

[2016-09-26T10:06:59] INFO: client connection may not be secure

[2016-09-26T10:07:00] INFO: OpenSSL 1.0.2 22 Jan 2015

[2016-09-26T10:07:16] ERROR: ssl error occurred (system call failure)

[2016-09-26T10:07:16] ERROR: eof violates ssl protocol

[2016-09-26T10:07:16] ERROR: failed to accept secure socket

[2016-09-26T10:07:16] INFO: client connection may not be secure

[2016-09-26T10:07:17] INFO: OpenSSL 1.0.2 22 Jan 2015

Share this post


Link to post
Share on other sites
1.8.3 seems have SSL Problem.

 

Disable SSL. Both Client and Server. =^_^=

 

How can I disable SSL on Ubunut 16.04?

Share this post


Link to post
Share on other sites

Please don't disable SSL support. If you do, I will read all your passwords as they travel across your local network. ;)

 

Make sure you are running Synergy Pro on both the client and the server. The easiest way is to re-run the setup wizard and make sure that you are logged in.

 

On my Mac, the wizard started by itself when I opened the app. On debian linux, I installed with dpkg -i, and synergy said nothing special when I started it, but I noticed that the window title was "Synergy Trial". When I ran the wizard again, I found out that it hadn't stored my login credentials, and after I fixed that the connection just worked.

 

I believe that the reason for this is that the free version of Synergy doesn't have ssl support. But license information should be kept during upgrades, and it should be very clear to the user that they are trying to run the free version but with (broken) ssl settings.

Share this post


Link to post
Share on other sites

Same problem here. Didn't try turning off SSL, but instead went back to v1.8.2. Also had a problem on server with not being able to install service until after a logoff/logon cycle. I remember this last issue from versions back a while but haven't had recently, including no problem with the v1.8.2 re-install.

Share this post


Link to post
Share on other sites
Please don't disable SSL support. If you do, I will read all your passwords as they travel across your local network. ;)

 

Make sure you are running Synergy Pro on both the client and the server. The easiest way is to re-run the setup wizard and make sure that you are logged in.

 

On my Mac, the wizard started by itself when I opened the app. On debian linux, I installed with dpkg -i, and synergy said nothing special when I started it, but I noticed that the window title was "Synergy Trial". When I ran the wizard again, I found out that it hadn't stored my login credentials, and after I fixed that the connection just worked.

 

I believe that the reason for this is that the free version of Synergy doesn't have ssl support. But license information should be kept during upgrades, and it should be very clear to the user that they are trying to run the free version but with (broken) ssl settings.

 

Aw shucks. I purchased Synergy Basic a couple of years ago. Today I attempted to upgrade from 1.7.6 to 1.8.3. Now it's broken, and it seems I need to upgrade to Synergy Pro. Not good. :-(

Share this post


Link to post
Share on other sites

I have the same issue with Synergy Pro 1.83. I had to disable the SSL in Synergy settings to get 1.83 to work.

Share this post


Link to post
Share on other sites

I had to turn off SSL also. Client kept saying it couldn't verify server certificate fingerprint.

 

And somehow the screen got nuked in my server config during the upgrade or rerunning the setup wizard. That was easy to restore.

 

[ Running Synergy Pro on both client and server. ]

Share this post


Link to post
Share on other sites
I had to turn off SSL also. Client kept saying it couldn't verify server certificate fingerprint.

 

And somehow the screen got nuked in my server config during the upgrade or rerunning the setup wizard. That was easy to restore.

 

[ Running Synergy Pro on both client and server. ]

 

I really needed to get Synergy running again, so I removed and reinstalled the server on Ubunutu, and, after re-installing, was able to figure out how to turn off SSL from a Windows client. I would like to get my Ubuntu client running again, but can't figure out how to turn off SSL from Ubunutu. Anybody know?

Share this post


Link to post
Share on other sites

Hey, don't disable SSL!!!

 

It works after you delete the old SSL-certificates and run the Setup-Wizard again.

 

1.) Make sure you have a backup of your old Server-configuration!

 

2.) Stop Synergy-Server and all synergy processes!

 

3.) Remove old Server config-directory’s:

"/home/USER/.config/Synergy"

"/home/USER/.synergy"

 

4.) Start Synergy again and create your own Settings with Setup-Wizard. The setup creates new certificates!

 

5.) Restore your old configuration and start Synergy-Server.

 

6.) Reconnect the Synergy-Client and accept the new Server fingerprint (see logs).

 

#Synergy-Server log:

..
[2016-09-27T10:31:53] NOTE: started server, waiting for clients
[2016-09-27T10:32:43] INFO: OpenSSL 1.0.1f 6 Jan 2014
[2016-09-27T10:32:43] INFO: accepted secure socket
[2016-09-27T10:32:43] INFO: AES256-GCM-SHA384       TLSv1.2 Kx=RSA      Au=RSA  Enc=AESGCM(256) Mac=AEAD
[2016-09-27T10:32:43] NOTE: accepted client connection
[2016-09-27T10:33:13] NOTE: new client is unresponsive
[2016-09-27T10:34:50] INFO: OpenSSL 1.0.1f 6 Jan 2014
[2016-09-27T10:34:50] INFO: accepted secure socket
[2016-09-27T10:34:50] INFO: AES256-GCM-SHA384       TLSv1.2 Kx=RSA      Au=RSA  Enc=AESGCM(256) Mac=AEAD
[2016-09-27T10:34:50] NOTE: accepted client connection
[2016-09-27T10:34:50] NOTE: client "TUX2" has connected
[2016-09-27T10:34:52] INFO: switch from "TUX1" to "TUX2" at 0,391
..

 

#Synergy-Client log:

..
[2016-09-27T10:33:26] NOTE: started client
[2016-09-27T10:33:26] NOTE: connecting to 'TUX1': 192.168.0.20:24800
[2016-09-27T10:33:26] INFO: OpenSSL 1.0.2g  1 Mar 2016
[2016-09-27T10:33:26] NOTE: server fingerprint: XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX
[2016-09-27T10:33:26] INFO: stopping synergy desktop process
[2016-09-27T10:33:26] ERROR: failed to verify server certificate fingerprint
[2016-09-27T10:33:26] INFO: process exited normally
[2016-09-27T10:35:33] INFO: starting client
[2016-09-27T10:35:33] INFO: config file: /tmp/qt_temp.F30687
[2016-09-27T10:35:33] INFO: log level: INFO
[2016-09-27T10:35:33] NOTE: started client
[2016-09-27T10:35:33] NOTE: connecting to 'TUX1': 192.168.0.20:24800
[2016-09-27T10:35:33] INFO: OpenSSL 1.0.2g  1 Mar 2016
[2016-09-27T10:35:33] NOTE: server fingerprint: XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX
[2016-09-27T10:35:33] INFO: connected to secure socket
[2016-09-27T10:35:33] INFO: server ssl certificate info: /CN=Synergy
[2016-09-27T10:35:33] INFO: AES256-GCM-SHA384       TLSv1.2 Kx=RSA      Au=RSA  Enc=AESGCM(256) Mac=AEAD
[2016-09-27T10:35:33] NOTE: connected to server
[2016-09-27T10:35:35] INFO: entering screen
..

 

 

Best regards

Mic

 

Test-System: Ubuntu 14.04.5 LTS (Synergy-Server) and Ubuntu 16.04.1 LTS (Synergy-Client)

Share this post


Link to post
Share on other sites

Running into the SSL issue myself. I uninstalled both the server and client, reinstalled. No luck. What did work for me was running the wizard again on both the server and client. The wizard generated new certificates and now 1.8.3 is up and running securely.

Share this post


Link to post
Share on other sites

You don't need to turn off SSL. Turn logging level in Settings to "Info" and it will start asking about accepting the certificate. Then turn logging back once you've accepted the certificate. 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now