Roberto Paolinelli

1.8.3 failed to connect to server

32 posts in this topic

Hello,

client in Win7 64 bit platform

Server in WIn 10 64 bit platform

 

Synergy 1.8.2 it was all ok

Synergy 1.8.3 the don't connect neither after reboot or process shutdown/restart

 

I can ping both PC each other

 

Client complains: failed to connect to server

Server tells: failed to accept secure socket

 

UPDATED:

restarted the service too and server Log File tells

[2016-09-26T16:13:28] ERROR: ssl error occurred (system call failure)

[2016-09-26T16:13:28] ERROR: eof violates ssl protocol

[2016-09-26T16:13:28] WARNING: failed to accept secure socket

[2016-09-26T16:13:44] WARNING: failed to accept secure socket

 

Can anyone help me?

 

Thank you very much

Best Regards

Roberto

Edited by Guest

Share this post


Link to post
Share on other sites

I just installed the latest (1.8.3) on a Mac running MacOS Sierra (ver 10.12) as the client and on a PC running Windows 10 (latest version) running as the server and also have now have error trying to connect. Worked fine with last version before this one. Server does not seem to see client and client is timing out over and over again.

 

I have restarted both the MAc and PC and same errors occur. Help?

Share this post


Link to post
Share on other sites

Same for me...

 

(A user of 5+ years too). Not had this problem before.

 

Gonna have to roll back.

Share this post


Link to post
Share on other sites

I've had to reconfigure Mac server (10.11.x) from scratch, and I have had the same timeout issue (Linux client, both updated). I've solved it by disabling SSL encryption on both sides, temporary

Share this post


Link to post
Share on other sites

It's not just me, then. I upgraded two Mac clients - client on El Cap, and server on Sierra, to 1.8.3, and they jabbered back and forth about each other, but wouldn't connect. I dropped back to 1.8.2, and they worked again. I'll try disabling SSL as mentioned below, and see if that does it.

Share this post


Link to post
Share on other sites
Disabling SSL works...

 

I can confirm that disabling SSL works. I am using Ubuntu-MATE 16.04 as my server and MacOSX 10.11.6 as the client.

Share this post


Link to post
Share on other sites

I'm having the same problem. Mac 10.11.6 server, Windows 7 client. If I turned off SSL, I can get it to work.

Share this post


Link to post
Share on other sites

SSL connect is most definitely broken in 1.8.3.

 

I'm happy to provide deeper logging via PM to any Synergy devs that want to dig in with me.

 

Server (Win10):

[2016-09-26T10:57:51] NOTE: started server, waiting for clients
[2016-09-26T10:57:51] INFO: watchdog status: ok
[2016-09-26T10:57:55] INFO: accepted secure socket
[2016-09-26T10:58:11] INFO: accepted secure socket
[2016-09-26T10:58:28] INFO: accepted secure socket

 

Client (OSX 10.11.6):

[2016-09-26T10:57:55] NOTE: started client
[2016-09-26T10:57:55] NOTE: connecting to '192.168.2.100': 192.168.2.100:24801
[2016-09-26T10:57:55] INFO: OpenSSL 1.0.2 22 Jan 2015
2016-09-26 10:57:55.587 synergyc[9955:2511190] starting cocoa loop
[2016-09-26T10:57:56] NOTE: server fingerprint: 0B:B0:61:37:DA:1B:5E:75:4B:9F:CC:9D:76:29:BB:F0:D7:03:37:3C
[2016-09-26T10:57:56] INFO: connected to secure socket
[2016-09-26T10:57:56] INFO: server ssl certificate info: /CN=Synergy
[2016-09-26T10:57:56] INFO: AES256-GCM-SHA384       TLSv1.2 Kx=RSA      Au=RSA  Enc=AESGCM(256) Mac=AEAD
[2016-09-26T10:58:11] WARNING: failed to connect to server: Timed out
[2016-09-26T10:58:12] NOTE: connecting to '192.168.2.100': 192.168.2.100:24801
[2016-09-26T10:58:12] INFO: OpenSSL 1.0.2 22 Jan 2015
[2016-09-26T10:58:12] NOTE: server fingerprint: 0B:B0:61:37:DA:1B:5E:75:4B:9F:CC:9D:76:29:BB:F0:D7:03:37:3C
[2016-09-26T10:58:12] INFO: connected to secure socket
[2016-09-26T10:58:12] INFO: server ssl certificate info: /CN=Synergy
[2016-09-26T10:58:12] INFO: AES256-GCM-SHA384       TLSv1.2 Kx=RSA      Au=RSA  Enc=AESGCM(256) Mac=AEAD
[2016-09-26T10:58:28] WARNING: failed to connect to server: Timed out
[2016-09-26T10:58:29] NOTE: connecting to '192.168.2.100': 192.168.2.100:24801
[2016-09-26T10:58:29] INFO: OpenSSL 1.0.2 22 Jan 2015
[2016-09-26T10:58:29] NOTE: server fingerprint: 0B:B0:61:37:DA:1B:5E:75:4B:9F:CC:9D:76:29:BB:F0:D7:03:37:3C
[2016-09-26T10:58:29] INFO: connected to secure socket
[2016-09-26T10:58:29] INFO: server ssl certificate info: /CN=Synergy
[2016-09-26T10:58:29] INFO: AES256-GCM-SHA384       TLSv1.2 Kx=RSA      Au=RSA  Enc=AESGCM(256) Mac=AEAD
[2016-09-26T10:58:45] WARNING: failed to connect to server: Ti
med out
[2016-09-26T10:58:46] NOTE: connecting to '192.168.2.100': 192.168.2.100:24801
[2016-09-26T10:58:46] INFO: OpenSSL 1.0.2 22 Jan 2015
[2016-09-26T10:58:46] NOTE: server fingerprint: 0B:B0:61:37:DA:1B:5E:75:4B:9F:CC:9D:76:29:BB:F0:D7:03:37:3C
[2016-09-26T10:58:46] INFO: connected to secure socket
[2016-09-26T10:58:46] INFO: server ssl certificate info: /CN=Synergy
[2016-09-26T10:58:46] INFO: AES256-GCM-SHA384       TLSv1.2 Kx=RSA      Au=RSA  Enc=AESGCM(256) Mac=AEAD

Edited by Guest

Share this post


Link to post
Share on other sites

Disabling SSL alone did not fix it for me using MacSierra as my server. I had to delete the Synergy folder in ~/Library/ Synergy folder.

 

After disabling SSL now on both sides I'm connected.

Share this post


Link to post
Share on other sites

It seems previous updates did not required re-registration. My Server machine reset its configs on applying this update, and forced me to re-register it (using Serial or login). When that happened, it generated a new SSL fingerprint.

 

My client did not re-register, and was still using the old config with the old SSL fingerprint. This is why the server did not accept the SSL connection.

 

The fix is to run through the config wizard again to re-register on the machine which did not force you to re-config (in my case, the client). Once that happens, it will ask you to trust the new SSL fingerprint and it should work.

Share this post


Link to post
Share on other sites

Windows (server) and Centos (client) here.

 

Same issue and fix ... on upgrade they wouldn't talk over SSL... re-ran the config wizard and put in my pro serial number in both. Everything works as expected now.

 

Robert

 

 

It seems previous updates did not required re-registration. My Server machine reset its configs on applying this update, and forced me to re-register it (using Serial or login). When that happened, it generated a new SSL fingerprint.

 

My client did not re-register, and was still using the old config with the old SSL fingerprint. This is why the server did not accept the SSL connection.

 

The fix is to run through the config wizard again to re-register on the machine which did not force you to re-config (in my case, the client). Once that happens, it will ask you to trust the new SSL fingerprint and it should work.

Share this post


Link to post
Share on other sites

Same problem, using Linux Mint 17.3 on the server and MacOS 10.11 (El Capitan) on the client. 1.8.2 was fine, 1.8.3 turbo-hates SSL now. What gives? I've turned off SSL for now, since it's on my home network, but I'd feel better if it were on...

 

Edit: Reran the wizard on my Linux Mint 17.3 desktop, and now it connects via SSL. This should be in big flashing red letters on the website.

Share this post


Link to post
Share on other sites

Same here, no connection to server (both client and server on Win10 x64). But for me, SSL is not available, getting the entry "NOTE: crypto disabled because of ns plugin not available". Executing the wizard or cleaning the config didn't fix it. Notified this error in RC and reported this to developers, but it isn't yet fixed in final. Have to stick with 1.8.2.

Share this post


Link to post
Share on other sites

I had the same issue.

Win 8.1 64-bit - Server

Ubuntu 14.04 64-bit - Client

 

I ran the Wizard on both: File -> Run Wizard

 

This fixed the issue.

On the Client, I had to select "Accept certificate" or something like that after the Wizard finished.

Share this post


Link to post
Share on other sites

Same thing here. MacOS Sierra (client) Ubuntu 16.04 (Server).

 

Everything was working in 1.8.2

 

Confirmed that re-running the wizard and accepting the SSL Cert on the client fixed the issue.

Share this post


Link to post
Share on other sites

Same error here. Tried everything for over an hour. Then switched off SSL on both client and server and instantly fixed issue.

Share this post


Link to post
Share on other sites

Hey all,

 

I had the connection problems once I updated to 1.8.3. Read the email that went out from Synergy that said there was an issue and I would have to run the setup Wizard again. Tried this... didn't work. I tried to disable the SSL... Didn't work. many restarts and firewall adjustments to try and get it to work, No luck.

 

MY FIX --> I uninstalled Synergy from the "server" computer and ran Revo to get rid of all the leftovers. Reinstalled Synergy and ran setup (the setup auto prompted upon installation). WORKED!

 

Hope this helps some of you.

Share this post


Link to post
Share on other sites

RESOLVED!

Received these instructions by email from the Synergy team. They resolved the issue for me.

 

There's a known issue in Synergy 1.8.3 where the SSL plugin can be out of date, which stops the client connecting to the server. To fix this, please re-run the wizard on all of your machines.

 

1. Open Synergy on the server

2. If Windows: Go to the Edit, then click Settings

3. If macOS: Go to Synergy, then click Preferences

4. Ensure the "Use SSL encryption" checkbox is enabled

5. Go to File, then Run Wizard

6. Click Next until you see the Activation screen

7. Enter your login details or serial key

8. Click "Continue" and finish the wizard

9. Repeat those steps for each client

 

I'm sorry you had to do that, it's a pretty major screw up on our part, sadly we didn't see this while testing. If those steps don't help, please let us know so we can troubleshoot further. Thanks for your patience!

Share this post


Link to post
Share on other sites

Didn't work for me. On my MacBook, it seemed to (the MacBook is the server). On my Windows 10 client, rerunning the setup wizard didn't clear out the server cert fingerprint. In fact, uninstalling and reinstalling Synergy on Windows didn't clean it out either. I tried to delete a directory that had fingerprints in it - that didn't help either. So far, no way to cause the Windows client to reprompt me to authorize the server cert.

Share this post


Link to post
Share on other sites

I tried taking off SSL support, updated things with the wizard several times. Nothing would allow me to connect two devices that were working on 1.8.2. As I needed to work today I backed off till I could spend more time on this problem. I'll keep monitoring here to see if a fix comes.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now