Sign in to follow this  
Luc Mousseau

Extra Mouse button mis-recognized in server config window

0 posts in this topic

I have a logitech mouse, which has forward and back buttons. For whatever reason, these weren't automatically working on the client in my setup, so I decided to just create hotkeys on the server to handle it using the keyboard equivalent for back (alt+left) and forward (alt+right), when clicking on the same mouse buttons.

 

The problem is that in the "Hotkey" window, where you "Enter the specification for the hotkey:", it sees both of my mouse buttons as "mousebutton(4)".

 

I've worked around this by saving the server configuration to a file, and manually changing the config from this:

mousebutton(4) = keystroke(Alt+Left,*)

mousebutton(4) = keystroke(Alt+Right,*)

To this:

mousebutton(4) = keystroke(Alt+Left)

mousebutton(5) = keystroke(Alt+Right)

 

It's an older logitech mouse and I do have the logitech Setpoint software installed, but exiting that app, or configuring the forward/back buttons differently within it (it has options for "forward" and "back", but also "Generic button", which is what I have it set to), made no difference. And obviously given that the above config change does work, it's obviously not that it doesn't know the second button IS button 5.... if it truly thought they were both button 4, then I wouldn't expect the manual config change to fix it.

 

On a side note, it would be nice if the Hotkey config allowed for NOT assigning the 2nd param to the keystroke() function, so that ONLY the current screen is affected by it. It appears the only option the interface allows are "*", when the "only on these screens" checkbox is unchecked, or actually selecting screens.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this