Sign in to follow this  
Pedro Orlando de Albuquerq

Drag and Drop not working

1 post in this topic

Server: Fedora 24 (XFCE spin)

Client: Windows 10 Pro

Synergy v1.8.2-stable on both

 

When I try to drag the file, my cursor just stops on the screen edge of my server (or client).

I double checked that the "Drag and Drop" flag is enable.

The cursor does not change.

In the log of synergy it doesn't show any report about my try to drag a file to the other side.

Share this post


Link to post
Share on other sites

I have the same question. Similar setup:

 

Server: Windows 10 Pro

Client: Fedora 24 (using Gnome 3.20.2)

 

Digging a bit further by switching the logging mode to DEBUG on both sides, on the Server I'll see the following message:

DEBUG: sending file to client, filename=C:\Users\Luc\test.txt

A few times I've also seen the following message on the Server instead of the above:
DEBUG: failed to get drag file name from OLE

On the Client I'll see:
DEBUG: drag drop not enabled, ignoring drag info.

and then upon returning to the server on the Client it will show:
DEBUG: file transmission interrupted

... Which makes no sense given supposedly "drag drop not enabled".

 

On the server I do have the "Enable drag and drop file transfers" checkbox checked. And on the client it's set to "Auto config".

 

One additional thing I noticed, if on the server you "Save configuration as..." to a file, I don't see anything in the file about the drag and drop checkbox, whether it's checked or not.

 

Luc

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this