Sign in to follow this  
Danny Suls

Typing diacritics via US international keyboard doesn't work

3 posts in this topic

Setup: Linux (Ubuntu 14.04 64-bit) server, Windows 10 client, both running Synergy stable 1.8.2. On my Windows client (laptop), I'm unable to type diacritics (e.g. ë, á) via the dead keys using the US international keyboard. It works fine when I use the physical keyboard from the laptop, it doesn't work when I use the shared keyboard connected to the Linux Synergy server. This is the actual behavior I see: when I type a relevant "dead key" (e.g. ', "), I see no character appearing (which is correct), but the next character I type doesn't get any added symbol / accent (e.g. I get e instead of ë when typing "+e).

Share this post


Link to post
Share on other sites

Many other symbols don't work:

SHIFT + " then u for ü

SHIFT + ~ then n for ñ

RIGHT ALT + n for ñ

RIGHT ALT + a for á

RIGHT ALT + , for ç

 

No one works!

I tried many of the other US Int keyboards with no luck. I guess the problem is Synergy doen't send the Right ALT properly to the Windows machines.

Share this post


Link to post
Share on other sites

I think this is part of a larger problem. Modifier keys don't work some others, like the arrows.

 

Try setting keyboard shortcuts from system preferences and then compare if the shortcuts actually do their assigned actions.

Share this post


Link to post
Share on other sites
I think this is part of a larger problem. Modifier keys don't work some others, like the arrows.

 

Try setting keyboard shortcuts from system preferences and then compare if the shortcuts actually do their assigned actions.

 

Yes, you are right. Just today, i realized the command to edit the last Skype comment (in the client, not the Synergy server) i did (ctrl + up arrow) sometimes doesn't work.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this