Stuart Walker

Win7 (server) lock screen loses focus to (client) screen

7 posts in this topic

and I can't get it back! Hi folk I have very recently upgraded to 1.8, and I now find that if my Windows 7 (server) is on the lock screen, and I accidentally move my mouse across to the client screen (Centos 7, with Synergy 1.8 also) the focus moves to the client PC and I can't get it back! The mouse cursor on the Windows PC sits on the extreme left side (where the client is) and does not move, and on the client PC the mouse cursor can be briefly glimpsed whizzing across the screen, and then disappears. The CTRL-ALT-DEL combo will bring up the password prompt on the Win7 PC, but all other keystrokes go to the client (Centos) PC until I kill Synergy on the client. (pkill synergy). Took me about half an hour to twig what was happening the first time, including calling the corporate help desk :) Suggestions/fixes welcome! Cheers, Stuart

Share this post


Link to post
Share on other sites

this is happening to me too. Ubuntu 16.04

 

mine goes from the server (win8.1) to the ubuntu guest top right corner, have to kill the service on the guest to fix it.

 

 

wrote this for my box to kill all of the processes then restart it after a minute so that I can login to the server and keep working.

 

 

#!/bin/bash
killall -v synergyc
killall -v synergy

sleep 1m

synergyc -f --enable-crypto -n  &

 

 

not sure if that helps get around it until they get it fixed...

sadly it only works if you have ready access to the client keyboard like I do and can switch over and run it before trying to unlock the server.

Share this post


Link to post
Share on other sites

This is still occurring with version 1.8.5-stable-a18eba7

 

Server: Windows 8.1 Pro

Client: Windows 10

 

Thanks,

 

-- Mark

Share this post


Link to post
Share on other sites

I am seeing the issue on Windows 8.1 (Server) to an EL Captain Mac (Client). I now just leave the client software searching and only activate the server software if I need to connect to the other machine. Symptoms are as Stuart describes for myself as well.

Share this post


Link to post
Share on other sites

I'm having the same issue. In my case I'm using Windows 10 Professional on both machines. If I boot up the host and am on the lock screen and accidentally then move over to the client, I can't get back to the host. The mouse stays locked on the client. I have to stop synergy on the client control then returns to the host.

 

Version 1.8.5-stable-a18eba7 on both machines.

 

Greg

Share this post


Link to post
Share on other sites

I'm having a somewhat similar problem.

 

I'm running the server on a Win10 machine, and my clients are a MacBook Pro and a Mac Tower (both running OS X Yosemite). The problem happens when I initiate the lock screen on the Win10 server (which, by the way, the key stroke {command-L} was being sent from the Mac tower client back to the Win10 server - I was trying to focus the location bar on Chrome in OSX).

 

Once I unlock the screen on Win10, my mouse and keyboard are still "connected" to the Win machine, but it kills the connection to the clients. Restarting the apps on all machines does not reinstate the connections. I have to shut down each machine, reboot, then restart Synergy on each to get the connections back up and running. I am not using SSL on any machine due to the fact SSL doesn't play nice with Win and OSX (according to my last memory from talking to Symless support about 15 months ago).

 

Overall, this is not a very efficient way of handling this problem. Should I try using SSL? Are there some settings that I can adjust to make sure that certain commands don't automatically get sent to the server?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now