James Walker

SSL problem on Mac client

8 posts in this topic

Version 1.8.2 is not working on the latest developer beta of Mac OS 10.12 Sierra, build 16A286a. It was working with previous beta builds. [2016-08-11T17:39:16] INFO: OpenSSL 1.0.2 22 Jan 2015 [2016-08-11T17:39:17] ERROR: ssl error occurred (generic failure) [2016-08-11T17:39:17] ERROR: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol [2016-08-11T17:39:17] ERROR: failed to connect secure socket [2016-08-11T17:39:18] NOTE: disconnected from server [2016-08-11T17:39:27] ERROR: exception on thread 0x00000003: <unknown> libc++abi.dylib: terminating with uncaught exception of type std::runtime_error: event queue is not ready within 5 sec Edited by Guest

Share this post


Link to post
Share on other sites
I am seeing the exact same thing but on only one of my four machines. My server is still connected to a PC and one other MAC with no issues. I have one Mac that will not connect and I get the exact same message as below. I have tried to unisntall and reinstall several times with same results.

Share this post


Link to post
Share on other sites
A bit more information that I should have mentioned before: The Sierra machine is set up as a client. The server is a Mac with OS 10.7.5, also with Synergy 1.8.2.

Share this post


Link to post
Share on other sites

Updated Win10 (Synergy server) to 1.8.3

Updated Mac OS 10.12 (Synergy client) as well, but was unable to connect (ERROR: failed to connect secure socket)

Downgraded Mac client to 1.8.2, and was able to connect normally.

Share this post


Link to post
Share on other sites

Same error for me.

Server Windows 7 32-bit Synergy version 1.8.3, Client MBP Yosemite 10.10 Synergy version 1.8.3 fails with this error.

I've upgraded my Mac to Sierra 10.12, same error with Synergy version 1.8.3.

Downgrading Synergy client back to 1.7.6 works (connecting to 1.8.3 server on my Windows PC).

Share this post


Link to post
Share on other sites

Same problem, same solution.

 

Server MacOSX 10.11.06 with Synergy 1.8.5

and Client MacOSX 10.11.06 with 1.8.5 did not work

 

downgraded to 1.8.2 on the Client and it works fine so far.

Share this post


Link to post
Share on other sites

Had the same problem with 1.8.5 update. Couldn't find install for 1.8.2 for Mac. Had an old installer for Windows and downgraded, but could only find 1.7.5 for Mac. Downgraded to that and it didn't solve it. Tried making sure my OpenSSL was up to date. Didn't fix it. Even tried a more recent "nightly build" to see if the issue had been resolved. Still no dice. Nothing helpful in the log.

 

Been several days now without Synergy since finally updating to 1.8.5. Very frustrating.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now