Sign in to follow this  
Vincent Ottinger

Mouse "disappear" (Windows 10)

4 posts in this topic

Hi, (sorry... i'm french speaking...) I just bought and installed the new version of Synergy. 1.8.2. My server is a Surface Book Pro (scree resolution is 3000x2000). My client is a desktop with a resolution 2560x1440. Both are with Windows 10 64bits. When I try to switch my mouse from the server to the client, "nothing" special appear, but mouse is "locked". When I clic, the opened window on the client is reduced, then opened, then reduced, then.... I have to stop the Synergy service from the client side, with the primary mouse. Then I recover the mouse in my server. Do you have any idea ? Thanks for you help. Vincent

Share this post


Link to post
Share on other sites
I'm having the same problem. Server is a Dell Laptop running Windows 10 64bit and the client is a Surface Pro 3 also running Windows 10 64bit. I have two monitors hooked up to the laptop and then the Surface Pro is just below them. If I try to configure the layout of the screens like this I can't event get the mouse to switch over to the client. If I set the client to be on the left of the server I can get the mouse to switch but it locks the mouse on the server and the clients mouse cursor seems to be locked in the upper right corner of the screen. Once there clicking buttons seem to work (right click brings up the context menu) and the keyboard seems to work but I can never move my mouse anywhere. To get it to go back to the server I have to stop the service on the client. Any help would be great! Thanks, Steve

Share this post


Link to post
Share on other sites
i have the same problem. sharing it with the big monitor but mouse doesnt work. any fix for this?

Share this post


Link to post
Share on other sites

I believe I'm having the same issue. Mouse gets locked in top left corner of client screen.

Share this post


Link to post
Share on other sites

This is often related to a Window's feature, called DPI scaling. You will need to disable this for Synergy, here are the exact steps:

 

Bring up your Start menu/screen

Search for and/or click on "This PC" (this is the name in Windows 8)

Open the C: drive

Open Program Files

Open the Synergy folder

Right click on "synergys.exe" and click "Properties"

Switch to the "compatibility" tab

Click "Change Settings for all users" (synergys can run as a different user)

Click the checkbox for "Deactivate scaling for high DPI value" (above "run as admin")

Click "OK"

Open your Synergy app the usual way (from the Start screen, you can just type synergy) and click "Apply" or "Stop"/"Start"

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this