Sign in to follow this  
jeff milton

crashes when moving to server with anythign in the clipboard

2 posts in this topic

Since installing 1.7.6 I am experiencing crashing whenever there is anything in the clipboard from the client, and I move the mouse from the client to the server... then synergyc crashes. Is this just me or are others experiencing this? The debug output on the crash is the following /build/synergy/src/synergy-1.7.6-stable/src/lib/server/Server.cpp,815 synergys: /build/synergy/src/synergy-1.7.6-stable/src/lib/synergy/Clipboard.cpp:72: virtual bool Clipboard::open(IClipboard::Time) const: Assertion `!m_open' failed. Here is the core dump when it crashes Process 11626 (synergys) of user 1000 dumped core. Stack trace of thread 11626: #0 0x00007f12d9b8d295 raise (libc.so.6) #1 0x00007f12d9b8e6da abort (libc.so.6) #2 0x00007f12d9b86297 __assert_fail_base (libc.so.6) #3 0x00007f12d9b86342 __assert_fail (libc.so.6) #4 0x0000000000498e73 _ZNK9Clipboard4openEj (synergys) #5 0x0000000000498015 _ZN10IClipboard4copyEPS_PKS_j (synergys) #6 0x0000000000492011 _ZNK14ClientProxy1_012getClipboardEhP10IClipboard (synergys) #7 0x00000000004892cf _ZN6Server18onClipboardChangedEP15BaseClientProxyhj (synergys) #8 0x000000000044ea9a _ZN10EventQueue13dispatchEventERK5Event (synergys) #9 0x000000000045158c _ZN10EventQueue4loopEv (synergys) #10 0x0000000000458ada _ZN9ServerApp8mainLoopEv (synergys) #11 0x0000000000454eb5 _ZN3App14daemonMainLoopEiPPKc (synergys) #12 0x0000000000443b4a _ZN14ArchDaemonUnix9daemonizeEPKcPFiiPS1_E (synergys) #13 0x00000000004563be _ZN9ServerApp8runInnerEiPPcP13ILogOutputterPFiiS1_E (synergys) #14 0x00000000004556d9 _ZN3App3runEiPPc (synergys) #15 0x0000000000442982 main (synergys) #16 0x00007f12d9b7a741 __libc_start_main (libc.so.6) #17 0x0000000000442b49 _start (synergys) Stack trace of thread 11627: #0 0x00007f12db219c97 do_sigwait (libpthread.so.0) #1 0x00007f12db219d0d sigwait (libpthread.so.0) #2 0x0000000000448b33 _ZN20ArchMultithreadPosix19threadSignalHandlerEPv (synergys) #3 0x00007f12db210484 start_thread (libpthread.so.0) #4 0x00007f12d9c416dd __clone (libc.so.6) Stack trace of thread 11628: #0 0x00007f12d9c386cd poll (libc.so.6) #1 0x0000000000447994 _ZN14ArchNetworkBSD10pollSocketEPN12IArchNetwork9PollEntryEid (synergys) #2 0x00000000004aa7cf _ZN17SocketMultiplexer13serviceThreadEPv (synergys) #3 0x00000000004ac893 _ZN6Thread10threadFuncEPv (synergys) #4 0x0000000000449a83 _ZN20ArchMultithreadPosix12doThreadFuncEP14ArchThreadImpl (synergys) #5 0x0000000000449b5b _ZN20ArchMultithreadPosix10threadFuncEPv (synergys) #6 0x00007f12db210484 start_thread (libpthread.so.0) #7 0x00007f12d9c416dd __clone (libc.so.6) Stack trace of thread 11845: #0 0x00007f12d9c386cd poll (libc.so.6) #1 0x00007f12d993d8e0 n/a (libxcb.so.1) #2 0x00007f12d993f39f n/a (libxcb.so.1) #3 0x00007f12d993f4b2 xcb_wait_for_reply (libxcb.so.1) #4 0x00007f12daaff727 _XReply (libX11.so.6) #5 0x00007f12daae5d21 XGetSelectionOwner (libX11.so.6) #6 0x000000000046a1e9 _ZNK17XWindowsClipboard18motifLockClipboardEv (synergys) #7 0x000000000046a558 _ZNK17XWindowsClipboard4openEj (synergys) #8 0x0000000000498015 _ZN10IClipboard4copyEPS_PKS_j (synergys) #9 0x0000000000485b0a _ZN6Server19sendClipboardThreadEPv (synergys) #10 0x00000000004ac893 _ZN6Thread10threadFuncEPv (synergys) #11 0x0000000000449a83 _ZN20ArchMultithreadPosix12doThreadFuncEP14ArchThreadImpl (synergys) #12 0x0000000000449b5b _ZN20ArchMultithreadPosix10threadFuncEPv (synergys) #13 0x00007f12db210484 start_thread (libpthread.so.0) #14 0x00007f12d9c416dd __clone (libc.so.6)

Share this post


Link to post
Share on other sites
FYI compiling the nightly build synergy-master-beta-2ed3d26-Source.tar.gz works, however, I can only compile the synergys. when I try to compile the while thing I get... $./hm.sh conf Mapping command: conf -> configure cmake version 3.5.2 CMake suite maintained and supported by Kitware (kitware.com/cmake). Entering dir: build/release CMake command: cmake -G "Unix Makefiles" -DCMAKE_BUILD_TYPE=Release ../.. -- Configuring done -- Generating done -- Build files have been written to: /store/jw/src/synergy-master-beta-2ed3d26-Source Going back to: /store/jw/src/synergy-master-beta-2ed3d26-Source Error: Could not get revision, git error: 128 $./hm.sh build 100%] Linking CXX executable ../../../../../bin/unittests [100%] Built target unittests Going back to: /store/jw/src/synergy-master-beta-2ed3d26-Source Make GUI command: make -w Entering dir: src/gui make: Entering directory '/store/jw/src/synergy-master-beta-2ed3d26-Source/src/gui' make: *** No targets specified and no makefile found. Stop. make: Leaving directory '/store/jw/src/synergy-master-beta-2ed3d26-Source/src/gui' Going back to: /store/jw/src/synergy-master-beta-2ed3d26-Source Error: make -w failed with error: 512 [[email protected] synergy-master-beta-2ed3d26-Source]$ So, just to get the server working I ran ./configure ./make synergys and that gave me a working server

Share this post


Link to post
Share on other sites

This is happening every time and totally locks up my windows 10 system that is working as the synergy server. It happens when I cut a large amount of data to the clipboard (Like a screenshot).

 

The whole system freezes and a reboot is required.

 

If this is not fixed then synergy will be removed as no application should freeze the whole OS. Talk about a time waster.

 

I am on Version 1.8.2 stable 36cd521

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this