Sign in to follow this  
Jackson Eyton

Mouse Movement issue only Win10->Ubuntu

1 post in this topic

Hey guys, I am having an issue with my mouse here. I was able to setup my win10 machine as the server and successfully connected my ubuntu 16.04 machine. I setup hotkeys for switching as I was unable to get screenedge to work. When I switch to the Ubuntu machine I can use the keyboard without issue, however when I move the mouse at all it jumps to the upper left corner of the screen and will not move from that point. I verified the mouse clicks do work as a maximized window's Close button lands right in that corner and I was able to close this. I enabled Debug logging on both machines, the following is the log from the server, I was unable to notice any issues in the logs from either machine: [code][2016-06-30T14:30:54] DEBUG: getting elevated token, elevation required [2016-06-30T14:30:54] DEBUG: processes in session 1: csrss.exe, winlogon.exe, dwm.exe, nvxdsync.exe, nvvsvc.exe, NvStreamUserAgent.exe, conhost.exe, sihost.exe, taskhostw.exe, explorer.exe, RuntimeBroker.exe, RemindersServer.exe, ShellExperienceHost.exe, SearchUI.exe, NvBackend.exe, svchost.exe, nvtray.exe, ApplicationFrameHost.exe, RAVCpl64.exe, LWEMon.exe, XBoxStat.exe, FaceLift_x64.exe, Steam.exe, Amazon Music Helper.exe, googledrivesync.exe, SpotifyWebHelper.exe, ROCCATPowerGrid.exe, Skype.exe, ScpTrayApp.exe, iusb3mon.exe, fontdrvhost.exe, jusched.exe, chrome.exe, chrome.exe, Monitor.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, googledrivesync.exe, chrome.exe, steamwebhelper.exe, OSD.exe, PrivacyIconClient.exe, jucheck.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, SettingSyncHost.exe, SystemSettings.exe, chrome.exe, mstsc.exe, lync.exe, CCleaner64.exe, CCleaner64.exe, SkypeHost.exe, chrome.exe, explorer.exe, dllhost.exe, synergy.exe, chrome.exe, chrome.exe, [2016-06-30T14:30:54] DEBUG: found winlogon.exe in session 1 [2016-06-30T14:30:54] DEBUG: got token 1664, duplicating [2016-06-30T14:30:54] DEBUG: duplicated, new token: 1652 [2016-06-30T14:30:54] INFO: starting new process [2016-06-30T14:30:54] DEBUG: launched syntool to check active desktop [2016-06-30T14:30:54] INFO: activeDesktop:Default [2016-06-30T14:30:54] DEBUG: processes in session 1: csrss.exe, winlogon.exe, dwm.exe, nvxdsync.exe, nvvsvc.exe, NvStreamUserAgent.exe, conhost.exe, sihost.exe, taskhostw.exe, explorer.exe, RuntimeBroker.exe, RemindersServer.exe, ShellExperienceHost.exe, SearchUI.exe, NvBackend.exe, svchost.exe, nvtray.exe, ApplicationFrameHost.exe, RAVCpl64.exe, LWEMon.exe, XBoxStat.exe, FaceLift_x64.exe, Steam.exe, Amazon Music Helper.exe, googledrivesync.exe, SpotifyWebHelper.exe, ROCCATPowerGrid.exe, Skype.exe, ScpTrayApp.exe, iusb3mon.exe, fontdrvhost.exe, jusched.exe, chrome.exe, chrome.exe, Monitor.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, googledrivesync.exe, chrome.exe, steamwebhelper.exe, OSD.exe, PrivacyIconClient.exe, jucheck.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, SettingSyncHost.exe, SystemSettings.exe, chrome.exe, mstsc.exe, lync.exe, CCleaner64.exe, CCleaner64.exe, SkypeHost.exe, chrome.exe, explorer.exe, dllhost.exe, synergy.exe, chrome.exe, chrome.exe, syntool.exe, conhost.exe, [2016-06-30T14:30:54] DEBUG: did not find logonui.exe in session 1 [2016-06-30T14:30:54] DEBUG: getting non-elevated token [2016-06-30T14:30:54] DEBUG: duplicated, new token: 1688 [2016-06-30T14:30:54] INFO: starting new process [2016-06-30T14:30:54] INFO: drag and drop enabled [2016-06-30T14:30:54] DEBUG: opening configuration "C:/Users/Jackson/AppData/Local/Temp/qt_temp.X12064" [2016-06-30T14:30:54] DEBUG: configuration read successfully [2016-06-30T14:30:54] DEBUG: plugins dir: C:\Users\Jackson\AppData\Local\Synergy\Plugins [2016-06-30T14:30:54] DEBUG: plugins dir is empty: C:\Users\Jackson\AppData\Local\Synergy\Plugins\*.dll [2016-06-30T14:30:54] DEBUG: DPI: 150% [2016-06-30T14:30:54] DEBUG: physical resolution: 4608, 2592 scaled resolution: 3072, 1728 [2016-06-30T14:30:54] DEBUG: screen shape: 0,0 4608x2592 (multi-monitor) [2016-06-30T14:30:54] DEBUG: window is 0x003803ae [2016-06-30T14:30:54] DEBUG: using desktop for drop target: C:\Users\Jackson\Desktop [2016-06-30T14:30:54] DEBUG: adopting new buffer [2016-06-30T14:30:54] DEBUG: opened display [2016-06-30T14:30:54] DEBUG: active sides: 4 [2016-06-30T14:30:54] DEBUG: active sides: 4 [2016-06-30T14:30:54] DEBUG: accepted ipc client connection [2016-06-30T14:30:54] DEBUG: desk Default window is 0x003603ac [2016-06-30T14:30:54] DEBUG: switched to desk "Default" [2016-06-30T14:30:54] DEBUG: desktop is now accessible [2016-06-30T14:30:54] DEBUG: registered hotkey Shift+Alt+Right (id=ef53 mask=0005) as id=1 [2016-06-30T14:30:54] DEBUG: registered hotkey Shift+Alt+Up (id=ef52 mask=0005) as id=2 [2016-06-30T14:30:54] DEBUG: registered hotkey ScrollLock (id=ef14 mask=0000) as id=3 [2016-06-30T14:30:54] NOTE: started server, waiting for clients [2016-06-30T14:30:54] DEBUG: event queue is ready [2016-06-30T14:30:54] DEBUG: add pending events to buffer [2016-06-30T14:30:54] DEBUG: screen "Jackson-PC" shape changed [2016-06-30T14:30:54] DEBUG: start ipc handle data [2016-06-30T14:30:54] DEBUG: ipc read: IHEL [2016-06-30T14:30:54] DEBUG: finished ipc handle data [2016-06-30T14:30:54] DEBUG: ipc hello, type=node [2016-06-30T14:30:54] INFO: watchdog status: ok [2016-06-30T14:30:55] NOTE: accepted client connection [2016-06-30T14:30:55] DEBUG: received client "jack-ThinkPad-SL410" info shape=0,0 1366x768 at 1365,0 [2016-06-30T14:30:55] DEBUG: active sides: 4 [2016-06-30T14:30:55] NOTE: client "Jack-ThinkPad-SL410" has connected [2016-06-30T14:30:55] DEBUG: started process, session=1, elevated: no, command="E:/Program Files/Synergy/synergys.exe" -f --no-tray --debug DEBUG --name Jackson-PC --ipc --stop-on-desk-switch --enable-drag-drop --profile-dir C:\Users\Jackson\AppData\Local -c C:/Users/Jackson/AppData/Local/Temp/qt_temp.X12064 --address :24800 --res-w 4608 --res-h 2592 --prm-wc 2304 --prm-hc 1296 [2016-06-30T14:30:58] INFO: switch from "Jackson-PC" to "Jack-ThinkPad-SL410" at 1365,0 [2016-06-30T14:30:58] INFO: leaving screen [2016-06-30T14:30:58] DEBUG: open clipboard [2016-06-30T14:30:58] DEBUG: close clipboard [2016-06-30T14:30:58] INFO: screen "Jackson-PC" updated clipboard 0 [2016-06-30T14:30:58] DEBUG: open clipboard [2016-06-30T14:30:58] DEBUG: close clipboard [2016-06-30T14:30:58] INFO: screen "Jackson-PC" updated clipboard 1 [2016-06-30T14:31:02] INFO: switch from "Jack-ThinkPad-SL410" to "Jackson-PC" at 1020,1191 [2016-06-30T14:31:02] INFO: entering screen[/code] *Edit* I replaced the physical mouse to test but the issue persists.

Share this post


Link to post
Share on other sites
An update to this, I was able to get a hold of the 1.3.8 ubuntu package and reinstalled with that version. Downgrade from the current version. This has resolved all of the issues I had.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this