Zach Estepp

WARNING: failed to connect to server: Timed Out

14 posts in this topic

I don't know what to do. I Just bought synergy yesterday and have not figured out how to get this to work. I've messed with the fire wall, adding exceptions and completely turning it off to no avail. I've turned off my antivirus on both machines. The machines I'm trying to use synergy on are a Windows 10 pc(Server), and my Macbook air running OS X El Capitain 10.11.5(Client). They're both on the same network and I'm using a wireless network for both. On the client PC(Mac) I always get "WARNING: failed to connect to server: Timed Out". I don't understand why. I believe my server PC is setup correctly, Maybe I'm wrong. I have no idea.

Share this post


Link to post
Share on other sites
Don't expect a reply for a long time, if you even get one. I have this problem too. Not solved for 6 months.

Share this post


Link to post
Share on other sites
I've had the same issue - noticed that installing a previous version helped. Updates stable updates seem to cause problems for me, more successful to be 1 version behind. Am currently having this problem, realized that both PCs are running latest version of Synergy - decided to try the beta version that didn't work. Tried version 1.7.4 and that didnt' work either. Questioning what I paid for - love how there are no answers in the forum, this is extremely frustrating.

Share this post


Link to post
Share on other sites
Alright, I may have found a way to identify the issue. For some reason the Server Configuration was wrong - here's what I did so far. Downloaded version 1.7.3 (haven't updated to 1.7.6 yet) Set up based on how I want things to be - Computer_1=Server, Computer_2=Client, nothing, can't get the thing to work at all. No dice. Got frustrated, paid the $20 upgrade for support, wrote several tickets and continued to try and figure it out on my own. As an experiment I switched the client and server around, now Computer_1=Client, Computer_2=Server, was prompted with message asking where I wanted my monitor to appear and noticed that Computer_1 had a new name Computer_1_X - seemed to solve my issue. I suggest trying the same steps, reverse the configuration, see if you can get the mouse to work that way. Will update to 1.7.6 later and let you know if this solves the problem for me again. Good luck, feel free to message me if you have any questions or need additional clarification on the above.

Share this post


Link to post
Share on other sites
Hi folks, I had the same issue for half a day today and it turned out that my host PC (Windows 10) had quite a few IP addresses associated with it, only one of which is my actual local network IP address. Basically I have Virtualbox installed on it which gave the host a false IP address that any virtual machine can access. Synergy on my client PC (Fedora 24) was trying to connect to that [b]Virtualbox/false[/b] IP address and not the actual one! So I manually entered my host's correct IP address on my client side, instead of typing the host name or auto-connecting. In this case it was Virtualbox for me, but there may well be some software on your host that is giving it a false IP address. Give my solution a try and let me know! Also feel free to ask for more details or help :)

Share this post


Link to post
Share on other sites
This worked for me. I was trying to set my Client (my Mac) to whichever IP was bolded among the list of IP options on the server side (my Win 10 PC) once I set the client to the IP I knew was correct for my network, it worked fine. Thanks for the help!! [quote="Bhavesh Kakwani"]Hi folks, I had the same issue for half a day today and it turned out that my host PC (Windows 10) had quite a few IP addresses associated with it, only one of which is my actual local network IP address. Basically I have Virtualbox installed on it which gave the host a false IP address that any virtual machine can access. Synergy on my client PC (Fedora 24) was trying to connect to that [b]Virtualbox/false[/b] IP address and not the actual one! So I manually entered my host's correct IP address on my client side, instead of typing the host name or auto-connecting. In this case it was Virtualbox for me, but there may well be some software on your host that is giving it a false IP address. Give my solution a try and let me know! Also feel free to ask for more details or help :)[/quote]

Share this post


Link to post
Share on other sites

I had this problem too. Very frustrating since you don't get much feedback to work on. :evil:

 

It seems that there are several causes for this problem. In my case the underlying cause was trying to connect a WiFi laptop to a cabled desktop server but the router blocks it. It seems that most routers by default block WiFi connections like Synergy tries to set up. Source: https://groups.google.com/forum/#!topic ... xApVi7v8mo

 

Identify if the is the case for you: Start a MS-DOS prompt and enter

ping otherPCsIPhere

. The server should be able to to ping/see the client and vice versa.

 

Fix: Get a cable or figure out how to change this specific setting in your router or access point.

Share this post


Link to post
Share on other sites

This thing is fracking garbage. I want my money back. I don't need the frustration. It is easier to just move my mouse and keyboard USB connectors manually. I am going to look for review sites and give these people the big ripoff reward that they are deserving of. You should do the same!

Share this post


Link to post
Share on other sites

I had this problem trying to connect a OS X (11.6) client to a Windows 10 host. My client was connected via wifi and my host via ethernet. I had to open the ethernet connection's settings in Windows and turn on the "Make this PC Discoverable" setting. Then it worked.

Share this post


Link to post
Share on other sites

Guys I had the same issue but I figured out. Make sure on the client computer, put in the correct server ID as shown in this link:

https://kb.wisc.edu/helpdesk/page.php?id=27309

 

It must be the "preferred Server ID". The cmd window can be opened by following the instructions in the link above.

 

And also sometimes it won't work again just because the preferred server ID actually will change! Just to make sure you open cmd again and input the latest preferred ID server ID shown on our server cmd window.

Share this post


Link to post
Share on other sites

I had this issue recently and realised that I had a VirtualBox connection set up and Synergy was trying to use it's IP instead of my computers.

Just make sure you're connecting to the right IP if multiple are showing up as the host.

Share this post


Link to post
Share on other sites

I had the same issue today. It turns out that the latest Windows 10 upgrade (Windows 10 Pro, 10.0.10586 Build 10586) changed the Firewall settings. In my case, the Private Profile, Inbound Connections, was blocked. Changed this to "Allow" and Synergy works again.

 

Besides the failed to connect error, another symptom was that I could ping the client PC from the server PC, but not the other way around.

 

I hope this helps someone with the same problem.

Share this post


Link to post
Share on other sites

I have a Windows 7 Enterprise SP1 machine (as client) and an Ubuntu 14.04 LTS machine (as server).

 

I attempted to upgrade to version 1.8.3 and the client was not able to connect to the server (kept timing out).

 

I verified that I could ping the server from the client and that there were no firewall issues, but nothing worked.

 

I downgraded both machines to Synergy version 1.8.2 and now have connectivity with no other changes to either machine.

 

Can anyone tell me what changed in 1.8.3 that may have caused this? Is there some new security or change in the security?

 

Any help greatly appreciated.

 

DanG

Share this post


Link to post
Share on other sites

It turns out this is a known problem caused by the SSL plugin being out of date.

 

Check out the 1.8.3 announcement thread Synergy 1.8.3 released for more details, but the fix is to go through the setup wizard which will update the plugin.

 

After that, I'm very happy with this release. It fixes the problem of bumping me off of Windows when privilege elevations occur which was really annoying.

Share this post


Link to post
Share on other sites

The following fixed it for me:

 

Go to the Synergy Interface --> FILE EDIT WINDOW HELP

 

Click Edit --> Settings --> change port from 80 to 24800

 

This is the default port for Synergy --

 

Hope this helps

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now