Carol Roberts

Synergy Upgrade 1.7.2-stable Not Working

11 posts in this topic

I have upgraded to the yet new upgrade, and still my MAC OS X 10.6.8, is not connecting to my PC. Synergy is running on my PC, but is waiting to connect to my MAC, but says "connection was refused". When I start Synergy on my MAC, I get an error message of "Exit Code of 1" - NOTE: starting server NOTE: config file: /var/folders/bw/bwEfr8VBHB4maWiCKybc+++++TI/-Tmp-/qt_temp.J17726 NOTE: log level: INFO INFO: drag and drop enabled ERROR: failed to load plugin: libns.dylib FATAL: An error occurred: dlopen(/Users/carolroberts/Library/Synergy/Plugins/libns.dylib, 1): Library not loaded: /usr/lib/libcurl.4.dylib Referenced from: /Users/carolroberts/Library/Synergy/Plugins/libns.dylib Reason: Incompatible library version: libns.dylib requires version 7.0.0 or later, but libcurl.4.dylib provides version 6.0.0 NOTE: stopping synergy desktop process Needless to say, I'm very frustrated. Did try deleting and reinstalling program......same ol ...

Share this post


Link to post
Share on other sites
yeah, just upgraded and synergy is dead in the water. :( Update: disabling SSL fixed it for me.

Share this post


Link to post
Share on other sites
Yeah same with me. I tried disabling the SSL but that did not work. Does anyone know how I can roll back my version to the previous? I unfortunately deleted my older setup.exe versions.

Share this post


Link to post
Share on other sites
I've tried installing older versions, and still won't work. Very frustrated. Don't want to keep coming back here to find solutions. The creator should send me a correct install version to get this fixed. I can't operate like this at work.

Share this post


Link to post
Share on other sites
Hey guys! Sorry about that, we messed up with 10.6. Here's the bug report which we intend on fixing: https://github.com/synergy/synergy/issues/4648 For the meantime, yes the workaround is to disable SSL via Settings (sucks, I know). Please subscribe to that issue on Github so you get a notification when its fixed (we hope this'll be within a few weeks). Thanks, Nick

Share this post


Link to post
Share on other sites
[quote="tomwilsonacn"]How do you disable SSL? I am new to this and a bit confused.[/quote] 1. Edit -> Settings 2. Uncheck "Use SSL..."

Share this post


Link to post
Share on other sites
Ive disabled SSL on my PC, but not finding it on my MAC. Perhaps MAC doesn't have this feature? A couple of weeks you say to resolve this matter? Can I please get the update here on Synergy's site (hopefully this thread), rather than having to sign up for another post account. Thanks

Share this post


Link to post
Share on other sites
I installed 1.7.2 and Synergy quit working. I unchecked SSL and rebooted. On the server machine Synergy started and pretty much locked up the whole system. Synergy says it was not responding. I waited about 5 minutes to see if it recovered. No. I closed it and then the mouse started moving normally. While Synergy was locked, it appeared that Synergy was using almost all the CPU. I closed it, reopened it unchecked the SSL and reconfigured and it started working again. Whew! I worked all day yesterday without it. What a pain. SSL is not an issue here but I would be good to default to no SSL if it is not going to work for a while.

Share this post


Link to post
Share on other sites
disabling SSL in both 1.7.2 server and client on 10.10.3 got Synergy working for me again.

Share this post


Link to post
Share on other sites
I'm not sure if this will help anyone, but I find that that setting half functional config options in advance solves a lot of problems in the long run. If you can find the Synergy.conf file (I am not sure where it is on a Mac) then you should be able to edit this line: [code]cryptoEnabled=false[/code] I'm assuming if it says "false" then the next time Synergy starts SSL will be disabled, no need to mess with the checkbox. It's the next best thing to having it off by default. I hope the Mac config is the same as Linux otherwise I have no idea what I am talking about! Hope this helps someone. openssl has always been a necessary evil. :evil:

Share this post


Link to post
Share on other sites
The Synergy.conf you're referring to on Linux holds the settings for the GUI, not Synergy itself. You can do the same by pulling up Edit -> Settings and unchecking the checkbox for SSL Encryption. This also applies to other OSes, though on Mac it's found under Synergy -> Preferences.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now