Sean Donahue

Unable to "mouselook" in World of Warcraft

7 posts in this topic

Hi! I've been a user of Synergy for years but resisted upgrading to the latest version for years because of a show-stopping issue I've been facing: I can't "mouselook" in World of Warcraft on my client Mac. By mouselook, I mean holding down the right mouse button and rotating the camera view around my character. It's as if the right mouse button press is being ignored (but does show up in the logs). If I use my attached mouse on the Mac the mouselook feature works perfectly fine. And here's the real kicker, if I downgrade my Mac client all the way to 1.3.8 the mouselook works fine but then I lose the ability to sync my clipboard. I was able to replicate the mouselook behavior on my client with versions 1.6.3 and 1.7.4 (1.4.16 and 1.4.18 Mac OS told me the files were damaged). My setup: Server: Synergy 1.7.6 Windows 8.1 Pro 64 bit MadCatz M.M.O. 7 Gaming Mouse Apple Magic Keyboard (via USB) Client: Synergy 1.7.6 Mac OS X 10.11.5 Magic Mouse (version 1 via bluetooth) No keyboard I've attached my logs of 1.7.6 running on both. Any assistance with getting my client up from 1.3.8 with a functioning mouselook would be greatly appreciated!

Share this post


Link to post
Share on other sites
With these kind of wierd game related issues, try setting hte "Use relative mouse movements" option on the advanced server settings tab as a first thing to try. I've noticed that the way games capture mouse movement (in particular when doing first person things) can often cause issues. Basically, when in a the mouse pointer appears normally (click around etc) it's just behaving like a normal mouse. But, when you want to use the mouse to control looking around (first person game / mouselook etc), where is the actual mouse cursor? It gets hidden and usually the game will grab it and keep it positioned in center screen, then translate any attempted movement of the cursor into the mouselook movements.

Share this post


Link to post
Share on other sites
Thanks for the suggestion! Enabling or disabling 'use relative mouse moves' on the server has no effect: the mouse cursor moves around fine, but when I right click to initiate mouselook, the cursor disappears (as expected) but no movement of the camera.

Share this post


Link to post
Share on other sites
Try locking the cursor to the screen the game is on by pressing "scroll lock". I've just got synergy setup and working again for me (network issues) and remember the steps I took now.

Share this post


Link to post
Share on other sites
Locking the cursor to one screen doesn't change the behavior, I still can't mouselook on my Mac client. And really, even if it did work, it would be a super intrusive workaround. The point is to game on both the client and the server with the cursor seamlessly transversing both screens, not locking and unlocking every time you want to turn or reposition the camera. The most frustrating thing about this is regression. Version 1.3.8 on the Mac client works with mouselook but doesn't work with clipboard reliably.

Share this post


Link to post
Share on other sites
If that doesn't work then I'm out of ideas. It works for me. One thing more that I've noticed is that sometimes if I have a full screen app running on BOTH machines, the scroll lock doesn't actually work. In that scenario I still get the jumpy movement etc. and even with scroll lock enabled, the mouse will move from one screen to another. To see if this is happening for you - try running only 1 full screen game on the client computer and check that the lock is working first, before trying mouse look. I'd say as a final step to try all combinations of cursor locked to screen relative mouse moves. It is a frustrating occurence, but given how different games / apps use the mouse and make assumptions about it it's not surprising that there is some strange edge case behaviour. Did you say this *used* to work for you? If so - when mouse-looking did the cursor not sometimes move off the screen you were controlling?

Share this post


Link to post
Share on other sites
The issue persists with WoW full screen or with it being windowed in all four combinations between the server and client. I'm running 1.3.7 on the Mac because this mouselook isn't working for me and suffering the bugs because of it such as clipboard not syncing. With 1.3.7 mouselook works perfectly fine, it doesn't spin super fast when turning with mouselook (which I have seen on my server but stopping and restarting synergy fixes that) and doesn't go off screen. When I turn on debug mode, Synergy's log is showing that the right or left mouse button is held down and moving, but WoW doesn't move.

Share this post


Link to post
Share on other sites

I am seeing this problem too, none of the typical 'fixes' for this behavior work even with the latest stable 1.8.2 :(

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now