Mathias Körber

constant disconnects

1 post in this topic

I am running 1.7.6 on my mbp (server,Yosemite) and and mac-mini (client,El Capitan) Recently (last 2-3 days) symmetry constantly disconnects. On the client, I see various SSL errors, amon others ERROR: ssl error occurred (system call failure) ERROR: eof violates ssl protocol NOTE: disconnected from server or Error: corrupted clipboard data, expected size 86662732 actual size=xxxxx (always a different number) What gives?

Share this post


Link to post
Share on other sites
May be unrelated, but I was having issues with constant connect/disconnect and getting ssl type errors. I'm on 1.7.6 and had my "client", a Win7 laptop, was offline/remote for a few weeks. When I returned, I decided to reverse my Server/Client, and make the laptop the server. Two issues I found, a 169.254... IP address was listed before my IP laptop's IP address in the configuration window. On research, I found this is possibly related to the wireless network using this range of IPs....and/or Bonjour using it by default. Long story short, that IP when away when I disabled my wireless (I'm on a hardwired LAN). Before that I had done many uninstalls/reinstalls with no luck. In one of the uninstalls, I renamed my C:\Users\<username>\AppData\Local\Synergy directory, thinking maybe something there was causing issues, and that it would reinstall a fresh folder. It did not. It needed the ns.dll in the Plugins folder. there is also an SSL folder which contains the "fingerprints" allowed. A third thing...the "TrustedServer.txt" had an address I didn't recognize, so I removed it and just left the other machine's info (the other fingerprint [i]may[/i] have bee that other IP address??) . It now seems to be working properly. Hope this helps you or someone troubleshoot.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now