Tim Clark

Ubuntu 16.04 LTS broken Synergy 1.6.2

9 posts in this topic

I've just upgraded to Ubuntu 16.04 LTS Desktop and my Synergy is now not connecting. getting this in the log [code] /build/synergy-CUL4K_/synergy-1.6.2/src/lib/client/Client.cpp,149 NOTE: stopping synergy desktop process [/code] I've already tried : - Uninstalling and reinstalling. - Setting debug to level 2, nothing of any value - Running from command line to check for any other errors Any ideas?

Share this post


Link to post
Share on other sites
I am having similar issues. Can't connect to the Synergy server on the windows 7 box from Ubunto 16.04. Error is: [2016-05-02T13:04:58] WARNING: failed to connect to server: Timed out [2016-05-02T13:04:59] NOTE: connecting to '192.168.2.107': 192.168.2.107:24800 [2016-05-02T13:04:59] DEBUG1: connecting to server [2016-05-02T13:05:08] DEBUG2: can't read property 585 on window 0x01000005 [2016-05-02T13:05:08] DEBUG2: can't read property 585 on window 0x05200330 [2016-05-02T13:05:08] DEBUG2: can't read property 585 on window 0x05200330 [2016-05-02T13:05:14] DEBUG1: connection timed out [2016-05-02T13:05:14] DEBUG: retry in 1 seconds [2016-05-02T13:05:14] WARNING: failed to connect to server: Timed out

Share this post


Link to post
Share on other sites
I have the same problem. I just downloaded and installed new version of synergy (64 bit version for ubuntu). File name is synergy-v1.7.6-stable-bcb9da8-Linux-x86_64.deb - but when i tried to install it i see 1.6.2 version number. When i tried to connect i see "incopatible client 1.5" warning. So the problem is : - i downloaded 1.7.6 ubuntu 64 bit version from website - system see 1.6.2 version (ubuntu) - other synergy (windows client with 1.7.6 version) report me connection problem with incopatible version 1.5

Share this post


Link to post
Share on other sites
It's been a couple weeks. Any updates? I'm just switching to 16.04. Also running Mint 17.3 (14.04 core) but getting errors. Seems that it's back to the dreaded SSL encryption issue for me. Works fine in 17.3 and on windows, but everything breaks when I reboot the windows box into 16.04.

Share this post


Link to post
Share on other sites
Ah, I thought I was the only one with this issue. I encounter constant time out errors using the basic version on a 16.04 client connecting to a Win10 server. Bummer.

Share this post


Link to post
Share on other sites
I had the same problem, running the server on Windows machine and the client on Ubuntu 16.04 machine, and I just disabled "Network Security" on the server from the Settings dialog box (untick "Use SSL encription"). More secure way would be to set SSL cetificate on the client machine, and that's my next to-do on the list. More on that: here [url]https://github.com/symless/synergy/wiki/Security#Generating_Certificate_and_Fingerprint[/url] Hope that helps.

Share this post


Link to post
Share on other sites
I ran into the same problem when I reinstalled Ubuntu to 16.04. I was able to get around it though. This is an issue with apt-get grabbing the public version rather than installing the downloaded deb. This is what I did to resolve, and didn't require much sophistry: In a terminal run apt-get purge synergy. accept. double-click and reinstall from the latest downloadable deb. (Be sure ubuntu installer GUI shows the correct version, and not 1.6 again) Launch synergy and register. FIN

Share this post


Link to post
Share on other sites
I am also running Ubuntu 16.04, and am trying to use Synergy (as a client) with Mac OS X 10.11.5 (server) and Windows 10 Build 10245 (client). I have the same problem where I download the deb file for version 1.7.6, it shows 1.7.6 in the installer GUI, but once it is installed, the 'About Synergy' window says it is running version 1.6.2. The main problem with this is that it does not support SSL Encryption, so while it works (after rebooting) with SSL de-selected on the server and other client it is running unsecured. I have tried purging as suggested by Joseph Day, but upon re-installing Synergy it still appears as version 1.6.2. Any other suggestions to resolve this?

Share this post


Link to post
Share on other sites
It's been 3 months with no update from Synergy, is this an attempt to get people to shell out money for tech support that used to be free when you donated? I really don't care. At the very least Synergy should update the people on this board and let them know wtf is going on even if it's just to say we haven't been able to patch yet. Not cool, this program is useless now with Ubuntu 16.04 and I'm not tearing down an encrypted build of Ubuntu to downgrade just so I can use synergy again. No update = lost users.

Share this post


Link to post
Share on other sites
yea, same issue here, and not providing support is not cool... ubuntu server, Mac OS 10.11 client. i attempt to install the 1.7.6 .deb from the site, the installer pops up, version 1.7.6 [attachment=2]Screenshot from 2016-07-18 20-47-37.png[/attachment] i click install and the screen changes to 1.6.2 [attachment=1]Screenshot from 2016-07-18 20-47-47.png[/attachment] i decided to let it install anyway, and when i try to connect the Mac does this awesome thing: [attachment=0]Screen Shot 2016-07-18 at 8.51.52 PM.png[/attachment] i attempted the apt-get purge, no change. UPDATE: so i fixed this, if anyone else has this problem... essentially there was a bug i was not aware of with the GUI installer in ubuntu: http://www.omgubuntu.co.uk/2016/04/ubun ... tall-error once I patched this bug i was ok.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now