Clifton Moog

Synergy + Games + Razer Naga problems.

6 posts in this topic

Hello! On the recommendation of one of the programmers I work with I picked up Synergy for my home setup. After installation it works beautifully and simplifies how I use my computers. 4 of 4 stars there. However once I started using my desktop as I normally would the wheels fell of the cart. All of these problems happen on my desktop (the server). When playing games (in this case World of Warcraft) right clicking the mouse to move the camera causes the camera to spin wildly out of control. The second problem it does not recognize the right and left tilt middle mouse buttons on my mouse. It wouldn't be a huge issue but I have push to talk mapped to one of those buttons. If I stop the synergy server everything works as normal. My set up. The server is a windows 10 x64 machine with two monitors. I am using a Razer Naga 2014 edition mouse. The client is a MacBook Pro running OS X 10.11. I am using the latest version of Synergy. I've looked at a couple of solution for games but those all seem to focus on the client computers not the server. I've also been unable to find anything for the mouse. Any suggestions would be very much appreciated.

Share this post


Link to post
Share on other sites

Not an answer.

I have a Dell laptop as a client to my HP laptop.  I am using a Logitech M570 trackball attached to the HP.

When I have World of Warcraft running on both laptops, the mouse works correctly on the HP laptop.  On the Dell laptop, the view spins wildly any time I use the M570 to control the character or the view.  Using the client's local touchpad does not exhibit these issues.

I *SUSPECT* there is an issue / conflict between the virtual mouse driver (if that is how it is implemented) and the touchpad driver, but I have not yet experimented with uninstalling the trackpad driver and disabling it.  I am also going to try installing the M570 driver on the Dell client laptop.

I am using Synergy 1.8.8-stable-25a8cb2.  The server is running Windows 10 Pro 64-bit.  The client is running Windows 7 Professional 64-bit.

My next steps:

1) Uninstall touchpad driver and disable touchpad hardware and test.

2) Install M570 driver on client and test.

3) Combination of steps 1 and 2

4) Install a wired external trackball on client (I despise touchpads for the most part, but use them when necessary - airplanes and the like).

5) Examine DXDiag diagnostic dump to determine if this is a DirectX pointer issue / conflict with the QuickTime pointer interface.

Edited by Walkabout Tigger

Share this post


Link to post
Share on other sites
On 4/25/2016 at 6:15 AM, Clifton Moog said:

Hello! On the recommendation of one of the programmers I work with I picked up Synergy for my home setup. After installation it works beautifully and simplifies how I use my computers. 4 of 4 stars there. However once I started using my desktop as I normally would the wheels fell of the cart. All of these problems happen on my desktop (the server). When playing games (in this case World of Warcraft) right clicking the mouse to move the camera causes the camera to spin wildly out of control. The second problem it does not recognize the right and left tilt middle mouse buttons on my mouse. It wouldn't be a huge issue but I have push to talk mapped to one of those buttons. If I stop the synergy server everything works as normal. My set up. The server is a windows 10 x64 machine with two monitors. I am using a Razer Naga 2014 edition mouse. The client is a MacBook Pro running OS X 10.11. I am using the latest version of Synergy. I've looked at a couple of solution for games but those all seem to focus on the client computers not the server. I've also been unable to find anything for the mouse. Any suggestions would be very much appreciated.

Hi @Clifton Moog. There's an open issue in GitHub for this problem. There are several steps posted there. Although some steps work for others, but some aren't working. Currently, it is labeled to be up in v1.10.

Share this post


Link to post
Share on other sites
2 hours ago, Walkabout Tigger said:

Not an answer.

I have a Dell laptop as a client to my HP laptop.  I am using a Logitech M570 trackball attached to the HP.

When I have World of Warcraft running on both laptops, the mouse works correctly on the HP laptop.  On the Dell laptop, the view spins wildly any time I use the M570 to control the character or the view.  Using the client's local touchpad does not exhibit these issues.

I *SUSPECT* there is an issue / conflict between the virtual mouse driver (if that is how it is implemented) and the touchpad driver, but I have not yet experimented with uninstalling the trackpad driver and disabling it.  I am also going to try installing the M570 driver on the Dell client laptop.

I am using Synergy 1.8.8-stable-25a8cb2.  The server is running Windows 10 Pro 64-bit.  The client is running Windows 7 Professional 64-bit.

My next steps:

1) Uninstall touchpad driver and disable touchpad hardware and test.

2) Install M570 driver on client and test.

3) Combination of steps 1 and 2

4) Install a wired external trackball on client (I despise touchpads for the most part, but use them when necessary - airplanes and the like).

5) Examine DXDiag diagnostic dump to determine if this is a DirectX pointer issue / conflict with the QuickTime pointer interface.

May we please ask to create a different thread instead of posting it in here. Thanks :)

Share this post


Link to post
Share on other sites
On 5/19/2017 at 11:20 AM, Paul Suarez said:

May we please ask to create a different thread instead of posting it in here. Thanks :)

Okay.  I posted it to a new thread here.

Considering the bug in GitHub related to this issue has been opened since 2014, when can I expect some form of resolution, whether that is a working version of Synergy or a refund?

Share this post


Link to post
Share on other sites
On 5/19/2017 at 11:20 AM, Paul Suarez said:

May we please ask to create a different thread instead of posting it in here. Thanks :)

Done.

No response from Support in a week.  When can I expect either some forward progress on the issue in the support queue?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now