Mike Lorenzen

1.7.6 Server (win10) stops

6 posts in this topic

Hello, Wonderful product! When it breaks it's like having the TV remote taken away. Prior version was solid. 1.7.6 locks up the same way several times now with a reboot of server side restoring it. I suspect it has something to do with taking a screen shot into the clipboard on the Win 10 server and then moving the mouse to the client XP Pro machine. Log attached shows some clipboard Win10 Server to WinXPPro Client transfers then the lockup. I pressed scroll thinking I accidentally locked the cursor to the screen but then brought up synergy to find it detected itself not running. The next few lines repeat until rebooted. Screen shot of log attached.

Share this post


Link to post
Share on other sites
I am also seeing same on latest Win10 server/client build. (failed to init synwinhk.dll, another program may be using it) as suggested in the log, rebooting (or just restarting the Synergy service) fixes it. I seemed to be able to replicate the problem by trying to copy/paste data using the Windows clipboard.

Share this post


Link to post
Share on other sites
Pro version. Server is Win10, Client is Mac. Literally now if someone farts, synwinhk stops working.. very disappointing. Even restarting the service on both machines only temporarily resolves the problem, then right back to the error. It's becoming a waste of time to try and KVM these two machines together. :(

Share this post


Link to post
Share on other sites
I found that 1.7.6 server broke my keyboard within the Kaseya remote desktop application, rolling back to 1.7.5 fixed the issue

Share this post


Link to post
Share on other sites
I can confirm that this bug is repeatable for me between two Windows 10 machines. On server, just use built-in Windows Snipping Tool to copy a part of your screen then move the mouse to the client PC, this kills the connection and generates - "[b]ERROR: failed to init synwinhk.dll, another program may be using it[/b]" I hope this info might help. [quote="Karl Marfitt"]I am also seeing same on latest Win10 server/client build. (failed to init synwinhk.dll, another program may be using it) as suggested in the log, rebooting (or just restarting the Synergy service) fixes it. I seemed to be able to replicate the problem by trying to copy/paste data using the Windows clipboard.[/quote]

Share this post


Link to post
Share on other sites
This bug has resurfaced (for the first time for me). [2016-07-11T10:23:06] ERROR: failed to init synwinhk.dll, another program may be using it [2016-07-11T10:23:06] INFO: restarting your computer may solve this error [2016-07-11T10:23:06] FATAL: failed to start server: unable to open screen [2016-07-11T10:23:07] ERROR: failed to launch, error: process immediately stopped [2016-07-11T10:23:07] INFO: backing off, wait=10s, failures=15

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now