Sign in to follow this  
James Osborn

Ctrl+Alt+Delete Oddness Windows 10

1 post in this topic

My Synergy server runs on Mac OS X El Capitan and I connect to a Windows 10 client. I have enabled Ctrl-Alt-Delete support on the client through group policy. It works for unlocking the screen, every time, no problems, but there are a few odd points it would be nice to resolve: [list=1][*]My Windows 10 screen is typically screen locked whenever I am reconnecting. Upon the first Ctrl-Alt-Delete, it correctly calls up the Windows authentication box, but it bunts the Synergy connection. I find myself having to wait 5 seconds or so for the client to reconnect to my Synergy server before I can flick my mouse back onto my client screen and enter my password. I found if I am not logged into Windows 10, or if it is locked due to a previous Remote Desktop connection, then it does not do this (Synergy is not bunted in this case).[/*:m] [*]After entering my password and hitting Enter, it bunts Synergy again. This happens regardless of the prior connection state (fresh login, unlock screen, or re-login after Remote Desktop disconnect). I again have to wait 5 seconds or so until client reconnects to my Synergy server and then I can flick my mouse back to the client screen to get going.[/*:m] [*]Sometimes I can use Ctrl-Alt-Delete to bring up the Windows Lock/Task Manager screen which I typically use to lock my client screen when I step away from my desk. Sometimes it does not seem to pass the Ctrl-Alt-Delete. When it does work however, guess what? It bunts the Synergy client again and I need to wait 5 seconds or so before I can re-enter the client screen to hit the Space bar to lock my screen. I often just use the second keyboard directly attached to the Windows 10 box to do Ctrl-Alt-Delete Space Bar quickly to avoid these delays when I am trying to lock the screen so I can walk away from it.[/*:m][/list:o] None of these are show stoppers. But it would make the whole interaction more natural and less annoying if they were resolved. I suspect some kind of Windows security feature may be temporarily cutting the connection. I do have User Account Control set to the minimum level. Come to think of it, I have not tried disabling it altogether. I will try that now and report back! :mrgreen:

Share this post


Link to post
Share on other sites
OK I disabled UAC by setting HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\EnableLUA to zero and rebooting. Results: [list=1][*]The initial lockout issue when Screen is Locked is gone. It continues to not be bunted for fresh logins and logins after Remote Desktop disconnection.[/*:m] [*]It still bunts Synergy after entering my password and hitting Enter when it is from a Screen Lock. If it is fresh login or login after Remote Desktop disconnection, it does NOT bunt Synergy. This means for first logins and re-logins after a Remote Desktop disconnection, there is no bunting at all - yay![/*:m] [*]Using Ctrl-Alt-Delete to bring up the Lock/Task Manager screen does continue to bunt Synergy. This is inconvenient as the whole point of doing this is to quickly lock the screen when trying to walk away. So I will continue to use my direct attached keyboard for this.[/*:m][/list:o] So some of the issues remain and it does seem like some of the behavior is due to UAC. But I am happier than when I started this thread. 8-)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this