Dan Fusaro

OSX 10.10 - Copy into Clipboard Crash

23 posts in this topic

Server - Windows 8.1 64-bit w/SSL Client - OSX 10.10.3 w/SSL Repro steps: 1. Start server and client 2. Select some text on the client (Mac) and copy into clipboard (Command+C) 3. Mouse over to server machine Result: Synergy client crashes silently. Note: This cannot be reproduced when SSL is off.

Share this post


Link to post
Share on other sites
I'm seeing a similar issue after updating to 1.7.1 Server - Windows 8.1 64-bit Client - Windows 7 64-bit When copying large amounts of text on the Server, trying to mouse over into the Client causes synergy on the Client to crash. This does not happen when copying single lines of text or less. It does happen when copying multiple lines of text or multiple cells from a spreadsheet. Copying a single line of text or word fixes the issue, as I can mouse over again with no issues. Thank you!

Share this post


Link to post
Share on other sites
I have experience the same issue. If copying multiple lines of text on the server (Mac 10.10) and attempting to enter the client (Windows 7), the server shows as disconnected (never actually 'crashes' on either machine). I can easily restart, but as soon as I touch the screen edge to move to the client, it disconnects again. The thing I found to "fix" the issue is to either empty my clipboard or copy a single word/line to repopulate the clipboard. Hopefully this will be fixed soon. Both server and client are 1.7.2 SSL.

Share this post


Link to post
Share on other sites
I'm seeing this issue too. Anyone know whether this is being tracked on GitHub? I couldn't find anything like this there. Synergy 1.7.2 Server: Mac OSX 10.9.4 Client: Windows 7 64bit

Share this post


Link to post
Share on other sites
I've been having many problems since updating to 1.7.3 and one of the main things is Synergy crashing during clipboard operations. I've always found the clipboard functionality to be iffy at best but it never crashed. Ever. I am using OS X 10.10.4 for the server and the guest is an Ubuntu 14.10 workstation both running 1.7.3. I've tried disabling SSH to see if that makes a difference.

Share this post


Link to post
Share on other sites
Hi, A lot of work has been going into the next release. The nightly builds have worked wonders for me, I encourage everyone who has the time to check them out. I know copy&paste is one of the features that got some attention. [url]http://synergy-project.org/nightly?filter=1.7.4[/url]

Share this post


Link to post
Share on other sites
Hi Ben, What are these commit hashes? They don't seem to match anything on the github. Are the newest builds at the top or bottom of the page? Sorry to ask a noob question like this 4dd4045, the top commit tagged v1.7.4-stable, does appear to still have problems with clipboard. I was able to copy one way but not the other, and it seems my other screen has died again completely. Admittedly I had not used Windows+Linux before today, I just bought into the new $10 basic version. Both sides are running 4dd4045, Ubuntu vivid is the one that's "using" and Windows 7 is sharing. It seems to work OK until I try to use the clipboard (but, that's pretty often, so . I was using 1.6.2 until today with both sides on Ubuntu and no problems, it was seeming pretty stable, but my desktop was having unexplainable compositor or x11 lockups that got annoying so I switched to Windows 7. This is not really much better ^_^

Share this post


Link to post
Share on other sites
This page apparently got worked over, it is possible to tell what build is the newest now, and lots more. Thanks! As of 4dd4045, I was still getting those clipboard crashes somewhat reliably. I will try another build since it looks like you are (someone is) actively developing the software. If I can help out with a stack trace or anything, I will gladly.

Share this post


Link to post
Share on other sites
synergy-master-alpha-41c03b8-Linux-x86_64.deb -- This build seemed at first to have resolved the crashing, but i still have problems copying from remote to local. And after enough trying, it can still be made to crash. That is, the connection goes down, but the process stays running. Could only be killed with -9. Will keep it running in terminal and check if any interesting messages are printed. Have been using quicksynergy, if that is potentially a source of problems then I can try without it.

Share this post


Link to post
Share on other sites
On the remote: [code]~$ quicksynergy (quicksynergy:28550): Gtk-CRITICAL **: IA__gtk_widget_set_sensitive: assertion 'GTK_IS_WIDGET (widget)' failed (quicksynergy:28550): Gtk-CRITICAL **: IA__gtk_widget_set_sensitive: assertion 'GTK_IS_WIDGET (widget)' failed (quicksynergy:28550): Gtk-CRITICAL **: IA__gtk_widget_set_sensitive: assertion 'GTK_IS_WIDGET (widget)' failed [2015-07-27T12:13:48] INFO: started client [2015-07-27T12:13:48] INFO: connecting to '192.168.3.90': 192.168.3.90:24800 [2015-07-27T12:13:48] INFO: connected to server [2015-07-27T12:13:56] INFO: entering screen [2015-07-27T12:13:56] NOTIFY: clipboard transmission started: start receiving 19 bytes of clipboard data [2015-07-27T12:13:56] NOTIFY: clipboard transmission complete [2015-07-27T12:13:56] NOTIFY: clipboard transmission started: start receiving 19 bytes of clipboard data [2015-07-27T12:13:56] NOTIFY: clipboard transmission complete [2015-07-27T12:14:05] INFO: leaving screen [2015-07-27T12:14:12] INFO: server is dead [2015-07-27T12:14:12] WARNING: failed to connect to server: server is not responding [2015-07-27T12:14:13] INFO: connecting to '192.168.3.90': 192.168.3.90:24800 [2015-07-27T12:14:28] WARNING: failed to connect to server: Timed out [/code]

Share this post


Link to post
Share on other sites
On the server/keyboard machine: [code]~$ quicksynergy (quicksynergy:5581): Gtk-CRITICAL **: IA__gtk_widget_set_sensitive: assertion 'GTK_IS_WIDGET (widget)' failed (quicksynergy:5581): Gtk-CRITICAL **: IA__gtk_widget_set_sensitive: assertion 'GTK_IS_WIDGET (widget)' failed (quicksynergy:5581): Gtk-CRITICAL **: IA__gtk_widget_set_sensitive: assertion 'GTK_IS_WIDGET (widget)' failed [2015-07-27T12:13:39] INFO: started server, waiting for clients [2015-07-27T12:13:48] INFO: accepted client connection [2015-07-27T12:13:48] INFO: client "vernon" has connected [2015-07-27T12:13:56] INFO: switch from "mmi-OptiPlex-760-01" to "vernon" at 0,592 [2015-07-27T12:13:56] INFO: leaving screen [2015-07-27T12:13:56] INFO: screen "mmi-OptiPlex-760-01" updated clipboard 0 [2015-07-27T12:13:56] INFO: screen "mmi-OptiPlex-760-01" updated clipboard 1 [2015-07-27T12:14:03] INFO: screen "vernon" grabbed clipboard 1 from "mmi-OptiPlex-760-01" [2015-07-27T12:14:05] INFO: switch from "vernon" to "mmi-OptiPlex-760-01" at 1900,606 [2015-07-27T12:14:05] INFO: entering screen[/code]

Share this post


Link to post
Share on other sites
I downgraded both hosts to 1.6.3 and the problem does not seem to be affecting me here.

Share this post


Link to post
Share on other sites
I ran into the problem also where the clipboard had content, but I wasn't actually trying to paste anything onto the client but still it crashed the server. I'm running OS X 10.10.4 on the server side and 10.7.5 on the client side. I solved the situation so as to give basic usability by making an applescript and saving it as an application which will clear the clipboard whenever needed. Here's the code: [code]set the clipboard to {}[/code] Simple but effective if copying/pasting isn't too important.

Share this post


Link to post
Share on other sites
[quote="Simon Foster"]I ran into the problem also where the clipboard had content, but I wasn't actually trying to paste anything onto the client but still it crashed the server. I'm running OS X 10.10.4 on the server side and 10.7.5 on the client side. I solved the situation so as to give basic usability by making an applescript and saving it as an application which will clear the clipboard whenever needed. Here's the code: [code]set the clipboard to {}[/code] Simple but effective if copying/pasting isn't too important.[/quote] That's interesting. Does your synergy server daemon recover when the clipboard is emptied? I don't know if there's a similar way to clear the clipboard in Linux (there are multiple clipboards, this is probably something that could be done with xclip or other cli tool). FWIW, the whole-display crash bug I mentioned (where my X11 display becomes non-responsive except for mouse movement, and the only way I am able to fix it is a full reboot)... that problem I was experiencing seems to have gone away too, when I downgraded to Synergy 1.6. I wasn't attributing it to Synergy upgrade, but now I have to question if that might have actually been the cause of the problem. It followed me from Unity to E19, and for a day or more since downgrading synergy it hasn't come back. I am really glad I can support the ongoing development of Synergy now by paying the $10 for access, but I can't say I'm particularly happy about the change in quality of the software since back when the binaries were more freely available. I basically never had a problem until I started paying for it! I have used Synergy for a long time with great results across platforms, then suddenly one day when SourceForge is down and I am in front of a Windows computer, I went to download and I noticed that the current (or any) Windows or Linux release version downloads have been moved behind a paywall. I go ahead and pay (why not), only to find the latest releases of the software are all completely unusable for me now. I get it, devs shouldn't have to work for free, but I hope you can hear what I'm saying too. Synergy devs maybe ought to get their act together (or otherwise just leave well-enough alone!) Maybe the pro version does not have these kind of problems, but I guess I'm not so optimistic.

Share this post


Link to post
Share on other sites
[quote="yebyen"] I get it, devs shouldn't have to work for free, but I hope you can hear what I'm saying too. Synergy devs maybe ought to get their act together (or otherwise just leave well-enough alone!) Maybe the pro version does not have these kind of problems, but I guess I'm not so optimistic.[/quote] I read your announcement of the 1.7.4 release and I want to say thank you, for addressing these issues so directly. I haven't tried the new release yet, but just based on your clear and direct apology and totally un-obfuscated admission that there were serious issues in the 1.7 release path, I think I can say my faith in Synergy is restored.

Share this post


Link to post
Share on other sites
[quote="yebyen"][quote="yebyen"] I get it, devs shouldn't have to work for free, but I hope you can hear what I'm saying too. Synergy devs maybe ought to get their act together (or otherwise just leave well-enough alone!) Maybe the pro version does not have these kind of problems, but I guess I'm not so optimistic.[/quote] I read your announcement of the 1.7.4 release and I want to say thank you, for addressing these issues so directly. I haven't tried the new release yet, but just based on your clear and direct apology and totally un-obfuscated admission that there were serious issues in the 1.7 release path, I think I can say my faith in Synergy is restored.[/quote] Sorry to report, I am back using the 1.6.3 release. Although I will agree that 1.7.4 is much "less crashy" than previous 1.7 releases, it still fails to copy clipboard from host to host eventually (I do not have exact steps to reproduce, but it failed for me after about a half-day of use). I do not have these problems with 1.6.3. I am not particularly interested in the new features in 1.7 and thus I don't mind running a 1.6 release. I just don't know how well it speaks for the leadership when you address the community and say "it's stable now" but for me, it's still not stable.

Share this post


Link to post
Share on other sites
I was about to report this clipboard problem as a bug, when I was directed to the forums. It's a bit sad to see it's been happening to many people for a long time and has not been resolved. Somewhat ludicrously, I guess I'm going back to 1.6.3 too. There's no point releasing new versions if they don't actually work, and you don't fix them in a timely manner. PS: I'm using Ubuntu as the Server and Windows 10 as the client. Happy to provide logs if anyone cares.

Share this post


Link to post
Share on other sites
Same sort of issue here. Linux server on network 1, windows 7 client on VPN network 2. Most times I copy something from the client and then move the cursor to the server the session dies silently and I have to stop then start the server process to reconnect. If there is any way to disable clipboard sharing I would accept that as a workaround!

Share this post


Link to post
Share on other sites
Same problem here using ubuntu on server and client side. Downgraded to 1.6.3. Seems that the only use for the paid version is the access to all the previous versions.

Share this post


Link to post
Share on other sites
Dan Fusaro, you hadn't mentioned the version of Synergy you're using, or the size of the file being copied. Versions before 1.7.5 had trouble with sending over 1024 bytes with SSL enabled, you might have better results with the latest stable version. - Brian [quote="Dan Fusaro"]Server - Windows 8.1 64-bit w/SSL Client - OSX 10.10.3 w/SSL Repro steps: 1. Start server and client 2. Select some text on the client (Mac) and copy into clipboard (Command+C) 3. Mouse over to server machine Result: Synergy client crashes silently. Note: This cannot be reproduced when SSL is off.[/quote] Edited by Guest

Share this post


Link to post
Share on other sites
Some solutions to this: you can use the latest Synergy, disable SSL, or disable SSL and use a different encryption implementation which has been developed more thoroughly. This problem is probably due to the 1024 bytes limit with the earlier Synergy SSL. Some people said they downgraded to 1.6.3, which should not be necessary. https://github.com/symless/synergy/issues/4584 https://github.com/symless/synergy/issues/4712 - Brian [quote="Jonathan Diefenbach"]I'm seeing a similar issue after updating to 1.7.1 Server - Windows 8.1 64-bit Client - Windows 7 64-bit When copying large amounts of text on the Server, trying to mouse over into the Client causes synergy on the Client to crash.[/quote]

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now