jnevans

1.76 on Windows - Synergy can't bind to desired interface

14 posts in this topic

I have wired and wireless connection both active at the same time on Windows PC. I need to bind Synergy to the wired connection/interface but it keeps on binding to the wireless connection. I have my PCs all connected together over their wired connections. I am seeing the similar thing when VPN connection is active, Synergy will bind on my VPN interface, instead of the wired interface. Proposed solution: Either have Synergy bind on ALL interfaces or allow me to be able to choose which interface to bind on.

Share this post


Link to post
Share on other sites
I am having the same issue, with both server and client running Mac OS X 10.11.3 and Synergy 1.7.6. The server pretty consistently picks a VMWare Fusion 192.168 address from the list, rather than the one associated with the wired or wireless networks. Static IP is not really an option on our network, I need to be able to use DNS.

Share this post


Link to post
Share on other sites
Same here, my computers are connected by both a wireless router and a direct ethernet and I can't tell Synergy to use the ethernet so it's pretty much laggy. Is there any way to tell it to use a specific IP for being a server? (as even if I set the secondary (ethernet) address in the client as the server IP, it can't find the server at that IP as I guess the server uses the bold IP address to be a server.)

Share this post


Link to post
Share on other sites
Yes, I had already tried to use the ip address in the interface field of server configuration but that's ignored by synergy and it binds to whatever ip address it wants.

Share this post


Link to post
Share on other sites
a small workaround if you disconnect the other networks from the client then it can connect to the server, and you can reconnect the other networks then. But it's silly why it's not connecting otherwise.

Share this post


Link to post
Share on other sites
I've posted my problem in Stack as the site suggested, here: http://superuser.com/questions/1064306/ ... ip-address My issue is just another version of the same issue here, when there are multiple adapters, we need the ability to force the Synergy Server to use a specific IP address. It seems pretty insane that this isn't a feature or configuration option, considering the most likely user of this software is a power user who will more than likely have multiple adapters for any number of different reasons. Either let us bind synergy to a specific IP, MAC or Adapter in the system so that regardless of changes to the system Synergy will continue to work for us as expected. In the mean time, this software has sadly become useless, and I've had to hook up a POS Keyboard and Mouse.

Share this post


Link to post
Share on other sites

It`s easier to solve this issue.

Click on Edit->Settings and change the Interface IP Address there to the correct one.

This worked for me. in Version 1.8.3

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now