Nick Bolton

Synergy 1.7.6 released

26 posts in this topic

The next version of Synergy is here! » [url=http://synergy-project.org/download/]Download Synergy v1.7.6-stable[/url] Here's the bug fixes… Bug [url=https://github.com/symless/synergy/issues/5041]#5041[/url] - Copying from the Chrome web browser doesn't work Bug [url=https://github.com/symless/synergy/issues/4735]#4735[/url] - Clipboard doesn't work from client to server Bug [url=https://github.com/symless/synergy/issues/4723]#4723[/url] - Waiting for active desktop result freezes Windows service Bug [url=https://github.com/symless/synergy/issues/4353]#4353[/url] - Large clipboard causes crash Bug [url=https://github.com/symless/synergy/issues/3774]#3774[/url] - Missing MinGW dependencies after install on Windows Bug [url=https://github.com/symless/synergy/issues/2909]#2909[/url] - Clipboard copies only plaintext between Mac and Windows Bug [url=https://github.com/symless/synergy/issues/451]#451[/url] - Fast cursor on any client with Mac server Thanks for using Synergy, enjoy the release!

Share this post


Link to post
Share on other sites
Great news! Will the source code be made available? Right now I'm getting a 404 error when attempting to download. I use Arch Linux so it's a lot easier to build then trying to extract from debs or RPMs. Thanks

Share this post


Link to post
Share on other sites
This is awesome. Totally solved the clipboard bug, what a relief (MacBook Pro server / Windows 10 client). Great work guys, keep up the good work!

Share this post


Link to post
Share on other sites
I was so happy that a new version with so many bugfixes has been released... BUT... it seems... the image of 1.7.6 for mac 10.11 is damaged on your server? :| :| :| I tried to download it again and again and again, but always got an error "image data corrupted" :cry: :cry: :cry:

Share this post


Link to post
Share on other sites
That chrome clipboard bugfix is a lifesaver, no more pasting into notepad++ and copying it again for me!... or so I thought... Unfortunately it comes with a few new random bugs and I am going to have to downgrade to 1.7.5 again (I think that is what I was running previously). For some reason Photoshop CC 2015 occasionally has its selector box disappear as soon as I select something. When it does this I also cant resize the with the crop tool. Unsure what would cause something like this. Also when I am playing Stardew Valley (steam game), my keyboard input does not work to move the character, and mouse does not let me click anything. Am able to press a key to display a menu. I'd be quite happy to blame both of those programs for causing the problems but it only appeared when I updated to 1.7.6, and as soon as I stop the synergy service the problems go away. :cry: Win10 Pro x64 server, OSX 10.11.3 MacMini client.

Share this post


Link to post
Share on other sites
In Windows 10 the mouse scroll wheel stops working and you can't select anything from a pop up box. As soon as you shut down the client server, all works again. Any chance of looking into this? Cheers.

Share this post


Link to post
Share on other sites
[quote="Jeffrey Glover"]Great news! Will the source code be made available? Right now I'm getting a 404 error when attempting to download. I use Arch Linux so it's a lot easier to build then trying to extract from debs or RPMs. Thanks[/quote] I just noticed that the link to the source is working now.

Share this post


Link to post
Share on other sites
Thanks for the update - is there any news on if this issue for Mac users is being addressed? viewtopic.php?f=19&t=1165 Currently, 1.7.6 still exhibits the same behavior between Macs on 10.11.2/10.11.3 - the keyboard connectivity between machines is unusable. Thanks!

Share this post


Link to post
Share on other sites
I'm also having mouse/keyboard issues with Adobe Photoshop and InDesign. This is on the local system, not a remote. Can't right click certain menus, cannot drag tools such as eraser, can click to erase but drag does not work. Also weird keyboard issues like ALT key not responding, etc. As soon as I stop Synery service everything works fine. Windows 7 Pro 64 system.

Share this post


Link to post
Share on other sites
I am having connectivity issues Linux Debian synergy server Windows 7 synergy client I keep getting the following message WARNING: failed to connect to server: incompatible client 1.5

Share this post


Link to post
Share on other sites
This release has caused specific key inputs to stop working for a couple of games I play. In Borderlands 2, it denies use of the movement keys (WASD by default) even when they are bound to other keys. In Warframe, it blocks being able to paste in to the game's chat. All other key inputs work, and I haven't found any other games it interferes with, which is the strangest thing. For now I'll just have to disable Synergy while I play those games, though.

Share this post


Link to post
Share on other sites
I updated Synergy 1.7.5 to version 1.7.6. After a while (a couple of hours) my AutoHotKey scripts stopped working. Rebooting my Win10x64 computer does not bring AHK scripts to work again. I uninstalled 1.7.6 and everything worked fine again. New install of 1.7.6 showed same behaviour. I repeated this procedure twice with same results. So I returned to Synergy 1.7.5 and everything is running ok as it was before installing 1.7.6

Share this post


Link to post
Share on other sites
[quote="Ray Shaffer"]I'm also having mouse/keyboard issues with Adobe Photoshop and InDesign. This is on the local system, not a remote. Can't right click certain menus, cannot drag tools such as eraser, can click to erase but drag does not work. Also weird keyboard issues like ALT key not responding, etc. As soon as I stop Synery service everything works fine. Windows 7 Pro 64 system.[/quote] I am experiencing similar issues. With Internet Explorer 11, I cannot type addresses into the Address Bar and navigate by pressing Enter -- IE freezes. Same URLs work fine from shortcuts. Today I noticed that the keyboard interaction with VMware Workstation 12 guests also doesn't work. The VM works fine, but as soon as I do anything inside the image requiring keyboard input, it freezes. If I stop the Synergy service, everything works fine. Using [b]synergy-v1.7.6-stable-bcb9da8 64-bit[/b] No similar issues encountered testing [b]synergy-v1.8.0-beta-4ff3cdd[/b] [u]Update after further testing[/u] From nightly builds, installed [b]synergy-v1.8.1-stable-257ac01-Windows-x64[/b] [i] (About... dialog still shows Version: 1.7.6!)[/i] Confirmed that same issue exists... Also in IE11, pressing Alt key to display menus doesn't work. RESTARTED Synergy Service and issues above went away. [color=#FF0000]Set Service Startup type: Automatic (Delayed Start), rebooted and seems to be working fine...[/color]

Share this post


Link to post
Share on other sites
[quote="Albert Winter"]I updated Synergy 1.7.5 to version 1.7.6. After a while (a couple of hours) my AutoHotKey scripts stopped working. Rebooting my Win10x64 computer does not bring AHK scripts to work again. I uninstalled 1.7.6 and everything worked fine again. New install of 1.7.6 showed same behaviour. I repeated this procedure twice with same results. So I returned to Synergy 1.7.5 and everything is running ok as it was before installing 1.7.6[/quote] I am also having problems running Synergy 1.7.6 and AutoHotkey on Windows 8.1. Sometimes if I start AutoHotkey before the Synergy service AutoHotkey will work fine, but other times AutoHotkey just won't work at all if Synergy is running.

Share this post


Link to post
Share on other sites
BUG - Mouse Click on Client [Windows 10] After the last update almost all the time the mouse works on client but the click does not work. Thanks!

Share this post


Link to post
Share on other sites
[quote="Albert Winter"]I updated Synergy 1.7.5 to version 1.7.6. After a while (a couple of hours) my AutoHotKey scripts stopped working. Rebooting my Win10x64 computer does not bring AHK scripts to work again. I uninstalled 1.7.6 and everything worked fine again. New install of 1.7.6 showed same behaviour. I repeated this procedure twice with same results. So I returned to Synergy 1.7.5 and everything is running ok as it was before installing 1.7.6[/quote] I have the same problem. As a work around I set the Synergy service to [b]Automatic (Delayed Start)[/b]. AutoHotKey seems to work as long as it starts before the Synergy service.

Share this post


Link to post
Share on other sites
[quote="William Deckert"]I am having connectivity issues Linux Debian synergy server Windows 7 synergy client I keep getting the following message WARNING: failed to connect to server: incompatible client 1.5[/quote] Having the same issue, exactly the same setup. (Xenial 16.04 server, Windows 7 Enterprise client, both just updated today). After installing the 1.7.6 64 bit .deb, my "about Synergy" shows version 1.6.2, copyright 2002-2012 [attachment=0]ScreenshotSynergy1.6.2.png[/attachment] Is the 64bit debian on the website correct? --EDIT-- I tried just running the .deb using the synaptic package manager. It seems to have searched for and installed the open-source version. Actually downloading the .deb and running: [code]$ dpkg -i synergy-v1.7.6-stable-bcb9da8-Linux-x86_64.deb [/code] actually installed the correct version and everything now works as expected.

Share this post


Link to post
Share on other sites
I'm still having key mapping issues on Mac servers, and even if this seems like a fairly common issue no one seems to address it..? All spacebar inputs come out as "/" (in my case anyway). This has been persistent in the past several versions. Any way we can help to fix this?

Share this post


Link to post
Share on other sites
Is there a snow leopard version? 1.7.4 is the latest I can download for osx 10.6.

Share this post


Link to post
Share on other sites
I am using synergy 1.7.6 on Ubuntu 14.04 on two machines. The client is not able to connect to the server and below is the log, kindly assist I am tired of being such softwares. [2016-05-26T23:25:39] ERROR: server refused client with name "krait-4790" [2016-05-26T23:25:39] WARNING: failed to connect to server: server refused client with our name [2016-05-26T23:25:40] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081 [2016-05-26T23:25:40] ERROR: server refused client with name "krait-4790" [2016-05-26T23:25:40] WARNING: failed to connect to server: server refused client with our name [2016-05-26T23:25:41] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081 [2016-05-26T23:25:41] ERROR: server refused client with name "krait-4790" [2016-05-26T23:25:41] WARNING: failed to connect to server: server refused client with our name [2016-05-26T23:25:42] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081 [2016-05-26T23:25:42] ERROR: server refused client with name "krait-4790" [2016-05-26T23:25:42] WARNING: failed to connect to server: server refused client with our name [2016-05-26T23:25:43] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081 [2016-05-26T23:25:43] ERROR: server refused client with name "krait-4790" [2016-05-26T23:25:43] WARNING: failed to connect to server: server refused client with our name [2016-05-26T23:25:44] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081 [2016-05-26T23:25:44] ERROR: server refused client with name "krait-4790" [2016-05-26T23:25:44] WARNING: failed to connect to server: server refused client with our name [2016-05-26T23:25:45] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081 [2016-05-26T23:25:45] ERROR: server refused client with name "krait-4790" [2016-05-26T23:25:45] WARNING: failed to connect to server: server refused client with our name [2016-05-26T23:25:46] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081 [2016-05-26T23:25:46] ERROR: server refused client with name "krait-4790" [2016-05-26T23:25:46] WARNING: failed to connect to server: server refused client with our name [2016-05-26T23:25:47] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081 [2016-05-26T23:25:47] ERROR: server refused client with name "krait-4790" [2016-05-26T23:25:47] WARNING: failed to connect to server: server refused client with our name [2016-05-26T23:25:48] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081 [2016-05-26T23:25:48] ERROR: server refused client with name "krait-4790" [2016-05-26T23:25:48] WARNING: failed to connect to server: server refused client with our name [2016-05-26T23:25:49] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081 [2016-05-26T23:25:49] ERROR: server refused client with name "krait-4790" [2016-05-26T23:25:49] WARNING: failed to connect to server: server refused client with our name [2016-05-26T23:25:50] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081 [2016-05-26T23:25:50] ERROR: server refused client with name "krait-4790" [2016-05-26T23:25:50] WARNING: failed to connect to server: server refused client with our name [2016-05-26T23:25:51] INFO: service command updated [2016-05-26T23:25:51] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081 [2016-05-26T23:25:51] ERROR: server refused client with name "krait-4790" [2016-05-26T23:25:51] WARNING: failed to connect to server: server refused client with our name [2016-05-26T23:25:52] INFO: process started but command is empty, shutting down [2016-05-26T23:25:52] INFO: got ipc shutdown message [2016-05-26T23:25:52] NOTE: stopped client [2016-05-26T23:25:53] INFO: process 7568 was shutdown gracefully

Share this post


Link to post
Share on other sites
Finally I figured it out that before we need to add screen using "Configure Server" and use the same name as client. Guyz kindly use this step to configure else you will be in my situation.

Share this post


Link to post
Share on other sites
Hello, I have been running Synergy on Ubuntu (16.04), Windows (7), and Mac OS (El Capitan) No matter which platform I choose as Server, During Copy and Paste operations the clients crash. Smaller text copy and paste (e.g URL) seems to work well. But If I start copying huge page of code and try to paste on anther client - I tend to loose the clients. Please help. (a) Are anyone else running into this issue of copy and paste and loosing clients. (b) Is there a way to disable copy and paste feature?

Share this post


Link to post
Share on other sites
I've been beta testing the 1.8 code for quite some time now without and update, should I go to 1.7.6?

Share this post


Link to post
Share on other sites
Same problem for me that others have had. Starting Synergy will sometimes stop the keyboard (and mouse) from working in VMs. I've noticed that if I press the left mouse button quickly in the VM window, it appears as though the VM gets focus, but then it is quickly taken away. Stopping Synergy allows the VM to work correctly. The problem is not tied to a particular guest. I run several versions of Windows, and Linux, and they all have the same issue.

Share this post


Link to post
Share on other sites
It's quite a shame to pay for a product but not getting support for it (or at least a comment...) - [url]http://symless.com/forum/viewtopic.php?f=9&t=1710[/url] It was acceptable when it was freeware... :|

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.