Sign in to follow this  
Jethro Padullon

Synergy auto-start on Mac OS X

2 posts in this topic

I can't seem to find any settings to auto-start Synergy at boot. I tried to use the Login Items in Mac OS X, but it keeps showing the configuration window when I login or start up my Mac, even with "Hidden" checked. Any help is greatly appreciated........new user here :) Please be gentle, I haven't gone through the entire forum yet to find out about this. Cheers

Share this post


Link to post
Share on other sites
Yes, I am just looking for this today, found old directions for getting it to start at boot using a script and plist file in /Library/StartupItems/Synergy, however, it doe snot seem to start [code] Mar 9 19:01:48 machine synergyc[790]: Untrusted apps are not allowed to connect to Window Server before login. Mar 9 19:01:48 machine synergyc[790]: Set a breakpoint at CGSLogError to catch errors as they are logged. Mar 9 19:01:48 machine synergyc[790]: This user is not allowed access to the window system right now. Mar 9 19:01:48 machine synergyc[790]: _RegisterApplication(), FAILED TO establish the default connection to the WindowServer, _CGSDefaultConnection() is NULL. Mar 9 19:01:48 machine logind[93]: -[SessionManager getClient:withRole:inAuditSession:]:241: ERROR: No session dictionary for audit session 100010 Mar 9 19:01:48 machine logind[93]: _SMGetSessionAgent:73: ERROR: __SMGetClientForAuditSessionAgent failed 2 Mar 9 19:01:48 machine synergyc[790]: SACScreenSaverIsRunning:554: ERROR: NULL response Mar 9 19:01:48 machine synergyc[790]: CGSConnectionByID: 0 is not a valid connection ID. Mar 9 19:01:48 --- last message repeated 9 times --- Mar 9 19:01:48 machine synergyc[790]: Invalid Connection ID 0 Mar 9 19:01:48 machine synergyc[790]: CGSConnectionByID: 0 is not a valid connection ID. Mar 9 19:01:48 machine synergyc[790]: Invalid Connection ID 0 Mar 9 19:01:48 machine synergyc[790]: An uncaught exception was raised Mar 9 19:01:48 machine synergyc[790]: Error (1000) creating CGSWindow Mar 9 19:01:48 machine synergyc[790]: ( 0 CoreFoundation 0x96123c63 __raiseError + 195 1 libobjc.A.dylib 0x9750ba2a objc_exception_throw + 276 2 CoreFoundation 0x96123b7d +[NSException raise:format:] + 141 3 AppKit 0x943c0112 _NXCreateWindowWithStyleMask + 519 4 AppKit 0x943bfe52 _NSCreateWindow + 165 5 AppKit 0x94209dac -[NSWindow _commonAwake] + 1522 6 AppKit 0x94190d8b -[NSWindow _commonInitFrame:styleMask:backing:defer:] + 874 7 AppKit 0x9419026a -[NSWindow _initContent:styleMask:backing:defer:contentView:] + 1899 8 AppKit 0x9418faec -[NSWindow initWithContentRect:styleMask:backing:defer:] + 72 9 synergyc 0x0011fab7 runCocoaApp + 199 10 synergyc 0x0012f2d2 _ZN9ClientApp8mainLoopEv + 338 11 synergyc 0x0014166b _Z21standardStartupStaticiPPc + 43 [/code] The startup script (Synergy and executable) looks like this [code] #!/bin/sh . /etc/rc.common run=(/Applications/Synergy.app/Contents/MacOS/synergyc -n $(hostname -s) -1 -f 10.1.10.23 ) KeepAlive () { proc=${1##*/} while [ -x "$1" ] do if ! ps axco command | grep -q "^${proc}\$" then "[email protected]" fi sleep 3 done } StartService () { ConsoleMessage "Starting Synergy" KeepAlive "${run[@]}" & } StopService () { return 0 } RestartService () { return 0 } RunService "$1" [/code] The plist file (StartupParameters.plist) [code] { Description = "Synergy Client"; Provides = ("Synergy"); Requires = ("Network"); OrderPreference = "None"; } [/code] SO it looks like the issue it that the App is not signed and is not trusted to run :( spctl --status shows: # spctl --status assessments disabled # Any help would be appreciated, I would love to not have to reach over, find keyboard etc just to log in.

Share this post


Link to post
Share on other sites
Definitely would like to see this working. I know it's minor but it really prevents me from having my desired setup due to needing the keyboard on the desk.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this