Sign in to follow this  
Andrew Griffin

OSX clients not reconnecting to Win7 server

2 posts in this topic

Win7 Server + OSX10.10 client -two of them actually, and one win7 client When server lockscreen comes up, all clients disconnect OSX clients will never try to reconnect after the error below, win7 client reconnects without difficulty stop/start on clients reconnects until next lock screen event [2016-02-05T14:11:31] INFO: entering screen [2016-02-05T14:11:33] INFO: leaving screen [b][2016-02-05T14:11:33] WARNING: cursor may not be visible[b] [2016-02-05T14:11:37] NOTE: disconnected from server [2016-02-05T14:11:38] NOTE: connecting to '10.100.85.63': 10.100.85.63:24800 [2016-02-05T14:11:40] ERROR: ssl error occurred (system call failure) [2016-02-05T14:11:40] ERROR: failed to connect secure socket [2016-02-05T14:11:41] NOTE: disconnected from server[/b] [2016-02-05T14:12:34] INFO: stopping synergy desktop process [2016-02-05T14:12:34] INFO: process exited normally [2016-02-05T14:12:34] INFO: starting client [2016-02-05T14:12:34] INFO: config file: /var/folders/8n/4l0sjbls1kddp1k31thpns7r0000gq/T/Synergy.sn3081 [2016-02-05T14:12:34] INFO: log level: INFO [2016-02-05T14:12:34] INFO: drag and drop enabled [2016-02-05T14:12:34] NOTE: started client [2016-02-05T14:12:34] NOTE: connecting to '10.100.85.63': 10.100.85.63:24800 2016-02-05 14:12:35.021 synergyc[6697:1411390] starting cocoa loop [2016-02-05T14:12:35] NOTE: server fingerprint: FF:8D:8B:82:D2:A3:39:BB:CE:72:50:C8:CB:B5:A9:C9:21:D8:6A:74 [2016-02-05T14:12:35] INFO: connected to secure socket [2016-02-05T14:12:35] INFO: server ssl certificate info: /CN=Synergy [2016-02-05T14:12:35] WARNING: cursor may not be visible [2016-02-05T14:12:35] NOTE: connected to server [2016-02-05T14:13:24] INFO: entering screen

Share this post


Link to post
Share on other sites
we have the same problem, it seems the issue is Mac OSX has no SSL encryption, and I cannot find here in the forum on how to enable the SSL certification for Synergy. The only solution I found is to disable the SSL encryption my Windows Main Server so it will connect to the client on mac osx. I do hope Synergy Tech can fixed this issue.

Share this post


Link to post
Share on other sites
I have the same problem, and a similar setup - Win10 server, 2x OSX and 1x Win10 client. The Windows client reestablishes after I log back into the server just fine, but the Mac clients throw that same error: ERROR: ssl error occurred (system call failure) ERROR: failed to connect secure socket NOTE: disconnected from server I can get it to reconnect w/o having to manually restart the service by forcing a geometry change on the Mac, such as opening+closing the lid of the laptop, so I can kind of work around it, but it's incredibly aggravating. It was happening on 1.7.5, so I went to 1.8.0-beta, but having the same result. It's not 100% consistent though - there is a small minority of times where one or the other of the Mac clients will reconnect correctly.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this