Jake Hawkes

Synergy interfering with mouse actions in Word 2013

4 posts in this topic

Running Synergy 1.7.5 on Windows 8.1 (server) and Windows 7 (client) While working in Word 2013 on the server, the mouse click-hold actions were failing. That is, anything that requires the left mouse button to be clicked and held down, failed. It was as if something was causing the mouse button hold event to end prematurely. Things that failed: [list][*]Click and drag the column widths[/*:m] [*]click and drag the indent handle on the ruler[/*:m] [*]click and drag to select text[/*:m][/list:u] The above behavior was only observed in Word 2013 on the server. As soon as I killed Synergy, the problem went away. Then, I rebooted the computer and fired up Synergy, and tested, and the problem did *NOT* re-occur. I will continue to monitor. I first mentioned this on the tail end of [url=http://synergy-project.org/forum/viewtopic.php?f=9&t=738&p=3632#p3632]this thread[/url]

Share this post


Link to post
Share on other sites
The problem re-occured. It appears to come and go, with no discernable pattern so far. Interestingly, putting Synergy into debug2 mode solves the problem. But I wonder if this is because the synergys program gets restarted when the debug level is changed. I will leave the debug2 mode on for now, and see if the problem comes back. FYI, when I put the program into debug2, and tried to perform the mouse-click-drag action (this time in Outlook, not Word), the debug log showed this: [code][2016-02-02T08:56:32] DEBUG1: event: button release button=1 [2016-02-02T08:56:32] DEBUG1: onMouseUp id=1 [2016-02-02T08:56:33] DEBUG1: hook: 0x0000002e 0x01530001 [2016-02-02T08:56:33] DEBUG1: hook: 0x0600002e 0x01530001 [2016-02-02T08:56:33] DEBUG1: hook: 0x0700002e 0x01530001 [2016-02-02T08:56:33] DEBUG1: event: Key char=0, vk=0x2e, nagr=0, lParam=0x01530001 [2016-02-02T08:56:33] DEBUG1: new mask: 0x2000 [2016-02-02T08:56:33] DEBUG1: new mask: 0x2000 [2016-02-02T08:56:33] DEBUG1: onKeyDown id=61439 mask=0x2000 button=0x0153 [2016-02-02T08:56:33] DEBUG1: hook: 0x0000002e 0x81530001 [2016-02-02T08:56:33] DEBUG1: hook: 0x0600002e 0x81530001 [2016-02-02T08:56:33] DEBUG1: hook: 0x0700002e 0x81530001 [2016-02-02T08:56:33] DEBUG1: event: Key char=0, vk=0x2e, nagr=0, lParam=0x81530001 [2016-02-02T08:56:33] DEBUG1: new mask: 0x2000 [2016-02-02T08:56:33] DEBUG1: new mask: 0x2000 [2016-02-02T08:56:33] DEBUG1: onKeyUp id=61439 mask=0x2000 button=0x0153 [2016-02-02T08:56:44] DEBUG1: event: button press button=1 [2016-02-02T08:56:44] DEBUG1: onMouseDown id=1 [2016-02-02T08:56:44] DEBUG1: event: button release button=1[/code]

Share this post


Link to post
Share on other sites
Synergy 1.8.0 beta. Windows 10 I am seeing the exact same problem. I have to stop the Synergy service to be able to select text or drag items like the page margins or indentions. I will try debug mode to see if that helps. Edit: I am now in Debug2 and am still seeing the problem.

Share this post


Link to post
Share on other sites
[quote="Andrew Pearson"]Synergy 1.8.0 beta. Windows 10 I am seeing the exact same problem. I have to stop the Synergy service to be able to select text or drag items like the page margins or indentions. I will try debug mode to see if that helps. Edit: I am now in Debug2 and am still seeing the problem.[/quote] I confirm, I'm having this drag-select issue in Windows 7 , also using the latest synergy (1.7.6). And I've had this issue for a long long time. I love Synergy, but as I'm using Office much more often than synergy, I have to kill synergy after a reboot, and eventually fire it up when I want to use it. Best, Ronald

Share this post


Link to post
Share on other sites
Having same issue with Word, noticed that click-drag-select works until the keyboard is used then it fails to drag-select. Unable to determine what allows it to work again.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now