Sign in to follow this  
Chris Kasten

Mouse cursor disappears

5 posts in this topic

I finished my Win 10 build on my Surface Pro 3 and immediately grabbed the latest version of Synergy. Synergy 1.7.1 installs OK on this and a Server 2012 R2 box. Using the Surface as server and the 2012 R2 box as client. They link up OK, but as soon as the mouse goes to the 2012 R2 rig it disappears. No errors in Synergy on either end. Mouse seems to warp over to the right-side of the screen because the "charms" menu pops up on 2012r2. Weird. Are there known issues with Win 10 -- or with the Surface's rather high res display? I skimmed the forums but didn't see anything right off. Any thoughts or troubleshooting ideas? I already tried disabling SSL. Going to try using the Win10 Surface to control a win8 tablet later today and see how that works.

Share this post


Link to post
Share on other sites
Well, the test to use a different client also failed. Same issue, mouse cursor disappears on the client and seems to drop into bottom-left corner. I guess this is either a Win 10 issue (build 10074) or a Surface scaling issue (?). I'm open to ideas, suggestions or work-arounds.

Share this post


Link to post
Share on other sites
Issue is caused by scaling. I have the Surface Pro 3 primary display scaled to 150%, all other displays at 100%. Both clients at 100%. If I change the SP3 primary display to 100% then everything works fine (I just can't read the teeny-tiny text on that display...). Is there a configuration option to handle scaling like this?

Share this post


Link to post
Share on other sites
Hey Chris, I just ran into the same problem and found this workaround. Change the compatibility mode for synergy.exe AND synergys.exe (server process) to "Deactivate scaling for hiDPI" and "run as Windows 7" and by setting those options for "all users" [attachment=0]synergy properties.jpg[/attachment] I hope this works for you. Thanks, Afie

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this