Sam Sketty

Synergy won't connect to Server using a dynamic IPs

6 posts in this topic

Hi All, Just bought Synergy and it's up and running between two 10.8.5 Mac Pros'. I'd prefer not to have a static IP on the 'Server' Mac, so is there a way of getting Synergy to allow the 'Client' mac to connect to the 'Server' when it's using DHCP IP not a static IP? I've tried 'Auto Config' but the 'Client' mac keeps going into a loop stating 'Host down…timed out etc.' Thank you for taking the time to read the post! Cheers, S

Share this post


Link to post
Share on other sites
The Wizard doesn't help you? You can find it on the menu bar, "File"->"Run Wizard".

Share this post


Link to post
Share on other sites
Hi Fujiwara-san, Thanks for your reply. The wizard doesn't seem to auto config the IP for the client. When i boot up the mac (server), when set to DHCP, as random IP is assigned. When i boot up the Client mac and Synergy launches, it doesn't see the server even if i run the wizard. To make them both see each other, i set the server mac to a static IP and set that IP in the Client dialog box of the client mac. It's not a big thing but, when i was testing out Synergy 1.0 i think, it used to work very well. Cheers, S

Share this post


Link to post
Share on other sites
Hi Sam, Bonjour resolves name of each mac. Are the server's screen name and the client's screen name (which can be defined in GUI of the server of synergy) consistent with the "PC name" which is shown in "System Preferences" - " Share" ?

Share this post


Link to post
Share on other sites
Hi Fujiwara-san, Thanks for your reply. Both Client & Server's name are the same in the GUI and SysPrefs/Sharing. Both server & client are set to 'Using DHCP' in SysPrefs/network. On the client mac, the synergy GUI shows the screen name in the client dialog and 'Auto Config' is ticked. The server IP shows the current IP assigned by the server mac. On the server mac, the synergy GUI server dialog shows the IP and the 'Configure interactively' is selected. When set as above, all works well but if i restart both macs', i have to re-input the server IP in the client 'server IP' dialog box. For some reason the client mac doesn't retrieve the dynamic IP from the server when it's assigned. Thanks, Sam

Share this post


Link to post
Share on other sites
Can you change the screen name of client/server so that they are consistent with NetBios Name of them (SysPref/Network/Detail/WINS)? (I have not tested this yet.)

Share this post


Link to post
Share on other sites
Sorry for my late reply, was focusing on another issue. Will give it a try tomorrow. For now, I've set the Server MacPro to 'DHCP with manual address' and the Client MacPro is set to that fixed IP (Server IP:) with auto confiq ticked. It seems to work but would prefer to have the server MP set to 'Using DCHP' but hey ho ;)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now