Lyle Ryan

install problems w Fedora 22 server & Windows 7 client

7 posts in this topic

Hello Forum Members: I've left support requests and made phone calls, but no response from Support. Maybe the community can answer. Using 1.7.5 with a Pro subscription, I've got a Fedora 22 Workstation set up as a server, and a Windows 7 laptop set up as a client. Just taking the defaults, both systems appear to use port 24800. They are on different networks. The Windows laptop can ping the IP address of the Fedora workstation, and the client screen shows it repeatedly trying to connect to the server on port 24800. The Fedora workstation can not ping the IP address of the Windows machine, and the server screen just shows "waiting for clients" Any advice? I'm thinkin I need a static route on Fedora box to get me to the Windows laptop. Thanks....

Share this post


Link to post
Share on other sites
[quote]The Windows laptop can ping the IP address of the Fedora workstation,[/quote] [quote]The Fedora workstation can not ping the IP address of the Windows machine,[/quote] Probably the static routing windows->Router 2 -> Router 1->fedora has been established. So the opposite direction should be set too in fedora.

Share this post


Link to post
Share on other sites
Yes, it seems to be the lack of routing from the linux machine back to the windows machine. I'm working with our network guys. Any opinions on this: I could get a usb-to-ethernet adapter for the laptop & give it an second address in the network of the linux box. The two boxes are right next to each other. Thanks...

Share this post


Link to post
Share on other sites
So my question to the Forum is: If I got a second ethernet interface for my laptop and gave it an address in the same network that my linux box is in, can I have Synergy use that interface? Looks to me like that's what the "Interface" option is for, under the Windows client settings. Right now, that option is blank. Not sure what to put there when I have a second NIC....IP address of the second interface maybe? Thanks....

Share this post


Link to post
Share on other sites
[quote]If I got a second ethernet interface for my laptop and gave it an address in the same network that my linux box is in, can I have Synergy use that interface?[/quote] Yes, (1) Server find Settings->Miscellaneous-> Interface and put the IP address that you want to use as a server. (2) Client uncheck auto config and input the IP address of the server.

Share this post


Link to post
Share on other sites
Both machines are on the same network now, and routes on each look correct. I'm using the IP addresses in the configs as suggested, and run the Wizard several times. But I still get "failed to connect to server: Timed out". I've read a lot of posts on that subject, and it's sad that nobody from support seems to be able to solve users problems. And count me among the legion of people who paid for support or Pro editions, but can't get an answer or an email back. Grrrr.... In any case, my Windows 7 client can ping the server, but the Linux server can not ping the client. Someone suggested our corporate config of the Windows firewall could be to blame (being more sensitive to incoming connections, than outgoing connections). When I look at the Synergy entry under "Allowed programs", there's a check box for "home" and "public", but not for "Domain". I'm at work, so I'm guessing the domain rules apply. Could this be the problem? Thanks....

Share this post


Link to post
Share on other sites
It is just an idea, "Windows Firewall" -> "Allow a program or feature through Windows Firewall" -> "Allow another program" ->"Browse" then select "Program Files/Synergy/synergyc" and allow it. synergyc : client synergys : server

Share this post


Link to post
Share on other sites
I had the same problem, it worked from laptop to pc but got timed out from the other way. I found that if I turn of the firewall it solves the problem. So I added a rule to firewall as "Yuya Fujiwara" mentioned and it did the trick

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now