Sign in to follow this  
Mike Price

No longer able to 'connect' my two computers

4 posts in this topic

I have been using Synergy between my Mac and my Windows 7 Pro pc, without issue. However, I suddenly found that I could only connect my Mac (as a server) and my PC (as a client) and not the other way around. So I tried reconfiguring the server on both machines (showing the layout of each correctly), uninstalled and reinstalled (after clearing out the cache from the originally installed programmes), etc. Now they won't work at all. I just get continual 'Warning: failed to connect to server. Connection was refused'. So I can't use this software and am back to having 2 x keyboards and 2 x mouse on my desk. Which is a pain. On the Mac, when I try to use it as the 'client', I get the following: 16-01-19T10:58:51] NOTE: connecting to '192.168.1.66': 192.168.1.66:24800 [2016-01-19T10:58:51] WARNING: failed to connect to server: cannot connect socket: Host is down [2016-01-19T10:58:51] DEBUG1: connecting to server [2016-01-19T10:58:51] DEBUG1: connection failed [2016-01-19T10:58:51] DEBUG: retry in 1 seconds [2016-01-19T10:58:52] NOTE: connecting to '192.168.1.66': 192.168.1.66:24800 [2016-01-19T10:58:52] WARNING: failed to connect to server: cannot connect socket: Host is down [2016-01-19T10:58:52] DEBUG1: connecting to server [2016-01-19T10:58:52] DEBUG1: connection failed [2016-01-19T10:58:52] DEBUG: retry in 1 seconds (over and over again.) On the PC, acting as the Server, I simply get a pile of 'errors codes ('failed to start server / failed in init synwinhk.dll / etc.) Can't copy this over as the bloody programme is not working (so no copy and paste facility between my screens!) Any ideas? Edited by Guest

Share this post


Link to post
Share on other sites
No reply from anyone, so trying again. Have now downloaded the most recent 'stable' version, onto both Mac and Windows PC. Got the installation on the PC to 'repair' the installation, then re-ran the Wizard on both computers, setting the Windows PC as the 'server' and the Mac as the 'client'. But still no joy - I immediately get the following (stars 'hide' the name of my iMac): [2016-01-22T08:36:45] INFO: watchdog status: error [2016-01-22T08:37:01] INFO: zeroconf client detected: ******** iMac [2016-01-22T08:37:08] INFO: starting server [2016-01-22T08:37:08] INFO: config file: C:/Users/MikeP/AppData/Local/Temp/qt_temp.sv8332 [2016-01-22T08:37:08] INFO: log level: INFO [2016-01-22T08:37:08] INFO: service command updated [2016-01-22T08:37:09] INFO: starting new process [2016-01-22T08:37:09] INFO: activeDesktop:Default [2016-01-22T08:37:09] INFO: starting new process [2016-01-22T08:37:09] INFO: drag and drop enabled [2016-01-22T08:37:09] ERROR: cannot read configuration "C:/Users/MikeP/AppData/Local/Temp/qt_temp.cr8332": read error: line 9: invalid character 0xffffff92 synergys.exe: no configuration available [2016-01-22T08:37:10] ERROR: failed to launch, error: process immediately stopped [2016-01-22T08:37:10] INFO: backing off, wait=2s, failures=1 [2016-01-22T08:37:12] INFO: starting new process [2016-01-22T08:37:12] INFO: activeDesktop:Default [2016-01-22T08:37:12] INFO: starting new process [2016-01-22T08:37:12] INFO: drag and drop enabled [2016-01-22T08:37:12] ERROR: cannot read configuration "C:/Users/MikeP/AppData/Local/Temp/qt_temp.cr8332": read error: line 9: invalid character 0xffffff92 synergys.exe: no configuration available [2016-01-22T08:37:13] ERROR: failed to launch, error: process immediately stopped [2016-01-22T08:37:13] INFO: backing off, wait=4s, failures=2 [2016-01-22T08:37:17] INFO: starting new process [2016-01-22T08:37:17] INFO: activeDesktop:Default [2016-01-22T08:37:17] INFO: starting new process [2016-01-22T08:37:17] INFO: drag and drop enabled [2016-01-22T08:37:17] ERROR: cannot read configuration "C:/Users/MikeP/AppData/Local/Temp/qt_temp.cr8332": read error: line 9: invalid character 0xffffff92 synergys.exe: no configuration available [2016-01-22T08:37:18] ERROR: failed to launch, error: process immediately stopped [2016-01-22T08:37:18] INFO: backing off, wait=6s, failures=3 [2016-01-22T08:37:24] INFO: starting new process [2016-01-22T08:37:24] INFO: activeDesktop:Default [2016-01-22T08:37:24] INFO: starting new process [2016-01-22T08:37:24] INFO: drag and drop enabled [2016-01-22T08:37:24] ERROR: cannot read configuration "C:/Users/MikeP/AppData/Local/Temp/qt_temp.cr8332": read error: line 9: invalid character 0xffffff92 synergys.exe: no configuration available [2016-01-22T08:37:25] ERROR: failed to launch, error: process immediately stopped [2016-01-22T08:37:25] INFO: backing off, wait=8s, failures=4 Anyone have any ideas on this? I cannot for the life of me work out why this has stopped working, I could really do with getting this fixed as I need to run both the PC and Mac all day, next to each other.

Share this post


Link to post
Share on other sites
On the Mac computer, this is what I am getting: [2016-01-22T08:50:37] WARNING: failed to connect to server: Connection refused [2016-01-22T08:50:38] NOTE: connecting to '192.168.1.65': 192.168.1.65:24810 [2016-01-22T08:50:38] WARNING: failed to connect to server: Connection refused [2016-01-22T08:50:39] NOTE: connecting to '192.168.1.65': 192.168.1.65:24810 [2016-01-22T08:50:39] WARNING: failed to connect to server: Connection refused [2016-01-22T08:50:40] NOTE: connecting to '192.168.1.65': 192.168.1.65:24810 [2016-01-22T08:50:40] WARNING: failed to connect to server: Connection refused [2016-01-22T08:50:41] NOTE: connecting to '192.168.1.65': 192.168.1.65:24810 [2016-01-22T08:50:41] WARNING: failed to connect to server: Connection refused [2016-01-22T08:50:42] NOTE: connecting to '192.168.1.65': 192.168.1.65:24810 [2016-01-22T08:50:42] WARNING: failed to connect to server: Connection refused [2016-01-22T08:50:43] WARNING: failed to connect to server: Connection refused [2016-01-22T08:50:43] NOTE: connecting to '192.168.1.65': 192.168.1.65:24810 [2016-01-22T08:50:44] WARNING: failed to connect to server: Connection refused [2016-01-22T08:50:44] NOTE: connecting to '192.168.1.65': 192.168.1.65:24810 [2016-01-22T08:50:45] WARNING: failed to connect to server: Connection refused [2016-01-22T08:50:45] NOTE: connecting to '192.168.1.65': 192.168.1.65:24810 [2016-01-22T08:50:46] WARNING: failed to connect to server: Connection refused [2016-01-22T08:50:46] NOTE: connecting to '192.168.1.65': 192.168.1.65:24810 [2016-01-22T08:50:47] NOTE: connecting to '192.168.1.65': 192.168.1.65:24810 [2016-01-22T08:50:47] WARNING: failed to connect to server: Connection refused [2016-01-22T08:50:48] NOTE: connecting to '192.168.1.65': 192.168.1.65:24810 [2016-01-22T08:50:48] WARNING: failed to connect to server: Connection refused [2016-01-22T08:50:49] NOTE: connecting to '192.168.1.65': 192.168.1.65:24810 [2016-01-22T08:50:49] WARNING: failed to connect to server: Connection refused [2016-01-22T08:50:50] NOTE: connecting to '192.168.1.65': 192.168.1.65:24810 [2016-01-22T08:50:50] WARNING: failed to connect to server: Connection refused I have checked that the name of the computer is the same as in System Preferences, I have uninstalled / reinstalled, removed the MAC from the 'Configure Server' on the PC and then it asks me to show where the Mac is when i restart Synergy (off to the left of the PC), but still no joy at all.

Share this post


Link to post
Share on other sites
Don't use "auto config" Try putting the actual computer name of the host in on the client side.

Share this post


Link to post
Share on other sites
This is known issue, not fixed for 3 years: [url]http://superuser.com/questions/488913/error-about-synrgyhk-dll-when-starting-synergy[/url] [url]https://github.com/symless/synergy/issues/4957[/url] This is really sad, that paid product has such flaw, that basically makes it useless.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this