Paul Johnson

1.7.5 on Mac OSX 10.11.2 Keyboard stops connecting

21 posts in this topic

I'm running Synergy 1.7.5 on two Mac's, an iMac and a Macbook Pro. Both are running OSX 10.11.2. When I first start Synergy the keyboard transfers correctly but after about 15 minutes, it stops transferring the key strokes to the client and instead inputs only on the server. This started after my upgrade to 10.11.2 from 10.11.1 so I think it's Mac related. Anyone else experiencing this issue?

Share this post


Link to post
Share on other sites
Disregard. I tried uninstalling my Sophos Antivirus and Synergy started working perfectly again.

Share this post


Link to post
Share on other sites
Yes, I'm having the same problem. Mouse input is passing between the Mac's properly, but keyboard is not. It works for a few minutes, then stops passing keystrokes between machines. Both machines running OS X 10.11.2. I've attempted turning off auto-config and using a manual configuration, but that doesn't resolve the issue. Starting and restarting the processes, or exiting and restarting Synergy also do not resolve the issue. I've also tried reversing client/server roles and passing keystrokes back the other way, and that doesn't work either. Rebooting, restarting the machines will work temporarily, but as Paul noted, it doesn't work for long.

Share this post


Link to post
Share on other sites
Possibly also related, the ability to highlight text with mouse button held down while on the Client machine no longer works either.

Share this post


Link to post
Share on other sites
[quote="JonL"]Yes, I'm having the same problem. Mouse input is passing between the Mac's properly, but keyboard is not. It works for a few minutes, then stops passing keystrokes between machines. Both machines running OS X 10.11.2. I've attempted turning off auto-config and using a manual configuration, but that doesn't resolve the issue. Starting and restarting the processes, or exiting and restarting Synergy also do not resolve the issue. I've also tried reversing client/server roles and passing keystrokes back the other way, and that doesn't work either. Rebooting, restarting the machines will work temporarily, but as Paul noted, it doesn't work for long.[/quote] I've tried pretty much everything I know to get it to work. It's very annoying as I love using my personal machine on the side while I'm at work. I also would like to note that my keyboard stopped transferring after about 1 minute today with no non-startup programs running on either machine with exception of synergy. Programs that I pretty much always run are listed below. On Server machine (iMac): Synergy Finder (I do mount network drives if that counts...) Google Chrome Google Drive FileMaker Pro 14 Sublime Text 2 Codekit Skitch Adobe Creative Suite Manager USB Overdrive (to make my mouse buttons work) Sophos Antivirus (uninstalled but needs to be running) On Client (Macbook Pro): Finder Synergy Sophos Antivirus Google Chrome Google Drive Slack Mozilla Thunderbird iMessage Adobe Creative Suite Manager Maybe this can help the synergy team figure out if there is a correlation between programs. Anyway, I hope y'all figure out this bug quickly.

Share this post


Link to post
Share on other sites
Yep, it's unfortunately made Synergy completely unusable atm. :( Synergy team - any chance we can help hunt logs for you on this issue? [quote="Paul Johnson"][quote="JonL"]Yes, I'm having the same problem. Mouse input is passing between the Mac's properly, but keyboard is not. It works for a few minutes, then stops passing keystrokes between machines. Both machines running OS X 10.11.2. I've attempted turning off auto-config and using a manual configuration, but that doesn't resolve the issue. Starting and restarting the processes, or exiting and restarting Synergy also do not resolve the issue. I've also tried reversing client/server roles and passing keystrokes back the other way, and that doesn't work either. Rebooting, restarting the machines will work temporarily, but as Paul noted, it doesn't work for long.[/quote] I've tried pretty much everything I know to get it to work. It's very annoying as I love using my personal machine on the side while I'm at work. I also would like to note that my keyboard stopped transferring after about 1 minute today with no non-startup programs running on either machine with exception of synergy. Programs that I pretty much always run are listed below. On Server machine (iMac): Synergy Finder (I do mount network drives if that counts...) Google Chrome Google Drive FileMaker Pro 14 Sublime Text 2 Codekit Skitch Adobe Creative Suite Manager USB Overdrive (to make my mouse buttons work) Sophos Antivirus (uninstalled but needs to be running) On Client (Macbook Pro): Finder Synergy Sophos Antivirus Google Chrome Google Drive Slack Mozilla Thunderbird iMessage Adobe Creative Suite Manager Maybe this can help the synergy team figure out if there is a correlation between programs. Anyway, I hope y'all figure out this bug quickly.[/quote]

Share this post


Link to post
Share on other sites
This is happening for me as well. I even purchased Synergy to get the pre-compiled version but no luck. * Mac OSX 10.11.2 server * Win 10 client

Share this post


Link to post
Share on other sites
I'm not a member of synergy team, but I can tell how to get a more precise log of synergy. Go "Synergy"->"Settings"->"Logging Level" and you can change the level.(Default=info.)

Share this post


Link to post
Share on other sites
OK, here's my Server and Client Logs for the same time: [b]Server:[/b] [2016-01-25T07:28:18] DEBUG2: mouse move +726,+448 [2016-01-25T07:28:18] DEBUG2: onMouseMoveSecondary +6,-2 [2016-01-25T07:28:18] DEBUG2: move on Neoworks-JL-Macbook.local to 671,323 [2016-01-25T07:28:18] DEBUG2: send mouse move to "Neoworks-JL-Macbook.local" 671,323 [2016-01-25T07:28:18] DEBUG2: writef(DMMV%2i%2i) [2016-01-25T07:28:18] DEBUG2: wrote 8 bytes [2016-01-25T07:28:18] DEBUG2: writing secure socket:0x79399db0 [2016-01-25T07:28:18] DEBUG2: reading secure socket [2016-01-25T07:28:18] DEBUG2: reading secure socket [2016-01-25T07:28:18] DEBUG2: want to read, error=2, attempt=1 [2016-01-25T07:28:18] DEBUG2: msg from "Neoworks-JL-Macbook.local": CNOP [2016-01-25T07:28:18] DEBUG2: no-op from [2016-01-25T07:28:18] DEBUG2: mouse move +733,+450 [2016-01-25T07:28:18] DEBUG2: onMouseMoveSecondary +13,+0 [2016-01-25T07:28:18] DEBUG2: move on Neoworks-JL-Macbook.local to 684,323 [2016-01-25T07:28:18] DEBUG2: send mouse move to "Neoworks-JL-Macbook.local" 684,323 [2016-01-25T07:28:18] DEBUG2: writef(DMMV%2i%2i) [2016-01-25T07:28:18] DEBUG2: wrote 8 bytes [2016-01-25T07:28:18] DEBUG2: writing secure socket:0x79399db0 [2016-01-25T07:28:18] DEBUG2: reading secure socket [2016-01-25T07:28:18] DEBUG2: reading secure socket [2016-01-25T07:28:18] DEBUG2: want to read, error=2, attempt=1 [2016-01-25T07:28:18] DEBUG2: msg from "Neoworks-JL-Macbook.local": CNOP [2016-01-25T07:28:18] DEBUG2: no-op from [2016-01-25T07:28:18] DEBUG2: mouse move +737,+450 [2016-01-25T07:28:18] DEBUG2: onMouseMoveSecondary +17,+0 [2016-01-25T07:28:18] DEBUG2: move on Neoworks-JL-Macbook.local to 701,323 [2016-01-25T07:28:18] DEBUG2: send mouse move to "Neoworks-JL-Macbook.local" 701,323 [2016-01-25T07:28:18] DEBUG2: writef(DMMV%2i%2i) [2016-01-25T07:28:18] DEBUG2: wrote 8 bytes [2016-01-25T07:28:18] DEBUG2: writing secure socket:0x79399db0 [2016-01-25T07:28:18] DEBUG2: reading secure socket [2016-01-25T07:28:18] DEBUG2: reading secure socket [2016-01-25T07:28:18] DEBUG2: want to read, error=2, attempt=1 [2016-01-25T07:28:18] DEBUG2: msg from "Neoworks-JL-Macbook.local": CNOP [2016-01-25T07:28:18] DEBUG2: no-op from [2016-01-25T07:28:18] DEBUG2: mouse move +747,+451 [2016-01-25T07:28:18] DEBUG2: onMouseMoveSecondary +27,+1 [2016-01-25T07:28:18] DEBUG2: move on Neoworks-JL-Macbook.local to 728,324 [2016-01-25T07:28:18] DEBUG2: send mouse move to "Neoworks-JL-Macbook.local" 728,324 [2016-01-25T07:28:18] DEBUG2: writef(DMMV%2i%2i) [2016-01-25T07:28:18] DEBUG2: wrote 8 bytes [2016-01-25T07:28:18] DEBUG2: writing secure socket:0x79399db0 [2016-01-25T07:28:18] DEBUG2: reading secure socket [2016-01-25T07:28:18] DEBUG2: reading secure socket [2016-01-25T07:28:18] DEBUG2: want to read, error=2, attempt=1 [b]Client:[/b] [2016-01-25T07:28:18] DEBUG2: reading secure socket [2016-01-25T07:28:18] DEBUG2: reading secure socket [2016-01-25T07:28:18] DEBUG2: want to read, error=2, attempt=1 [2016-01-25T07:28:18] DEBUG2: msg from server: DMMV [2016-01-25T07:28:18] DEBUG2: readf(%2i%2i) [2016-01-25T07:28:18] DEBUG2: readf: read 2 byte integer: 671 (0x29f) [2016-01-25T07:28:18] DEBUG2: readf: read 2 byte integer: 323 (0x143) [2016-01-25T07:28:18] DEBUG2: recv mouse move 671,323 [2016-01-25T07:28:18] DEBUG2: writef(CNOP) [2016-01-25T07:28:18] DEBUG2: wrote 4 bytes [2016-01-25T07:28:18] DEBUG2: writing secure socket:0x7b12eb70 [2016-01-25T07:28:18] DEBUG2: reading secure socket [2016-01-25T07:28:18] DEBUG2: reading secure socket [2016-01-25T07:28:18] DEBUG2: want to read, error=2, attempt=1 [2016-01-25T07:28:18] DEBUG2: msg from server: DMMV [2016-01-25T07:28:18] DEBUG2: readf(%2i%2i) [2016-01-25T07:28:18] DEBUG2: readf: read 2 byte integer: 684 (0x2ac) [2016-01-25T07:28:18] DEBUG2: readf: read 2 byte integer: 323 (0x143) [2016-01-25T07:28:18] DEBUG2: recv mouse move 684,323 [2016-01-25T07:28:18] DEBUG2: writef(CNOP) [2016-01-25T07:28:18] DEBUG2: wrote 4 bytes [2016-01-25T07:28:18] DEBUG2: writing secure socket:0x7b12eb70 [2016-01-25T07:28:18] DEBUG2: reading secure socket [2016-01-25T07:28:18] DEBUG2: reading secure socket [2016-01-25T07:28:18] DEBUG2: want to read, error=2, attempt=1 [2016-01-25T07:28:18] DEBUG2: msg from server: DMMV [2016-01-25T07:28:18] DEBUG2: readf(%2i%2i) [2016-01-25T07:28:18] DEBUG2: readf: read 2 byte integer: 701 (0x2bd) [2016-01-25T07:28:18] DEBUG2: readf: read 2 byte integer: 323 (0x143) [2016-01-25T07:28:18] DEBUG2: recv mouse move 701,323 [2016-01-25T07:28:18] DEBUG2: writef(CNOP) [2016-01-25T07:28:18] DEBUG2: wrote 4 bytes [2016-01-25T07:28:18] DEBUG2: writing secure socket:0x7b12eb70 [2016-01-25T07:28:18] DEBUG2: reading secure socket [2016-01-25T07:28:18] DEBUG2: reading secure socket [2016-01-25T07:28:18] DEBUG2: want to read, error=2, attempt=1 [2016-01-25T07:28:18] DEBUG2: msg from server: DMMV [2016-01-25T07:28:18] DEBUG2: readf(%2i%2i)

Share this post


Link to post
Share on other sites
I'm having the same issue on 1.7.5 but I didn't see it until I upgraded the server side to OS X 10.11.3 and applied the latest security patch on the client OS X 10.10.5.

Share this post


Link to post
Share on other sites
BUMP! Was working fine, then it's just got unusable Server: Windows 10 Client: Mac 10.11.3

Share this post


Link to post
Share on other sites
I'm having the same problem - server is running OS X Yosemite 10.10.5, client is running El Capitan 10.11.4 Beta (though I was having the problem before I installed the beta, on regular El Capitan). Help!

Share this post


Link to post
Share on other sites
More info on this. IF I start the server computer, with NO programs running, then start the client computer and run programs, I can still pass keyboard strokes back and forth between machines. AS SOON AS I use the keyboard on the server computer and have entered text in whatever program, the ability to to pass keyboard strokes to the client machine stops. App focus on the server/host binds keyboard to host only.

Share this post


Link to post
Share on other sites
[quote="JonL"]More info on this. IF I start the server computer, with NO programs running, then start the client computer and run programs, I can still pass keyboard strokes back and forth between machines. AS SOON AS I use the keyboard on the server computer and have entered text in whatever program, the ability to to pass keyboard strokes to the client machine stops. App focus on the server/host binds keyboard to host only.[/quote] I've noticed this too. It seems that it works until I use the clipboard on the server computer.

Share this post


Link to post
Share on other sites
I have a mac mini (El Capitan 10.11.13) as the server and a macbook pro (El Capitan 10.11.13) as the client. I use Sublime text and IntelliJIDEA java IDE on the macbook prod (client). Every few minutes, I wont be able to input/delete text from IntelliJIDEA, minimizing it and maximizing it again resolves the issue temporarily. Please fix soon.

Share this post


Link to post
Share on other sites
[quote="JonL"]Unfortunately, it does not appear that 1.7.6 fixes this issue. :([/quote] Yeah I've upgraded my machines to Mac OSX 10.11.4 and am running Synergy 1.7.6. Still not working.

Share this post


Link to post
Share on other sites
I am getting only intermittent connections. Even when connected there is delay in mouse movement. But conenction lasts only a few seconds before it. Here's sample log: [2016-04-05T10:07:12] NOTE: connecting to '192.168.0.3': 192.168.0.3:24800 [2016-04-05T10:07:12] WARNING: cursor may not be visible [2016-04-05T10:07:12] NOTE: connected to server [2016-04-05T10:07:43] NOTE: server is dead [2016-04-05T10:07:43] WARNING: failed to connect to server: server is not responding [2016-04-05T10:07:44] NOTE: connecting to '192.168.0.3': 192.168.0.3:24800 [2016-04-05T10:07:44] WARNING: cursor may not be visible [2016-04-05T10:07:44] NOTE: connected to server [2016-04-05T10:08:17] NOTE: server is dead [2016-04-05T10:08:17] WARNING: failed to connect to server: server is not responding [2016-04-05T10:08:18] NOTE: connecting to '192.168.0.3': 192.168.0.3:24800 [2016-04-05T10:08:18] WARNING: cursor may not be visible [2016-04-05T10:08:18] NOTE: connected to server [2016-04-05T10:08:30] NOTE: server is dead [2016-04-05T10:08:30] WARNING: failed to connect to server: server is not responding [2016-04-05T10:08:31] NOTE: connecting to '192.168.0.3': 192.168.0.3:24800 [2016-04-05T10:08:31] WARNING: cursor may not be visible [2016-04-05T10:08:31] NOTE: connected to server [2016-04-05T10:08:52] NOTE: server is dead [2016-04-05T10:08:52] WARNING: failed to connect to server: server is not responding [2016-04-05T10:08:53] NOTE: connecting to '192.168.0.3': 192.168.0.3:24800 [2016-04-05T10:08:53] WARNING: cursor may not be visible [2016-04-05T10:08:53] NOTE: connected to server [2016-04-05T10:09:20] NOTE: server is dead [2016-04-05T10:09:20] WARNING: failed to connect to server: server is not responding [2016-04-05T10:09:21] NOTE: connecting to '192.168.0.3': 192.168.0.3:24800 [2016-04-05T10:09:21] WARNING: cursor may not be visible [2016-04-05T10:09:21] NOTE: connected to server [2016-04-05T10:09:26] INFO: entering screen [2016-04-05T10:09:26] WARNING: cursor may not be visible [2016-04-05T10:09:26] INFO: clipboard was updated [2016-04-05T10:09:26] INFO: clipboard was updated [2016-04-05T10:09:30] INFO: leaving screen [2016-04-05T10:09:30] WARNING: cursor may not be visible [2016-04-05T10:10:22] NOTE: server is dead [2016-04-05T10:10:22] WARNING: failed to connect to server: server is not responding [2016-04-05T10:10:23] NOTE: connecting to '192.168.0.3': 192.168.0.3:24800 [2016-04-05T10:10:23] WARNING: cursor may not be visible [2016-04-05T10:10:23] NOTE: connected to server [2016-04-05T10:10:41] NOTE: server is dead [2016-04-05T10:10:41] WARNING: failed to connect to server: server is not responding [2016-04-05T10:10:42] NOTE: connecting to '192.168.0.3': 192.168.0.3:24800 [2016-04-05T10:10:42] WARNING: cursor may not be visible [2016-04-05T10:10:42] NOTE: connected to server [2016-04-05T10:10:51] NOTE: server is dead [2016-04-05T10:10:51] WARNING: failed to connect to server: server is not responding [2016-04-05T10:10:52] NOTE: connecting to '192.168.0.3': 192.168.0.3:24800 [2016-04-05T10:10:52] WARNING: cursor may not be visible [2016-04-05T10:10:52] NOTE: connected to server [2016-04-05T10:11:22] NOTE: server is dead [2016-04-05T10:11:22] WARNING: failed to connect to server: server is not responding [2016-04-05T10:11:23] NOTE: connecting to '192.168.0.3': 192.168.0.3:24800 [2016-04-05T10:11:23] WARNING: cursor may not be visible [2016-04-05T10:11:23] NOTE: connected to server [2016-04-05T10:11:43] NOTE: server is dead [2016-04-05T10:11:43] WARNING: failed to connect to server: server is not responding [2016-04-05T10:11:44] NOTE: connecting to '192.168.0.3': 192.168.0.3:24800 [2016-04-05T10:11:44] WARNING: cursor may not be visible [2016-04-05T10:11:44] NOTE: connected to server [2016-04-05T10:12:20] NOTE: server is dead [2016-04-05T10:12:20] WARNING: failed to connect to server: server is not responding [2016-04-05T10:12:21] NOTE: connecting to '192.168.0.3': 192.168.0.3:24800 [2016-04-05T10:12:21] WARNING: cursor may not be visible [2016-04-05T10:12:21] NOTE: connected to server [2016-04-05T10:12:42] NOTE: server is dead [2016-04-05T10:12:42] WARNING: failed to connect to server: server is not responding [2016-04-05T10:12:43] NOTE: connecting to '192.168.0.3': 192.168.0.3:24800 [2016-04-05T10:12:43] WARNING: cursor may not be visible [2016-04-05T10:12:43] NOTE: connected to server [2016-04-05T10:12:58] NOTE: server is dead [2016-04-05T10:12:58] WARNING: failed to connect to server: server is not responding [2016-04-05T10:12:59] NOTE: connecting to '192.168.0.3': 192.168.0.3:24800 [2016-04-05T10:12:59] WARNING: cursor may not be visible [2016-04-05T10:12:59] NOTE: connected to server [2016-04-05T10:13:52] NOTE: server is dead [2016-04-05T10:13:52] WARNING: failed to connect to server: server is not responding [2016-04-05T10:13:53] NOTE: connecting to '192.168.0.3': 192.168.0.3:24800 [2016-04-05T10:13:53] WARNING: cursor may not be visible [2016-04-05T10:13:53] NOTE: connected to server [2016-04-05T10:14:08] NOTE: server is dead [2016-04-05T10:14:08] WARNING: failed to connect to server: server is not responding [2016-04-05T10:14:09] NOTE: connecting to '192.168.0.3': 192.168.0.3:24800 [2016-04-05T10:14:09] WARNING: cursor may not be visible [2016-04-05T10:14:09] NOTE: connected to server [2016-04-05T10:14:48] INFO: entering screen [2016-04-05T10:14:48] INFO: clipboard was updated [2016-04-05T10:14:48] INFO: clipboard was updated [2016-04-05T10:15:27] NOTE: server is dead [2016-04-05T10:15:27] INFO: leaving screen [2016-04-05T10:15:27] WARNING: cursor may not be visible [2016-04-05T10:15:27] WARNING: failed to connect to server: server is not responding [2016-04-05T10:15:28] NOTE: connecting to '192.168.0.3': 192.168.0.3:24800 [2016-04-05T10:15:28] WARNING: cursor may not be visible [2016-04-05T10:15:28] NOTE: connected to server [2016-04-05T10:15:30] INFO: entering screen [2016-04-05T10:15:30] WARNING: cursor may not be visible [2016-04-05T10:15:30] INFO: clipboard was updated [2016-04-05T10:15:30] INFO: clipboard was updated

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now