Sign in to follow this  
Stuart Smith

Dropping windows clients after a bit...Ubuntu server

1 post in this topic

1.7.5 Synergy Pro: Kubuntu 15.04 acting as server, two Windows 7 Pro clients. Server sits in between both clients. Multiple screens attached to all PCs. All the monitors are switchable (using different inputs) to two computers with the center screen attached to all three. Workflow often involves setting all monitors to the Windows clients leaving the server un-viewed but still logically present. I am not using SSL and I am using port 22000 instead of the default. Every so often, both clients will drop connection to synergy. Since they both loose connectivity in the same event, I assume the problem is with the server. It seems to happen randomly or when using the clipboard on one of the clients - but not always. I also don't have consistent clipboard behavior - sometimes I can copy from one PC to another - sometimes not. Often, an attempt at pasting will cause the desktop on the server to freeze for a half a minute or so, then both clients will drop. Often, just clicking on the "Apply" button on the server synergy window will reconnect the clients, sometimes a Stop-Start is required. It also seems like it happens less often if I leave the Synergy window open on the server - which I've taken to since I have to reconnect the clients several times an hour or more. I would really like the ability to clip from one PC to another but it seems problematic. Log snippet from the server set at basic Debug level: [code][2016-01-08T11:35:01] INFO: leaving screen [2016-01-08T11:35:11] DEBUG: received client "FAAMSPTS-PC" grabbed clipboard 0 seqnum=17 [2016-01-08T11:35:11] INFO: screen "FAAMSPTS-PC" grabbed clipboard 0 from "NSG-E5430-006" [2016-01-08T11:35:11] DEBUG: send grab clipboard 0 to "NSG-E5430-006" [2016-01-08T11:35:11] DEBUG: open clipboard 0 [2016-01-08T11:35:11] DEBUG: empty clipboard 0 [2016-01-08T11:35:11] DEBUG: grabbed clipboard 0 [2016-01-08T11:35:11] DEBUG: close clipboard 0 [2016-01-08T11:35:11] DEBUG: received client "FAAMSPTS-PC" grabbed clipboard 1 seqnum=17 [2016-01-08T11:35:11] INFO: screen "FAAMSPTS-PC" grabbed clipboard 1 from "NSG-E5430-006" [2016-01-08T11:35:11] DEBUG: send grab clipboard 1 to "NSG-E5430-006" [2016-01-08T11:35:11] DEBUG: open clipboard 1 [2016-01-08T11:35:11] DEBUG: empty clipboard 1 [2016-01-08T11:35:11] DEBUG: grabbed clipboard 1 [2016-01-08T11:35:11] DEBUG: close clipboard 1 [2016-01-08T11:35:12] INFO: switch from "FAAMSPTS-PC" to "office" at 35,439 [2016-01-08T11:35:12] INFO: entering screen [2016-01-08T11:35:12] DEBUG: start receiving clipboard data [2016-01-08T11:35:12] DEBUG: receiving clipboard 0 size=212 [2016-01-08T11:35:12] DEBUG: received client "FAAMSPTS-PC" clipboard 0 seqnum=17, size=212 [2016-01-08T11:35:12] DEBUG: start receiving clipboard data [2016-01-08T11:35:12] DEBUG: receiving clipboard 1 size=212 [2016-01-08T11:35:12] DEBUG: received client "FAAMSPTS-PC" clipboard 1 seqnum=17, size=212 [2016-01-08T11:35:12] INFO: screen "FAAMSPTS-PC" updated clipboard 0 [2016-01-08T11:35:12] DEBUG: open clipboard 0 [2016-01-08T11:35:12] DEBUG: empty clipboard 0[/code] Let me know what to do to collect more useful info...

Share this post


Link to post
Share on other sites
Upped it to Debug1 and got this below. Client was not available, then all of a sudden was. This happened right after changing to Debug2 and attempt to scroll right. I only tried to slide the pointer - no actions taken on either desktop - server or client. [code][2016-01-08T11:43:54] DEBUG1: no neighbor right [2016-01-08T11:43:54] DEBUG1: try to leave "office" on right [2016-01-08T11:43:54] DEBUG1: no neighbor right [2016-01-08T11:43:54] DEBUG1: try to leave "office" on right [2016-01-08T11:43:54] DEBUG1: no neighbor right [2016-01-08T11:43:54] DEBUG1: try to leave "office" on right [2016-01-08T11:43:54] DEBUG1: no neighbor right [2016-01-08T11:43:54] NOTE: accepted client connection [2016-01-08T11:43:54] DEBUG1: saying hello [2016-01-08T11:43:54] DEBUG1: parsing hello reply [2016-01-08T11:43:54] DEBUG1: querying client "NSG-E5430-006" info [2016-01-08T11:43:54] DEBUG1: created proxy for client "NSG-E5430-006" version 1.6 [2016-01-08T11:43:54] DEBUG: received client "NSG-E5430-006" info shape=-1920,0 3840x1080 at 0,0 [2016-01-08T11:43:54] DEBUG1: send info ack to "NSG-E5430-006" [2016-01-08T11:43:54] NOTE: client "NSG-E5430-006" has connected [2016-01-08T11:43:54] DEBUG1: send reset options to "NSG-E5430-006" [2016-01-08T11:43:54] DEBUG1: send set options to "NSG-E5430-006" size=22 [2016-01-08T11:43:55] DEBUG1: try to leave "office" on right [2016-01-08T11:43:55] INFO: switch from "office" to "NSG-E5430-006" at -1920,420 [2016-01-08T11:43:55] INFO: leaving screen [2016-01-08T11:43:55] DEBUG1: grabbed pointer and keyboard [2016-01-08T11:43:55] DEBUG1: modifiers on update: 0x2000 [2016-01-08T11:43:55] DEBUG: open clipboard 0 [2016-01-08T11:43:55] DEBUG1: locked motif clipboard [2016-01-08T11:43:55] DEBUG1: motif does not own clipboard [2016-01-08T11:43:55] DEBUG1: unlocked motif clipboard [2016-01-08T11:43:55] DEBUG1: request selection=CLIPBOARD (314), target=TIMESTAMP (318), window=1200004 [2016-01-08T11:43:55] DEBUG1: target INTEGER (19) [2016-01-08T11:43:55] DEBUG1: got data, 4 bytes [2016-01-08T11:43:55] DEBUG1: request succeeded [2016-01-08T11:43:55] DEBUG1: got ICCCM time 248486201 [2016-01-08T11:43:55] DEBUG: ICCCM fill clipboard 0 [2016-01-08T11:43:55] DEBUG1: request selection=CLIPBOARD (314), target=TARGETS (316), window=1200004 [2016-01-08T11:43:55] DEBUG1: target ATOM (4) [2016-01-08T11:43:55] DEBUG1: got data, 44 bytes [2016-01-08T11:43:55] DEBUG1: request succeeded [2016-01-08T11:43:55] DEBUG: available targets: text/html (626), application/vnd.oasis.opendocument.text (683), text/plain (536), UTF8_STRING (380), STRING (31), TEXT (379) [2016-01-08T11:43:55] DEBUG1: request selection=CLIPBOARD (314), target=text/html (626), window=1200004 [2016-01-08T11:43:55] DEBUG1: target text/html (626) [2016-01-08T11:43:55] DEBUG1: got data, 5294 bytes [2016-01-08T11:43:55] DEBUG1: request succeeded [2016-01-08T11:43:55] DEBUG: added format 2 for target text/html (626) (5294 bytes) [2016-01-08T11:43:55] DEBUG1: request selection=CLIPBOARD (314), target=image/bmp (627), window=1200004 [2016-01-08T11:43:55] DEBUG1: request failed [2016-01-08T11:43:55] DEBUG1: can't get data for selection target image/bmp (627) [2016-01-08T11:43:55] DEBUG1: no data for target image/bmp (627) [2016-01-08T11:43:55] DEBUG1: request selection=CLIPBOARD (314), target=text/plain;charset=UTF-8 (628), window=1200004 [2016-01-08T11:43:55] DEBUG1: request failed [2016-01-08T11:43:55] DEBUG1: can't get data for selection target text/plain;charset=UTF-8 (628) [2016-01-08T11:43:55] DEBUG1: no data for target text/plain;charset=UTF-8 (628) [2016-01-08T11:43:55] DEBUG1: request selection=CLIPBOARD (314), target=UTF8_STRING (380), window=1200004 [2016-01-08T11:43:55] DEBUG1: target UTF8_STRING (380) [2016-01-08T11:43:55] DEBUG1: got data, 1622 bytes [2016-01-08T11:43:55] DEBUG1: request succeeded [2016-01-08T11:43:55] DEBUG: added format 0 for target UTF8_STRING (380) (1622 bytes) [2016-01-08T11:43:55] DEBUG: close clipboard 0 [2016-01-08T11:43:55] INFO: screen "office" updated clipboard 0 [2016-01-08T11:43:55] DEBUG: open clipboard 1 [2016-01-08T11:43:55] DEBUG1: request selection=PRIMARY (1), target=TIMESTAMP (318), window=1200004 [2016-01-08T11:43:55] DEBUG1: request succeeded [2016-01-08T11:43:55] DEBUG1: selection conversion failed for target TIMESTAMP (318) [2016-01-08T11:43:55] DEBUG1: can't get ICCCM time [2016-01-08T11:43:55] DEBUG: ICCCM fill clipboard 1 [2016-01-08T11:43:55] DEBUG1: request selection=PRIMARY (1), target=TARGETS (316), window=1200004 [2016-01-08T11:43:55] DEBUG1: target ATOM (4) [2016-01-08T11:43:55] DEBUG1: got data, 28 bytes [2016-01-08T11:43:55] DEBUG1: request succeeded [2016-01-08T11:43:55] DEBUG: available targets: TARGETS (316), SAVE_TARGETS (319), MULTIPLE (317), STRING (31) [2016-01-08T11:43:55] DEBUG1: request selection=PRIMARY (1), target=text/html (626), window=1200004 [2016-01-08T11:43:55] DEBUG1: request succeeded [2016-01-08T11:43:55] DEBUG1: selection conversion failed for target text/html (626) [2016-01-08T11:43:55] DEBUG1: no data for target text/html (626) [2016-01-08T11:43:55] DEBUG1: request selection=PRIMARY (1), target=image/bmp (627), window=1200004 [2016-01-08T11:43:55] DEBUG1: request succeeded [2016-01-08T11:43:55] DEBUG1: selection conversion failed for target image/bmp (627) [2016-01-08T11:43:55] DEBUG1: no data for target image/bmp (627) [2016-01-08T11:43:55] DEBUG1: request selection=PRIMARY (1), target=text/plain;charset=UTF-8 (628), window=1200004 [2016-01-08T11:43:55] DEBUG1: request succeeded [2016-01-08T11:43:55] DEBUG1: selection conversion failed for target text/plain;charset=UTF-8 (628) [2016-01-08T11:43:55] DEBUG1: no data for target text/plain;charset=UTF-8 (628) [2016-01-08T11:43:55] DEBUG1: request selection=PRIMARY (1), target=UTF8_STRING (380), window=1200004 [2016-01-08T11:43:55] DEBUG1: target UTF8_STRING (380) [2016-01-08T11:43:55] DEBUG1: got data, 7 bytes [2016-01-08T11:43:55] DEBUG1: request succeeded [2016-01-08T11:43:55] DEBUG: added format 0 for target UTF8_STRING (380) (7 bytes) [2016-01-08T11:43:55] DEBUG: close clipboard 1 [2016-01-08T11:43:55] INFO: screen "office" updated clipboard 1 [2016-01-08T11:43:55] DEBUG1: send enter to "NSG-E5430-006", -1920,420 1 2000 [2016-01-08T11:43:55] DEBUG1: thread 0x00000003 entry [2016-01-08T11:43:55] DEBUG: sending clipboard 0 to "NSG-E5430-006" [2016-01-08T11:43:55] DEBUG1: sending clipboard chunk [2016-01-08T11:43:55] DEBUG: sent clipboard size=9583 [2016-01-08T11:43:55] DEBUG: sending clipboard 1 to "NSG-E5430-006" [2016-01-08T11:43:55] DEBUG1: sending clipboard chunk [2016-01-08T11:43:55] DEBUG1: sending clipboard chunk [2016-01-08T11:43:55] DEBUG1: sending clipboard chunk [2016-01-08T11:43:55] DEBUG: sent clipboard size=19 [2016-01-08T11:43:55] DEBUG1: thread 0x00000003 exit [2016-01-08T11:43:55] DEBUG1: sending clipboard chunk [2016-01-08T11:43:55] DEBUG1: sending clipboard chunk [2016-01-08T11:43:58] DEBUG1: try to leave "NSG-E5430-006" on left [2016-01-08T11:43:58] INFO: switch from "NSG-E5430-006" to "office" at 5745,623 [2016-01-08T11:43:58] DEBUG1: send leave to "NSG-E5430-006" [2016-01-08T11:43:58] INFO: entering screen [2016-01-08T11:43:58] DEBUG1: thread 0x00000004 entry [2016-01-08T11:43:58] DEBUG1: thread 0x00000004 exit[/code]

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this