Matt Chiste

High Resolution monitor breaks Synergy

16 posts in this topic

I'm having the exact problem described here: viewtopic.php?f=13&t=697&hilit=high+resolution&start=30#p2859: "I don't need to re-start synergy, ctl-alt-del alone restores the mouse pointer to the server. When the mouse pointer is "on" the client I _can_ use the keyboard but I _cannot_ see the pointer. I think that the mouse control is there, I just can't see where the mouse is pointing. Any help would be appreciated." I have a 2-monitor desktop (server) with the main monitor at 3840x2160, and a laptop (client). Dragging off the side of the high-res monitor causes the mouse to just disappear and I can't get control back to the desktop, as the mouse is gone and the keyboard is locked on the laptop. CTRL-ALT-DELETE brings the mouse back to the desktop, but the only workaround to getting Synergy to work at all is to drop the resolution of the main screen to 2560x1440. I'm using Windows 10, and Synergy 1.7.5 64-bit. Any thoughts? Thanks!

Share this post


Link to post
Share on other sites
Odd, 1.7.5 was supposed to fix problems with high rez monitors. First, let's collect some logs so we can try to figure out what else we can try. Open the Edit menu and click Settings. At the bottom, you'll find a drop-down list of how much information you want to be put in the logs. It can get quite noisy. Debug should be sufficient for this purpose. Select Debug, then click OK, then click Apply. Move the mouse until it gets stuck, then use your ctrl-alt-delete to get it back to the server and copy the logs from the time it starts up til the time you switch back. Paste here and we'll see what we can figure out!

Share this post


Link to post
Share on other sites
Thanks for the quick reply! OK I changed the screen rez on my main monitor (shown in the logs), dragged the mouse to the left off the big screen, moved it around a bit (getting thousands of lines in the log, which I snipped, below), and got the following: [2015-12-08T10:40:03] DEBUG: screen shape: 0,0 6400x1440 (multi-monitor) [2015-12-08T10:40:03] DEBUG: screen "MATT-PC" shape changed [2015-12-08T10:40:19] INFO: switch from "MATT-PC" to "MATT-LPTP2" at 1919,917 [2015-12-08T10:40:19] INFO: leaving screen [2015-12-08T10:40:19] DEBUG: open clipboard [2015-12-08T10:40:19] DEBUG: close clipboard [2015-12-08T10:40:19] DEBUG: ignored screen "MATT-PC" update of clipboard 0 (unchanged) [2015-12-08T10:40:19] DEBUG: open clipboard [2015-12-08T10:40:19] DEBUG: close clipboard [2015-12-08T10:40:19] DEBUG: ignored screen "MATT-PC" update of clipboard 1 (unchanged) [2015-12-08T10:40:19] DEBUG: dpi: 1.000000 m_w: 6400 center: 1280 x: 614 [2015-12-08T10:40:19] DEBUG: dpi: 1.000000 m_w: 6400 center: 1280 x: 618 [2015-12-08T10:40:19] DEBUG: dpi: 1.000000 m_w: 6400 center: 1280 x: 616 [2015-12-08T10:40:19] DEBUG: dpi: 1.000000 m_w: 6400 center: 1280 x: 613 [2015-12-08T10:40:19] DEBUG: dpi: 1.000000 m_w: 6400 center: 1280 x: 612 [2015-12-08T10:40:19] DEBUG: dpi: 1.000000 m_w: 6400 center: 1280 x: 612 [ ** SNIP about 2000 lines of these coordinates **] [2015-12-08T10:40:28] DEBUG: dpi: 1.000000 m_w: 6400 center: 1280 x: 641 [2015-12-08T10:40:29] DEBUG: dpi: 1.000000 m_w: 6400 center: 1280 x: 639 [2015-12-08T10:40:31] DEBUG: discard ctrl+alt+del [2015-12-08T10:40:31] DEBUG: shutting down because of desk switch to "" [2015-12-08T10:40:31] NOTE: disconnecting client "MATT-LPTP2" [2015-12-08T10:40:31] INFO: jump from "MATT-LPTP2" to "MATT-PC" at 1280,720 [2015-12-08T10:40:31] INFO: entering screen [2015-12-08T10:40:31] DEBUG: active sides: 2 [2015-12-08T10:40:31] DEBUG: event queue is ready [2015-12-08T10:40:31] NOTE: client "MATT-LPTP2" has disconnected [2015-12-08T10:40:31] DEBUG: unregistered hotkey id=1 [2015-12-08T10:40:31] DEBUG: adopting new buffer [2015-12-08T10:40:31] DEBUG: discarding 1 event(s) [2015-12-08T10:40:31] DEBUG: ipc disconnect, closing stream [2015-12-08T10:40:31] DEBUG: ipc client disconnected [2015-12-08T10:40:31] DEBUG: closed display [2015-12-08T10:40:31] NOTE: stopped server [2015-12-08T10:40:31] DEBUG: ipc disconnect, closing stream

Share this post


Link to post
Share on other sites
What is the rez of your second monitor on the server? Do you have display scaling set differently for each monitor (again on the server)?

Share this post


Link to post
Share on other sites
Ah, Wes, looks like that was it! My two desktop monitor resolutions are: 3840x2160 2560x1440 In Windows Display settings, because the text on the 4k monitor is so tiny, I had the "Change the size of text, apps, and other items" option set to 150% on the 4k monitor and 100% on the other one. If I change them both to 100% then Synergy works as expected. Based on your question, I thought maybe the scaling just had to be the same on both, so I tested both at 125%. But that didn't work either - even if both monitors have the SAME display scaling, Synergy doesn't seem to like it unless the value is 100% on each. Not sure I can deal with squinting at the 4k monitor at 100%, so i'll just drop it back to the same 2560x1440 resolution as the other one and keep an eye out to see if there are fixes to the issue in future updates - unless I can offer any help to you in testing beta builds or anything? Thanks again, Matt

Share this post


Link to post
Share on other sites
The purpose of all these questions is to attempt to identify what didn't work about the fix that was put into 1.7.5. I think the issue now is the different resolutions of the two monitors. If they were both 3840x2160, and you set the scaling level to 150%, I think it would work. Let's try one other thing. Open the C:\Program Files\Synergy folder Right click on synergys.exe and click Properties Switch to the "compatibility" tab Click "Change Settings for all users" (synergys can run as a different user) Click the checkbox for "Deactivate scaling for high DPI value" (the one above run as admin) Click OK Click Apply or Stop/Start in your Synergy app Set your monitors to their normal resolutions and scaling levels. Let me know if that changes anything!

Share this post


Link to post
Share on other sites
I am having the same issue, using a Surface Book with two external displays. The SB's display is high res, but turned off. The two local monitors and the two remote monitors are identical in size (1680x1050) and are not scaled. I have tried the solution posted, but it has not helped.

Share this post


Link to post
Share on other sites
[quote="Evan Youngblood"]I am having the same issue, using a Surface Book with two external displays. The SB's display is high res, but turned off. The two local monitors and the two remote monitors are identical in size (1680x1050) and are not scaled. I have tried the solution posted, but it has not helped.[/quote] Well, I have to eat my own words here. Restarting the service won't do it, but it appears rebooting the serving PC will.

Share this post


Link to post
Share on other sites
Restarting the service probably would not do it, as these settings take effect when the process is launched. The service controls the synergys.exe process, but restarting it does not necessarily guarantee that synergys will be restarted. If you open the Synergy GUI and press Apply, it should work. Of course, rebooting is always a good idea too.

Share this post


Link to post
Share on other sites
[quote="the-wes"]The purpose of all these questions is to attempt to identify what didn't work about the fix that was put into 1.7.5. I think the issue now is the different resolutions of the two monitors. If they were both 3840x2160, and you set the scaling level to 150%, I think it would work. Let's try one other thing. Open the C:\Program Files\Synergy folder Right click on synergys.exe and click Properties Switch to the "compatibility" tab Click "Change Settings for all users" (synergys can run as a different user) Click the checkbox for "Deactivate scaling for high DPI value" (the one above run as admin) Click OK Click Apply or Stop/Start in your Synergy app Set your monitors to their normal resolutions and scaling levels. Let me know if that changes anything![/quote] I'm having the same issue as the OP. Trying all listed solutions didn't help. In my case the native resolutions of the two laptops are vastly different, one being 1080p and the other being 4K. Turning the display scaling to 100% will make the 4K laptop impossible to use practically. Is there s fix for this issue yet?

Share this post


Link to post
Share on other sites
Just to clarify: there is no issue with the resolutions of each different system being different. The issue is with 2 monitors on the _same_ system having different resolutions. If you tried the option to disable DPI scaling on synergys.exe, and it didn't work, I would strongly advise you to revisit this procedure and make sure everything is selected correctly. Almost every time someone said they tried it and it didn't work, and I looked into it, I found that they didn't do it right. Nothing personal on you, but this is my experience. So please check it carefully.

Share this post


Link to post
Share on other sites
No offense taken. I did in fact make sure to disable dpi scaling on synergys.exe on both machines, no change. Reduce the dpi scaling on the 4k machine to 100%, same scaling ratio on the 1080p machine, and it works. In that state, though, the 4k machine stops serving a practical purpose, and reducing the screen resolution to a comfortable level at 100% scale isn't ideal, as there are some applications I like to run in 4k. That being said, the root issue is the same even if the systems are different in that Synergy seems to be unable to work across two screens with different dpi scaling settings, same system or otherwise.

Share this post


Link to post
Share on other sites
I do understand that removing the display scaling from a high-res monitor is impractical. I don't suggest that for most situations. Though it is helpful to know that the problem doesn't happen when you do that. I may be splitting hairs here, but the root cause of the issue is when the Synergy server is using DPI scaling. It doesn't matter on the client. The problem is that Windows then reports the mouse cursor position to Synergy incorrectly - always lower and to the right of the actual position on the server. So, when Synergy tries to relay this to the client, it ends up lower and to the right of wherever it started. It keeps going in that direction until it hits the bottom right corner, where it gets stuck. Disabling DPI scaling (for all users!) fixes it because Windows then does not attempt to translate the mouse position for Synergy. Synergy attempted a code-based fix by reading the screen resolution and DPI scale setting, and re-translating the mouse position based on that. This breaks when the server uses 2 monitors of different DPI scales and/or resolutions. If none of this helps in your situation, then something unique is going on with your system and I have no idea what that could be.

Share this post


Link to post
Share on other sites
Same issue with 1.7.6. I tried the compatibility flag, did not help at all.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now