All Activity

This stream auto-updates     

  1. Today
  2. Mouse Cursor appearing at the middle of the screen?

    I turned off Synergy for the last week. It is wonderful to not have to deal with the cursor getting stuck. Utter joy. Why don't you folks fix this crap. Synergy, back in the day was a wonderful product, those days are long gone. Just for kicks I turned it on to do something on one of my macs. Less than 2 minutes and the freakin' mouse is stuck dead center on server machine. This is crazy.
  3. Yesterday
  4. Last week
  5. Some observations about the screen/mouse freezing problem.

    I've been using Barrier now for a few days and I have seen the problem maybe a couple of times per day max. And even if it happens it only lasts a second or so and is pretty much a non-issue. In Synergy the mouse becomes completely stuck, lasting maybe 10 to 30 seconds or so, unless I would 'break it loose' it by moving the actual mouse on the client computer. It sure would be nice to get at least an official acknowledgment that this is an issue and somebody would start looking at it.
  6. Workaround: macOS WiFi ping spikes

    Setup between Win10 (server) and OSX (client). Didn't get Synergy 1 to work properly, same network, allowed in firewall on both OSes and also in the router. Pings went trough without problems. Really needed this to work to actually utilize the 49" monitor I just got. Took a gamble with Synergy 2, experienced lot of lag and DC from the client. Installed Share-Mouse. Proved itself being 200 times worse. Was just about to give up, at least for now but then i tried this. Decreases lag and keeps the connection alive (still have some DC issues) however seems to work pretty well when using the Mac for longer periods. Basically, I just wanted to say thank you @zachn
  7. Kali Linux Install Failing

    Hi, Was wondering if someone could assist me with the install for Synergy 2 on Kali Linux. I do the following and get back this error and doesn't appear to load the application to the OS Application List [email protected]:-$ sudo dpkg -i /root/Downloads/synergy_2.0.12.beta_b1705+e5daaeda_amd64.deb (Reading database ... 494744 files and directories currently installed.) preparing to unpack .../synergy_2.0.12.beta_b1705+e5daaeda_amd64.deb ... Unpacking synergy (2.0.12.beta-b1705+e5daaeda) ... dpkg: error processing archive /root/Downloads/synergy_2.0.12.beta_b1705+e5daaeda_amd64.deb (--install): unable to open 'user/lib/systemd/system/synergy.service.dpkg-new': No such file or directory Processing triggers for gnome-menus (3.31.4-3) ... Processing triggers for mime-support (3.62) ... Processing triggers for desktop-file-utils (0.23.-4) ... Errors were encountered while processing: /root/Downloads/synergy_2.0.12.beta_b1705+e5daaeda_amd64.deb [email protected]:-$ Any help will be appreciated, just note im very new to the OS and learning as i go along. Regards, Daryl
  8. Linux Mint 19 is based on Ubuntu 18, so you must use synergy_1.10.2.stable_b10 + 8c010140_ubuntu18 _....
  9. Ugh, I had this problem on Ubuntu when Synergy 2 came out. No reason for them to package the .deb with such a high version number. You can probably build from source here: and it will work.
  10. When I went to install v 1.10.2 on my Linux system, I received the error "Dependency is not satisfiable: libqt5core5a (>=5.12.2)". I am on the latest Linux Mint version at the moment (19.1) and this appears to be an issue. I have contacted support.
  11. Auto start on Linux before login

    In case this helps anyone, I finally bothered to get Synergy to auto-start before login for Kubuntu 18.04 (sddm login manager/KDE plasma shell). I'm using systemd to start the process by creating a service file at /etc/systemd/system/synergy.service [Unit] Description=Synergy Service Requires=display-manager.service After=display-manager.service [Service] Type=simple Restart=always RestartSec=3 ExecStartPre=/bin/bash -c "sleep 10; /bin/systemctl set-environment SDDMXAUTH=$(/usr/bin/find /var/run/sddm/ -type f)" ExecStart=/bin/bash -c "XAUTHORITY=${SDDMXAUTH} /opt/synergy-core/build/bin/synergyc -f -n minotaur" [Install] (replace "/opt/synergy-core" and "minotaur" with the path to your install of synergyc and your hostname respectively). You then can enable the service at startup with "sudo systemctl daemon-reload; sudo systemctl enable synergy.service" The ExecStartPre was necessary because the XAuthority file used by SDDM in randomly generated when the process starts. The "sleep" is a bit of a hack to ensure the file was created after the display-manager.service starts. Hope that's helpful for someone out there! Dean
  12. CTRL+ALT+DELETE to a remote machine?

    Fixed by setting "Elevate: Always" on client settings. I also put in the interface IP, but not sure if that matters.
  13. CTRL+ALT+DELETE to a remote machine?

    Running 1.10.2, both client and server are windows 10. ctrl-alt-pause doesn't seem to work. This used to work on my win7 client, but i have updated to win10 on client and this no longer works.
  14. Internet REQUIRED? Collecting information????? VERY UNCOOL !
  15. i bought synergy to work at my office with my mac and my pc (CPU) it NEVER worked. Tried everything for months including this kind of forums. I want a refund, how can i get it? very dissapointed with the program.
  16. Fedora not working (Synergy 2)

    I found that the firewall was holding me back on Synergy. The default FirewallD service for Synergy only listens to port 24800 whereas Synergy2 also needs 24801 and 24802. These commands should update the firewall and allow Synergy: sudo sed -i 's/port="24800"/port="24800-24802"/g' /usr/lib/firewalld/services/synergy.xml sudo firewall-cmd --zone=$(firewall-cmd --get-default-zone) --add-service=synergy --permanent sudo systemctl restart firewalld
  17. Choppy mouse movement on client

    Hello, I am still affected by the jumpy mouse , or choppy how you call it. I experience this in every possible configuration, mac server , mac client / windows client, or reverse . I only need to have 2 computers connected but is not a smooth movement, I can't do nothing on the client side... I have the imac pro and 8700k for example, <1ms ping between the computers, no packets lost I am using the latest of the synergy 2 versions. Should I try version 1 ?
  18. Exclamation mark

    Unfortunately this bug is still there in the latest version (1.10.2-stable-8c010140). Would be great if you guys could fix this ;-)
  19. Synergy 1.10.2 Finally Released

    [Solved] Never mind fixed by going to System Preferences -> Security & Privacy -> Privacy and unchecking and then rechecking the box allowing Synergy to control the computer.
  20. Synergy 1.10.2 Finally Released

    I get constant "There was an error, retrying..." message when trying to start my Synnergy server on my macbook running macOS 10.14 I installed 1.10.2 on both my Win10 client and macbook. Any advice? [2019-05-15T12:53:36] INFO: starting server [2019-05-15T12:53:36] INFO: config file: /Users/edward3/Documents/synergy/synergy.conf [2019-05-15T12:53:36] INFO: log level: INFO [2019-05-15T12:53:36] INFO: drag and drop enabled [2019-05-15T12:53:36] ERROR: failed to create quartz event tap [2019-05-15T12:53:36] ERROR: process exited with error code: 11 [2019-05-15T12:53:36] INFO: detected process not running, auto restarting [2019-05-15T12:53:37] INFO: stopping synergy desktop process Thanks in advance, -Ed
  21. Repository for updates and installation

    I want to bump this as well. I would love it if my Ubuntu boxes updated automatically via apt. It would also be great if my Mac install checked periodically and threw something up in Notification Center in addition to putting a note at the top of the configuration window (which I never actually see unless I go into Synergy and click "show.")
  22. Synergy 1.10.2 Finally Released

    Hi, I still use Synergy 2, on my two Win10 Systems...was that a mistake? It still works fine with me!? (In fact it connects automatically, when both Computers are on ;-))
  23. Some observations about the screen/mouse freezing problem.

    I tried Barrier too, but the problem persists with it. Maybe it's some lib used by synergy in Kubuntu 18.04, maybe it's hardware related. I'll try getting a statically compiled binary from someone.
  24. Synergy 1.10.2 Finally Released

    This is indeed a limitation of macOS, it does not route keyboard inputs, for security reasons, they are totally intercepted by the OS itself whenever a password field to log on is shown. Mouse being unable to be utilized for this input of the password is free to move about still however.
  25. Hello, This is an issue on version 1 also, but I figured I'd post it here. I have two Mac's that I share a keyboard / mouse between. If I go to the second Mac which I am using Synergy to control the keyboard and Mouse, and I try to run Microsoft Remote Desktop to access a Windows box over an RDP session, the shift keys do not work. If I use the keyboard from that machine it is fine. The Shift keys just do not work within Microsoft Remote Desktop RDP session when you try to use them through Synergy. This happens with the old version of Synergy and older versions of Microsoft Remote Desktop. As a result, if I use Microsoft Remote Desktop, I need to use an actual keyboard if I expect to use the Shift Keys. They shift key works fine within the admin screens of Microsoft Remote Desktop, just not inside of the RDP session. VNC, OSX Screen Share, everything else is fine but RDP within Microsoft Remote Desktop. Anyone have an ideas? This issue occurs on Mojave and High Sierra, Osxster
  26. Synergy 1.10.2 Finally Released

    Not sure if this was an issue before because I never tried doing it before this version today. Server is macOS Mojave, client Windows 8.1. If I don't log in to the server's OS, but have the mouse pointer on the logged-in Windows machine, typing goes to the password field on the Mac and not the selected field in Windows. I got to this state by enabling the screen saver of the Mac, which did the same on all machines as expected. Then I moved the mouse pointer to the Windows machine, tried to search for something in the Control Panel, but the text didn't appear. Looking back at the Mac's screen, it had instead typed the search term into the password field. Entering my password correctly worked and keyboard followed pointer as expected. If this is a technical requirement that you must be logged in to the server to allow keyboarding on another system, so be it. I just thought it was unexpected so decided to report. I'll expect it now if the situation arises again (probably won't put the system in that state deliberately again). Thank you for the update. I'd go insane having to always be switching physical keyboard and mouse to access machines on the same desk.
  27. Some observations about the screen/mouse freezing problem.

    Thank you for the Barrier suggestion, Kyle! Today I updated to 1.10.2 hoping for any improvement, but the issues remained exactly the same. So I installed Barrier and no more issues so far. I haven't seen a single freeze. I ought to ask for my money back.
  1. Load more activity