All Activity

This stream auto-updates     

  1. Today
  2. Mouse Cursor appearing at the middle of the screen?

    Seems better but still gets stuck regularly in the middle of the server machine. All running latest 1.10.2. I'm just shutting it off and only using it when desperate :-(
  3. Yesterday
  4. It's being tracked on github here: Appears to be caused by a lock conflict in X11.
  5. Synergy for Android and Samsung DeX

    That would be awesome, I have a P20 Pro, it uses EMUI, I used to use the old port for synergy on android: I can connect it, but I cannot see the mouse and keyboard integration, the project seemed discontinued since 3 years, it would be awesome if someone would pick it up and continue developing it Thanks
  6. Last week
  7. Synergy 1.10.2 Finally Released

    I'm still using 1.8.8. It works fine, and I've never had a problem with it. Looking at the enhancements, I don't see anything that's of interest to me. (I use the program less than once a week on average, and how 1.8.8 works meets my needs.). One issue that kept me from updating earlier was that somewhere along the line I read that the new version required that I log into a Synergy server somewhere to use it. Is this still the case in 1.10.2? I guess the only real motivation I'd have to update would involve 1.10.2 being more "secure" than 1.8.8. Is this, perhaps, the case? Thank you.
  8. Mouse Cursor appearing at the middle of the screen?

    I decided today I had to try to figure out what is killing me here and I ended up finding one of my machines running older 1.9 series vs others running 1.10.1. The 1.10.1s were also telling me there was a 1.10.2. I updated everything to 1.10.2. At the moment, about 2 hours in, everything is working well. I have not used Synergy without the stuck cursor for anything near this long anytime in the recent past so I'm quite hopeful that me messing up some versions or updating some but not all was contributing to my problems. Fingers crossed the fix was this easy.
  9. Mouse Cursor appearing at the middle of the screen?

    I turned off Synergy for the last week. It is wonderful to not have to deal with the cursor getting stuck. Utter joy. Why don't you folks fix this crap. Synergy, back in the day was a wonderful product, those days are long gone. Just for kicks I turned it on to do something on one of my macs. Less than 2 minutes and the freakin' mouse is stuck dead center on server machine. This is crazy.
  10. Some observations about the screen/mouse freezing problem.

    I've been using Barrier now for a few days and I have seen the problem maybe a couple of times per day max. And even if it happens it only lasts a second or so and is pretty much a non-issue. In Synergy the mouse becomes completely stuck, lasting maybe 10 to 30 seconds or so, unless I would 'break it loose' it by moving the actual mouse on the client computer. It sure would be nice to get at least an official acknowledgment that this is an issue and somebody would start looking at it.
  11. Workaround: macOS WiFi ping spikes

    Setup between Win10 (server) and OSX (client). Didn't get Synergy 1 to work properly, same network, allowed in firewall on both OSes and also in the router. Pings went trough without problems. Really needed this to work to actually utilize the 49" monitor I just got. Took a gamble with Synergy 2, experienced lot of lag and DC from the client. Installed Share-Mouse. Proved itself being 200 times worse. Was just about to give up, at least for now but then i tried this. Decreases lag and keeps the connection alive (still have some DC issues) however seems to work pretty well when using the Mac for longer periods. Basically, I just wanted to say thank you @zachn
  12. Kali Linux Install Failing

    Hi, Was wondering if someone could assist me with the install for Synergy 2 on Kali Linux. I do the following and get back this error and doesn't appear to load the application to the OS Application List [email protected]:-$ sudo dpkg -i /root/Downloads/synergy_2.0.12.beta_b1705+e5daaeda_amd64.deb (Reading database ... 494744 files and directories currently installed.) preparing to unpack .../synergy_2.0.12.beta_b1705+e5daaeda_amd64.deb ... Unpacking synergy (2.0.12.beta-b1705+e5daaeda) ... dpkg: error processing archive /root/Downloads/synergy_2.0.12.beta_b1705+e5daaeda_amd64.deb (--install): unable to open 'user/lib/systemd/system/synergy.service.dpkg-new': No such file or directory Processing triggers for gnome-menus (3.31.4-3) ... Processing triggers for mime-support (3.62) ... Processing triggers for desktop-file-utils (0.23.-4) ... Errors were encountered while processing: /root/Downloads/synergy_2.0.12.beta_b1705+e5daaeda_amd64.deb [email protected]:-$ Any help will be appreciated, just note im very new to the OS and learning as i go along. Regards, Daryl
  13. Linux Mint 19 is based on Ubuntu 18, so you must use synergy_1.10.2.stable_b10 + 8c010140_ubuntu18 _....
  14. Ugh, I had this problem on Ubuntu when Synergy 2 came out. No reason for them to package the .deb with such a high version number. You can probably build from source here: and it will work.
  15. When I went to install v 1.10.2 on my Linux system, I received the error "Dependency is not satisfiable: libqt5core5a (>=5.12.2)". I am on the latest Linux Mint version at the moment (19.1) and this appears to be an issue. I have contacted support.
  16. Auto start on Linux before login

    In case this helps anyone, I finally bothered to get Synergy to auto-start before login for Kubuntu 18.04 (sddm login manager/KDE plasma shell). I'm using systemd to start the process by creating a service file at /etc/systemd/system/synergy.service [Unit] Description=Synergy Service Requires=display-manager.service After=display-manager.service [Service] Type=simple Restart=always RestartSec=3 ExecStartPre=/bin/bash -c "sleep 10; /bin/systemctl set-environment SDDMXAUTH=$(/usr/bin/find /var/run/sddm/ -type f)" ExecStart=/bin/bash -c "XAUTHORITY=${SDDMXAUTH} /opt/synergy-core/build/bin/synergyc -f -n minotaur" [Install] (replace "/opt/synergy-core" and "minotaur" with the path to your install of synergyc and your hostname respectively). You then can enable the service at startup with "sudo systemctl daemon-reload; sudo systemctl enable synergy.service" The ExecStartPre was necessary because the XAuthority file used by SDDM in randomly generated when the process starts. The "sleep" is a bit of a hack to ensure the file was created after the display-manager.service starts. Hope that's helpful for someone out there! Dean
  17. CTRL+ALT+DELETE to a remote machine?

    Fixed by setting "Elevate: Always" on client settings. I also put in the interface IP, but not sure if that matters.
  18. CTRL+ALT+DELETE to a remote machine?

    Running 1.10.2, both client and server are windows 10. ctrl-alt-pause doesn't seem to work. This used to work on my win7 client, but i have updated to win10 on client and this no longer works.
  19. Internet REQUIRED? Collecting information????? VERY UNCOOL !
  20. i bought synergy to work at my office with my mac and my pc (CPU) it NEVER worked. Tried everything for months including this kind of forums. I want a refund, how can i get it? very dissapointed with the program.
  21. Fedora not working (Synergy 2)

    I found that the firewall was holding me back on Synergy. The default FirewallD service for Synergy only listens to port 24800 whereas Synergy2 also needs 24801 and 24802. These commands should update the firewall and allow Synergy: sudo sed -i 's/port="24800"/port="24800-24802"/g' /usr/lib/firewalld/services/synergy.xml sudo firewall-cmd --zone=$(firewall-cmd --get-default-zone) --add-service=synergy --permanent sudo systemctl restart firewalld
  22. Choppy mouse movement on client

    Hello, I am still affected by the jumpy mouse , or choppy how you call it. I experience this in every possible configuration, mac server , mac client / windows client, or reverse . I only need to have 2 computers connected but is not a smooth movement, I can't do nothing on the client side... I have the imac pro and 8700k for example, <1ms ping between the computers, no packets lost I am using the latest of the synergy 2 versions. Should I try version 1 ?
  23. Exclamation mark

    Unfortunately this bug is still there in the latest version (1.10.2-stable-8c010140). Would be great if you guys could fix this ;-)
  24. Synergy 1.10.2 Finally Released

    [Solved] Never mind fixed by going to System Preferences -> Security & Privacy -> Privacy and unchecking and then rechecking the box allowing Synergy to control the computer.
  25. Synergy 1.10.2 Finally Released

    I get constant "There was an error, retrying..." message when trying to start my Synnergy server on my macbook running macOS 10.14 I installed 1.10.2 on both my Win10 client and macbook. Any advice? [2019-05-15T12:53:36] INFO: starting server [2019-05-15T12:53:36] INFO: config file: /Users/edward3/Documents/synergy/synergy.conf [2019-05-15T12:53:36] INFO: log level: INFO [2019-05-15T12:53:36] INFO: drag and drop enabled [2019-05-15T12:53:36] ERROR: failed to create quartz event tap [2019-05-15T12:53:36] ERROR: process exited with error code: 11 [2019-05-15T12:53:36] INFO: detected process not running, auto restarting [2019-05-15T12:53:37] INFO: stopping synergy desktop process Thanks in advance, -Ed
  26. Repository for updates and installation

    I want to bump this as well. I would love it if my Ubuntu boxes updated automatically via apt. It would also be great if my Mac install checked periodically and threw something up in Notification Center in addition to putting a note at the top of the configuration window (which I never actually see unless I go into Synergy and click "show.")
  27. Synergy 1.10.2 Finally Released

    Hi, I still use Synergy 2, on my two Win10 Systems...was that a mistake? It still works fine with me!? (In fact it connects automatically, when both Computers are on ;-))
  1. Load more activity