Connection Issues

Get help with connectivity problems.
Posts: 1
Joined: Tue Sep 27, 2016 5:06 am

Connection Issues

Postby Quentin DSouza » Tue Sep 27, 2016 5:07 am

After the latest release I cant connect my client to the server. The server is giving the following errors:

[2016-09-27T08:04:30] ERROR: ssl error occurred (system call failure)
[2016-09-27T08:04:30] ERROR: eof violates ssl protocol

I did re-run and checked off SSL.

On the client side I get: failed to connect to server.

Thanks

Q

Posts: 3
Joined: Sun May 31, 2015 6:18 pm

Re: Connection Issues

Postby Don Sachnoff » Tue Sep 27, 2016 7:08 am

I have had a similar problem for quite some time using SSL even in the latest release. If I disable SSL on both the server and client a connection is made and it works ok. So the question is why is this failing when trying to use SSL?

Client log:
-09-27T09:20:30] INFO: starting client
[2016-09-27T09:20:30] INFO: config file: C:/Users/Don/AppData/Local/Temp/qt_temp.wx7360
[2016-09-27T09:20:30] INFO: log level: ERROR
[2016-09-27T09:20:31] INFO: activeDesktop:Default
[2016-09-27T09:20:35] ERROR: failed to verify server certificate fingerprint
[2016-09-27T09:20:48] INFO: starting client
[2016-09-27T09:20:48] INFO: config file: C:/Users/Don/AppData/Local/Temp/qt_temp.nf7360
[2016-09-27T09:20:48] INFO: log level: ERROR
[2016-09-27T09:20:51] INFO: activeDesktop:Default
[2016-09-27T09:20:51] ERROR: failed to verify server certificate fingerprint
[2016-09-27T09:21:08] ERROR: failed to verify server certificate fingerprint
[2016-09-27T09:21:25] ERROR: failed to verify server certificate fingerprint

Server log:
[2016-09-27T09:20:34] NOTE: started server, waiting for clients
2016-09-27 09:20:34.782 synergys[11590:87177] starting cocoa loop
[2016-09-27T09:20:35] INFO: OpenSSL 1.0.2 22 Jan 2015
[2016-09-27T09:20:35] INFO: accepted secure socket
[2016-09-27T09:20:35] INFO: AES256-GCM-SHA384 TLSv1.2 Kx=RSA Au=RSA Enc=AESGCM(256) Mac=AEAD
[2016-09-27T09:20:35] NOTE: accepted client connection
[2016-09-27T09:20:37] INFO: stopping synergy desktop process
[2016-09-27T09:20:37] INFO: process exited normally
[2016-09-27T09:20:37] INFO: starting server
[2016-09-27T09:20:37] INFO: config file: /var/folders/v1/8jmsh8qs5fb3bt9t24trzp280000gn/T/Synergy.RN6817
[2016-09-27T09:20:37] INFO: log level: INFO
[2016-09-27T09:20:37] INFO: drag and drop enabled
[2016-09-27T09:20:37] NOTE: started server, waiting for clients
2016-09-27 09:20:37.984 synergys[11601:87306] starting cocoa loop
[2016-09-27T09:20:51] INFO: OpenSSL 1.0.2 22 Jan 2015
[2016-09-27T09:20:51] INFO: accepted secure socket
[2016-09-27T09:20:51] INFO: AES256-GCM-SHA384 TLSv1.2 Kx=RSA Au=RSA Enc=AESGCM(256) Mac=AEAD
[2016-09-27T09:20:51] NOTE: accepted client connection
[2016-09-27T09:21:06] NOTE: new client disconnected
[2016-09-27T09:21:08] INFO: OpenSSL 1.0.2 22 Jan 2015
[2016-09-27T09:21:08] INFO: accepted secure socket
[2016-09-27T09:21:08] INFO: AES256-GCM-SHA384 TLSv1.2 Kx=RSA Au=RSA Enc=AESGCM(256) Mac=AEAD
[2016-09-27T09:21:08] NOTE: accepted client connection
[2016-09-27T09:21:23] NOTE: new client disconnected
[2016-09-27T09:21:25] INFO: OpenSSL 1.0.2 22 Jan 2015
[2016-09-27T09:21:25] INFO: accepted secure socket
[2016-09-27T09:21:25] INFO: AES256-GCM-SHA384 TLSv1.2 Kx=RSA Au=RSA Enc=AESGCM(256) Mac=AEAD
[2016-09-27T09:21:25] NOTE: accepted client connection
[2016-09-27T09:21:37] NOTE: new client disconnected
[2016-09-27T09:21:39] INFO: stopping synergy desktop process
[2016-09-27T09:21:39] INFO: process exited normally

Posts: 2
Joined: Tue Sep 27, 2016 8:12 am

Re: Connection Issues

Postby Jeffrey Lee » Tue Sep 27, 2016 8:28 am

I was getting the 1st problem this morning after upgrading to 1.8.3. After putting in a support ticket and going through the Setup Wizard steps to reinstall the SSL modules, I still couldn't connect. Now I am getting the "failed to verify server certificate" after it first wasn't an issue. Perhaps they are doing some server maintenance on their end right now.

Posts: 1
Joined: Wed Nov 30, 2016 8:17 am

Re: Connection Issues

Postby David Senterfitt » Wed Nov 30, 2016 8:28 am

I had a similar problem today on my linux - CentOS box and synergy. I performed the following set of steps to clear the error and enable my client to connect to my synergy server.
  1. I used the synergy GUI to edit my settings and turn off the SSL
  2. started synergy on this client
  3. stopped synergy on this client
  4. edited my settings again and re-enabled SSL
  5. When I restarted synergy on this client, a dialogue box popped up asking me to accept the synergy server's certificate.
After performing this series of steps, my client was able to connect with SSL to my server.

Posts: 1
Joined: Sat Dec 03, 2016 1:54 pm

Re: Connection Issues

Postby Philipp Straehl » Sat Dec 03, 2016 1:59 pm

I had the same problem, with a new setup (new server), and v.1.8.4. Before I used a different computer as server, and an older Synergy version (1.6.x or 1.7.x). I simply switched off SSL encryption (I don't need it anyway), and instantly the connections to all machines worked.

Thank you for your help.

Return to Connectivity

Who is online

Users browsing this forum: No registered users and 2 guests