Synergy 1.7.4 released

See announcements from the team.
User avatar
Posts: 67
Joined: Thu Apr 09, 2015 9:25 am
Location: Camberley, UK

Synergy 1.7.4 released

Postby Nick Bolton » Tue Aug 11, 2015 2:10 pm

The next version of Synergy is here!

» Download Synergy v1.7.4-stable

Here's the bug fixes...

  • Bug #4721 - High CPU usage for Windows service
  • Bug #4750 - SSL connect error 'passive ssl error limit'
  • Bug #4584 - Drag and drop with SSL causes crash
  • Bug #4749 - Clipboard thread race condition causes assertion failure
  • Bug #4720 - Plugin download shows 'Could not get Linux package type' error
  • Bug #4712 - Unable to send clipboard with size above 1KB when using SSL
  • Bug #4642 - Connecting causes SSL23_GET_SERVER_HELLO error
  • Bug #4690 - Log line 'activeDesktop' does not use logging system
  • Bug #4866 - Wrong ns plugin version can be loaded

We also made some improvements...

  • Enhancement #4901 - Auto restart when running from GUI in desktop mode
  • Enhancement #4845 - Add timestamp to log output
  • Enhancement #4898 - Move version stage name to build config

Thanks for using Synergy, enjoy the release!
CEO of Symless

Posts: 1
Joined: Wed Aug 12, 2015 12:35 am

Re: Synergy 1.7.4 released

Postby Kay Zenner » Wed Aug 12, 2015 12:39 am

I have a 4k-Display on my main-system and a full-hd display on my notebook. this combination is not working. the server says: mouse is leaving the main-screen and is on notebook-screen, but I cannot see a mouse pointer. Keyboard is not working at all.
This is on Windows 10 (64bit)

Thanks for your good work.

Posts: 21
Joined: Wed Apr 29, 2015 8:53 am

Re: Synergy 1.7.4 released

Postby Allen » Wed Aug 12, 2015 5:12 am

I downloaded and installed 1.74. I attempted to post on the blog site where the announcement was made, but was apprehended by a Wordpress password request which stopped me -- and there was no link back to this forum , but I found my way here and can post.

With 1.74, Installation still took me hours because SSL does not work for me and I repeatedly failed until I turned SSL off. I have no idea why.

The installation and configuration process is somewhat mysterious and unexplained and he messages scrolling in the log are marginally useful to me.

When I turn SSL off, Synergy works fine.

For that matter, I don’t even know why I would want or need SSL. Is this explained somewhere?

Also, somehow, it seems multiple copies of Synergy might be running when the GUI is opened repeatedly because in my mucking around, I sometimes see the message that a synergy-related dll is in use by another process. Why do we not have an icon in the system tray any more? That was really handy.

At least the excessive processor use has gone away and the plugin now downloads and Synergy is working. Thanks.

Windows 7 - 64 bit, Windows 7 - 64 bit,, and Windows 7 32bit.

Posts: 3
Joined: Wed Aug 12, 2015 12:41 pm

Re: Synergy 1.7.4 released

Postby Luke Jernejcic » Wed Aug 12, 2015 12:42 pm

SSL still doesn't work for me (didn't work in 1.7.3 either). I had to downgrade again to 1.7.2 in order to get SSL support.

Here's the error:

Code: Select all
[2015-08-12T12:29:46] WARNING: failed to accept secure socket

Posts: 4
Joined: Thu Aug 13, 2015 12:22 am

Re: Synergy 1.7.4 released

Postby Gary Butler » Thu Aug 13, 2015 12:30 am

Tried to install it yesterday but hangs on the ns plugin download.

Posts: 3
Joined: Mon Aug 10, 2015 2:57 am

Re: Synergy 1.7.4 released

Postby Aled Treharne » Fri Aug 14, 2015 7:38 am

I'd had SSL disabled from 1.7.3, but it got re-enabled when I installed 1.7.4, however I'm also seeing the following error on the (Windows 7) client:

[2015-08-14T10:24:14] ERROR: failed to verify server certificate fingerprint


No amount of changing SSL settings fixed this, disabling SSL works around it for now.

Posts: 1
Joined: Mon Aug 17, 2015 6:49 am

Re: Synergy 1.7.4 released

Postby eric john nagel » Mon Aug 17, 2015 6:50 am

Just re-installed with server on Fedora 23. get the following....WARNING: cannot listen for clients: cannot bind address: Address already in use
Switched server to W8 machine and made the Fedora 23 machine client, working now that I took them off SSL
Last edited by eric john nagel on Mon Aug 17, 2015 8:29 pm, edited 1 time in total.

Posts: 7
Joined: Wed Jun 03, 2015 6:00 pm

Re: Synergy 1.7.4 released

Postby Andy Hall » Mon Aug 17, 2015 11:06 am

I upgraded from a pre-release to 1.7.4-stable on my pair of Win 7 PRO 64-bit machines. I was running in non-SSL prior to the upgrade. Synergy came up smoothly in non-SSL mode which I expected as that had been the experience with upgrading from one pre-release to another.

Thinking that SSL might actually have been fixed and I should test it, I enabled it on both the server and client. Sadly, the problems I reported on the pre-releases still exist and are similar to those reported by Allen above.

I encountered a new and possibly obscure problem. The very first screen shot I took on the client and pasted into an e-mail on the server, came across flipped on the vertical axis. I fixed that by pasting it into a Word document on the client an copying and pasting that. Subsequent attempts to take screen shots on the client and paste on the server have been OK. So far I have been unable to reproduce the problem. It may require a reboot of the client and server, which I don't anticipate doing for a while. (The client machine has a VM running which I need to keep on the air for a while.)

Posts: 3
Joined: Tue Aug 18, 2015 9:13 am

Re: Synergy 1.7.4 released

Postby David De Hora » Tue Aug 18, 2015 9:20 am

I installed the synergy-v1.7.4-stable version on a Win 7 box (Synergy Server) and on 2 clients, Win 8 and Mac with OSX 10.9.5. I am still experiencing crashes on the server as with previous 1.7.4 releases. I have to reboot my machine when this happens as it does not recover from the crash. Any suggestions. I now have synergy logging enabled so will be able to provide this log when this occurs again.

Event Log:

Faulting application name: synergys.exe, version: 0.0.0.0, time stamp: 0x55c53ad1
Faulting module name: synergys.exe, version: 0.0.0.0, time stamp: 0x55c53ad1
Exception code: 0xc0000005
Fault offset: 0x000000000005ecae
Faulting process id: 0x2b10
Faulting application start time: 0x01d0d79aa8376b81
Faulting application path: C:\Program Files\Synergy\synergys.exe
Faulting module path: C:\Program Files\Synergy\synergys.exe
Report Id: 739bf29e-44ec-11e5-9cbb-f9e0456878a5

Posts: 7
Joined: Wed Jun 03, 2015 6:00 pm

Re: Synergy 1.7.4 released

Postby Andy Hall » Tue Aug 18, 2015 11:14 am

Here are two more potential bugs with 1.7.4

1. Over night my Win 7 Pro 64-bit machine went into power saving mode. When I brought it back to life by hitting a key or moving the mouse, I don't remember which, The mouse pointer did not display and therefore I could not move to the password entry box. I had to reboot. This never happened on the pre-releases.

2. While the server was rebooting, I manually switched the keyboard and mouse to the client side (via a KVM switch and brought up the Synergy GUI to see what was happening. The GUI had the "Start" button displayed, but as soon as the server came alive, Synergy started working. Which indicated to me that the client side was actually working! To make sure, once every thing was working satisfactorily, I brought up the client GUI again and the "Start" button still displayed.

I will monitor #1 above to see if it is just a fluke or repeatable.

PS. (1) I wish it was possible to edit these posts so that subsequent findings could be added. (2) Why when I login to this site am I prevented from posting replies to this forum. I have to navigate around in yet some magic sequence of clicks to get a "post a reply" button to display.

Next

Return to Announcements

Who is online

Users browsing this forum: No registered users and 1 guest