Synergy 1.8.4 is here!

See announcements from the team.
User avatar
Posts: 78
Joined: Thu Apr 09, 2015 9:25 am
Location: Camberley, UK

Synergy 1.8.4 is here!

Postby Nick Bolton » Mon Oct 17, 2016 7:17 am

Hi everyone,

Synergy 1.8.4 is ready for you to download!

Here are a few reasons why you should update to version 1.8.4...

1. It's always free! (just make sure you login first)
2. There's better support for high DPI displays on Windows
3. Seamless update: no more wizard every time you update
4. We've made SSL even more reliable, and fixed some other bugs

Update to Synergy 1.8.4 (requires login)

Just to recap, these are the bugs that we fixed...

- DPI scaling was broken when using a Windows server
- On Linux, newly added or resized screens were being ignored
- Our update notification was bugging users to downgrade
- Overwriting existing SSL certificates when you re-run the wizard

And we also added these enhancements...

- Removed the buggy plugin infrastructure (no more ns.dll)
- Made SSL even more reliable than before
- Easier to upgrade to Pro via the new activation dialog (File menu)
- The wizard is no longer run every time you update

Enjoy the new version of Synergy! Let us know if there's anything we can do to help.

Nick Bolton
CEO of Symless
Synergy Team

Image Image


Posts: 11
Joined: Tue Apr 21, 2015 2:56 am

Re: Synergy 1.8.4 is here!

Postby Steffen W Soerensen » Mon Oct 17, 2016 7:48 am

1.8.4 is failing just as 1.8.3 were on macOS Sierra w/some failure about permission to access and temp sub dir under /var/tmp, had to revert to 1.8.2 on my macOS server.

Posts: 1
Joined: Mon Oct 17, 2016 8:20 am

Re: Synergy 1.8.4 is here!

Postby Jay Bee » Mon Oct 17, 2016 8:31 am

Yeah, me too - I haven't been able to get Synergy to work since 1.8.3, which is a bummer since it's the first time I've had a problem in all the years I've used it. When I couldn't figure out the problems with 1.8.3 I rolled back to 1.7.5 (the last version available for download) and it all worked again. I figured I'd wait until the next version to see if the problems were resolved, but no luck with 1.8.4 either.

fwiw, I'm using Mac OS El Capitan as the server and Windows 10 as the client. This is the setup I've had for several years now, and it's always worked flawlessly, until 1.8.3 and now 1.8.4. I'm getting a "Connection refused" on the client, and on the server I'm getting this:

[2016-10-17T11:18:51] INFO: drag and drop enabled
[2016-10-17T11:18:51] FATAL: unknown screen name `ip-192-168-16-91.ec2.internal'
[2016-10-17T11:18:51] ERROR: process exited with error code: 1
[2016-10-17T11:18:51] INFO: detected process not running, auto restarting
[2016-10-17T11:18:52] INFO: stopping synergy desktop process
[2016-10-17T11:18:52] INFO: starting server
[2016-10-17T11:18:52] INFO: config file: /var/folders/1w/75j5mh292x1b7n_ct5ln76300000gn/T/Synergy.JH2815
[2016-10-17T11:18:52] INFO: log level: INFO
[2016-10-17T11:18:52] INFO: drag and drop enabled
[2016-10-17T11:18:52] FATAL: unknown screen name `ip-192-168-16-91.ec2.internal'
[2016-10-17T11:18:52] ERROR: process exited with error code: 1

One annoying thing is that I can't stop the server - every time I click Stop it just starts again. I thought I'd run the wizard on both machines but you guys removed it, so... not sure what to do now. Clicking around in Prefs and trying things isn't working, so my plan is to keep using 1.7.5 until (if) a new version works.

Posts: 1
Joined: Mon Oct 17, 2016 11:25 am

Re: Synergy 1.8.4 is here!

Postby juan muzquiz » Mon Oct 17, 2016 11:58 am

Same with me, been using Synergy on two Windows machines for a long time and can't get this version to work.
Real Bummer!!


Posts: 1
Joined: Mon Oct 17, 2016 9:04 am

Re: Synergy 1.8.4 is here!

Postby Adrian Pecker » Tue Oct 18, 2016 12:37 am

Yes, indeed there seems to be a problem with this version. I couldn´t get it to work on my Windows 7/Mac configuration.
There is a problem with the client that will loop trying to connect.

As you only keep the last builds in your download page I cannot make it work downloading an older version. Its a pitty, as I bought it some days ago and I am still unable to use it. I hope you can deliver a patch soon.


Posts: 1
Joined: Tue Oct 18, 2016 1:18 am

Re: Synergy 1.8.4 is here!

Postby Wim Vlak » Tue Oct 18, 2016 1:27 am

1.8.4 is not working for me. Host: Windows 10. Client: Windows 7. Upon starting Synergy on both machines, the cursor disappears when switching to the Client machine. Will only reappear when I stop the Client. This renders Synergy completely unusable

Posts: 4
Joined: Fri May 22, 2015 9:09 am

Re: Synergy 1.8.4 is here!

Postby rajiv » Tue Oct 18, 2016 7:01 am

Since upgrading to 1.8.4, from 1.8.3, the Synergy server has crashed multiple times per day.

Server: Windows 2008 R2
Client: Windows 8.1 Pro

Posts: 2
Joined: Sun May 08, 2016 4:30 am

Re: Synergy 1.8.4 is here!

Postby David Harrison » Tue Oct 18, 2016 8:46 am

Sorry to say that Synergy is now behaving much better with Creative Cloud Applications such as Indesign, Photoshop et al, at least on my Win7 machine. It no longer interferes with keyboard shortcuts.

It also seems to play nicer with Hexchat, although there's still a little laginess there when moving from one machine to the next.

So that's one less excuse to pause work and enjoy a coffee instead. Cheers, devs. :shock:

Posts: 1
Joined: Tue Oct 18, 2016 9:54 am

Re: Synergy 1.8.4 is here!

Postby Tin Le » Tue Oct 18, 2016 9:56 am

OSX 10.11.6 client (macbook)
RHEL 6.6 server
1.8.4 stable release

On the macbook side, the cursor is very jerky, shimmery. Impossible to use. I reverted back to 1.8.3-stable. Work perfectly.


User avatar
Posts: 6
Joined: Wed May 06, 2015 5:03 am
Location: Minnteapolis, MN, USA

Re: Synergy 1.8.4 is here!

Postby Kelvin D. Olson » Wed Oct 19, 2016 5:31 am

Server is TrebleBoot of Linux Mint 17.3 (mostly), Win10 Pro (daily), and UbuntuSomething (rarely).

Client is Mac OS X Sierra (or whatever the heck just came out mid-2016).

At the upgrade to 1.8.3, had trouble getting it to start, making SSL-related complaints. Shut off all the SSL stuff and it started working again, and I've had no problems.

Now, with upgrade to 1.8.4, it seems to be working just fine whether server is Mint or Win. But on Mint, the /usr/share/icons/synergy.ico is suddenly broken. The app still works, but on the launch panel, I'm clicking a tiny black icon with a red circle-and-slash.

Going to sudo root, rm that synergy.ico file, and try to re-install from the synergy-v1.8.4-stable-a6ff907-Linux-x86_64.deb file.

...(clickety, click)...

Nope, that didn't work. The synergy.ico file came back, but it's worthless. It's been fine. For years. Why screw with it?

Code: Select all
[email protected] ~/.synergy $ ls -latr /usr/share/icons |tail
drwxr-xr-x   7 root root  4096 Nov 28  2015 gnome-colors-common
drwxr-xr-x   7 root root  4096 Nov 28  2015 gnome-wise
drwxr-xr-x   3 root root  4096 Mar 30  2016 ubuntu-mono-light
drwxr-xr-x   3 root root  4096 Mar 30  2016 ubuntu-mono-dark
drwxr-xr-x 332 root root 12288 Sep  6 07:15 ..
drwxr-xr-x  12 root root  4096 Sep 24 18:13 gnome
drwxr-xr-x  11 root root  4096 Sep 24 18:13 mate
-rw-r--r--   1 root root 24277 Oct 11 04:23 synergy.ico   <--that file is $#!+
drwxr-xr-x  16 root root  4096 Oct 17 13:17 hicolor
drwxr-xr-x  28 root root  4096 Oct 19 07:32 .
[email protected] ~/.synergy $

Alas, the actual functionality that I require of Synergy has long been and continues to be nearly flawless. This post is much ado about nothing.

I can probably re-install 1.8.3 or 1.8.2 from the .deb files, grab a backup copy of synergy.ico, and use that one.

...(clickety, clack)...

Yup, that worked.

Went into Menu, Administration, Synaptic Package Manager (because I'm one of those GUI types) and removed Synergy 1.8.4.

Went to my Downloads folder, and double-clicked synergy-v1.8.3-stable-db9181b-Linux-x86_64.deb and installed it. Icon on launch pad immediately fixed.

Code: Select all
$ cp /usr/share/icons/synergy.ico .

Back to Downloads folder, and double-clicked synergy-v1.8.4-stable-a6ff907-Linux-x86_64.deb to re-install the latest. Icon on launch panel immediately broken.

Code: Select all
$ sudo cp ./synergy.ico /usr/share/icons/

Icon on launch panel still broken. Right-click on it, Properties, verify that within there, it DOES appear correct.


Icon on launch panel is again fine.


Return to Announcements

Who is online

Users browsing this forum: No registered users and 1 guest