Synergy 1.8.3 released

See announcements from the team.
User avatar
Posts: 67
Joined: Thu Apr 09, 2015 9:25 am
Location: Camberley, UK

Synergy 1.8.3 released

Postby Nick Bolton » Mon Sep 26, 2016 5:55 am

The Synergy 1.8.3 update is ready for you to download!

Here are 5 reasons why you should update Synergy...

1. It's a free update, as always
2. Clipboard sharing is even more reliable
3. The spacebar key on Mac is fixed
4. Media keys now work on Mac
5. Improved Windows UAC handling

Update to Synergy 1.8.3

Just to recap, these are the bugs that we fixed...

  • A letter is typed when spacebar is pressed on Mac client
  • Tab behaves like shift tab on client
  • UAC causes disconnection while in elevate mode

And we also added these enhancements...

  • Media key support for Mac clients
  • Make auto-elevate optional

Enjoy the new version of Synergy! Let us know if there's anything we can do to help.
CEO of Symless

Posts: 3
Joined: Sun May 31, 2015 1:40 am

Re: Synergy 1.8.3 released

Postby jimmy anderson » Mon Sep 26, 2016 10:17 am

However it's failed to work here. force removed the software and reloaded but no still no joy. posting.php?mode=reply&f=16&t=1961&sid=9fa3d6a338dd2eb9d62e57454667f266#

Posts: 1
Joined: Mon Sep 26, 2016 10:55 am

Re: Synergy 1.8.3 released

Postby Tom Caudill » Mon Sep 26, 2016 10:57 am

SSL configuration is not working. Going into the EDIT menu and disabling SSL works, but re-enabling SSL continues to kill the connections. This is a workaround. Is there a Solution?

Posts: 4
Joined: Mon Sep 26, 2016 9:10 am

Re: Synergy 1.8.3 released

Postby Mark Mazelin » Mon Sep 26, 2016 11:03 am

(from the Synergy Team at Symless)
There's a known issue in Synergy 1.8.3 where the SSL plugin can be out of date, which stops the client connecting to the server. To fix this, please re-run the wizard on all of your machines.

  1. Open Synergy on the server
  2. If Windows: Go to the Edit, then click Settings
  3. If macOS: Go to Synergy, then click Preferences
  4. Ensure the "Use SSL encryption" checkbox is enabled
  5. Go to File, then Run Wizard
  6. Click Next until you see the Activation screen
  7. Enter your login details or serial key
  8. Click "Continue" and finish the wizard
  9. Repeat those steps for each client

Posts: 1
Joined: Mon Sep 26, 2016 5:08 pm

Re: Synergy 1.8.3 released

Postby Heath Glass » Mon Sep 26, 2016 5:13 pm

I upgraded my 2 Windows 10 PC's. One is 32 bit and the other its 64.

The 32bit machine is the server.

Upgraded the 32bit OK and it still connected to the 64 bit running version 1.8.2 and was working.

Upgraded the 64bit and it lost connection with the 32 bit server.

I downgraded the 64bit back to 1.8.2 and it worked OK. So I upgraded back to 1.8.3 and it stopped again so I downgraded and it worked.

So very strange.

My setup is standard windows and nothing special.

Last bits from log on client are:
[2016-09-27T09:59:56] NOTE: started client
[2016-09-27T09:59:56] NOTE: connecting to '192.168.0.70': 192.168.0.70:24800
[2016-09-27T09:59:56] INFO: watchdog status: ok
[2016-09-27T10:00:11] WARNING: failed to connect to server: Timed out
[2016-09-27T10:00:12] NOTE: connecting to '192.168.0.70': 192.168.0.70:24800


Hope this helps.
Cheers.

Posts: 2
Joined: Tue Sep 27, 2016 12:32 am

Re: Synergy 1.8.3 released

Postby Jason Resch » Tue Sep 27, 2016 12:49 am

Issues with 1.8.3.


Using MacOS Sierra 1.83 as server and Windows 10 1.8.3 as client, the server would show in the log a new client, when i removed the screen it would detect new client and ask where to put the screen and then windows client would timeout on connecting, after checking firewall rules and checking if i could connect to the synergy port through telnet is succeeded.

Went back to 1.8.2 on Windows 10 client, worked as it did before no timeout issue.

I also have another mac on MacOS Sierra as a client with no physical keyboard attached standard function keys no longer work, ctrl+right/ctrl+left no longer moves to the next desktop on the right, ctrl+up no will open mission control.

I attached screenshots of both System Preferences for keyboard on both MacOS server and MacOS client and since i use a physical KVM between all my machines for login, network loss or out of OS use i noticed that the preferences panel of the client changes to that of the server indicating the lack of a physical keyboard may be an issue in MacOS Sierra as if i switch my KVM to the MacOS client ctrl+up and ctrl+left/right work.

Hope the information i've provided fixes those issues.
Attachments
Screen Shot 2016-09-27 at 5.41.20 pm.png
Screenshot of Keyboard system preferences of MacOS Sierra Synergy Client
Screen Shot 2016-09-27 at 5.41.20 pm.png (39.02 KiB) Viewed 1795 times
Screen Shot 2016-09-27 at 5.40.58 pm.png
Screenshot of Keyboard system preferences of MacOS Sierra Synergy Server
Screen Shot 2016-09-27 at 5.40.58 pm.png (53.18 KiB) Viewed 1795 times

Posts: 13
Joined: Wed Sep 28, 2016 9:07 am

Re: Synergy 1.8.3 released

Postby Bryan Watson » Wed Sep 28, 2016 9:16 am

I have a Mac OS 10.11.6, El Capitan, as my server and Windows 10 64-bit as a client. When I'm on my Windows 10 client, my Mac media keys do not work.

Posts: 1
Joined: Wed Sep 28, 2016 10:09 am

Re: Synergy 1.8.3 released

Postby John Herry » Wed Sep 28, 2016 10:14 am

Unfortunately, I am still having clipboard issues, even after upgrading to 1.8.3 (Win7 Ent client, Kubuntu 16.04 server)

I've sent logs to service, so hopefully I hear something soon. I've made myself dependant on this product!! :lol:

Posts: 3
Joined: Mon Jul 18, 2016 5:44 pm

Re: Synergy 1.8.3 released

Postby mike dunlap » Thu Sep 29, 2016 6:57 am

ubuntu 15.04 server, Mac OS 10.12 client.

SSL cert error, ran the wizard on everything 3 times, uninstalled and reinstalled. no dice.
Attachments
Screen Shot 2016-09-29 at 9.55.44 AM.png
Screen Shot 2016-09-29 at 9.55.44 AM.png (102.4 KiB) Viewed 1564 times

Posts: 1
Joined: Thu Sep 29, 2016 7:07 am

Re: Synergy 1.8.3 released

Postby Mark Brown » Thu Sep 29, 2016 7:14 am

I uninstalled 1.8.3, which did not work for me, and went back to 1.8.2, which still works fine.

server OS X 10.11.6, client Windows 7 64-bit.

I could get 1.8.3 to work if I made Windows 7 the server and OS X 10.11.6 the client, but that's exactly the reverse of how I need my setup to work.

Under 1.8.3, synergy would announce that the client had connected, but wouldn't share the mouse or keyboard, and then it would disconnect after a short time. This cycle would repeat endlessly.

After checking this thread, I tried to re-run the wizard. The "Use SSL Encryption" option is grayed out on my system, not able to check that.

So I'm good for the time being, but would welcome suggestions anyone has about what to try next.

Thanks!
Mark

Next

Return to Announcements

Who is online

Users browsing this forum: No registered users and 1 guest