Synergy 1.7.6 released

See announcements from the team.
Posts: 1
Joined: Mon Apr 11, 2016 3:19 pm

Re: Synergy 1.7.6 released

Postby Devon Shisler » Mon Apr 11, 2016 3:24 pm

This release has caused specific key inputs to stop working for a couple of games I play.

In Borderlands 2, it denies use of the movement keys (WASD by default) even when they are bound to other keys. In Warframe, it blocks being able to paste in to the game's chat.

All other key inputs work, and I haven't found any other games it interferes with, which is the strangest thing. For now I'll just have to disable Synergy while I play those games, though.

Posts: 5
Joined: Mon Dec 28, 2015 3:19 am

Re: Synergy 1.7.6 released

Postby Albert Winter » Sat Apr 16, 2016 6:45 am

I updated Synergy 1.7.5 to version 1.7.6. After a while (a couple of hours) my AutoHotKey scripts stopped working. Rebooting my Win10x64 computer does not bring AHK scripts to work again. I uninstalled 1.7.6 and everything worked fine again. New install of 1.7.6 showed same behaviour. I repeated this procedure twice with same results.
So I returned to Synergy 1.7.5 and everything is running ok as it was before installing 1.7.6

Posts: 3
Joined: Tue Jun 02, 2015 11:43 am

Re: Synergy 1.7.6 released

Postby tomicjr » Tue Apr 19, 2016 11:05 am

Ray Shaffer wrote:I'm also having mouse/keyboard issues with Adobe Photoshop and InDesign. This is on the local system, not a remote. Can't right click certain menus, cannot drag tools such as eraser, can click to erase but drag does not work. Also weird keyboard issues like ALT key not responding, etc. As soon as I stop Synery service everything works fine.

Windows 7 Pro 64 system.


I am experiencing similar issues. With Internet Explorer 11, I cannot type addresses into the Address Bar and navigate by pressing Enter -- IE freezes. Same URLs work fine from shortcuts. Today I noticed that the keyboard interaction with VMware Workstation 12 guests also doesn't work. The VM works fine, but as soon as I do anything inside the image requiring keyboard input, it freezes.

If I stop the Synergy service, everything works fine.

Using synergy-v1.7.6-stable-bcb9da8 64-bit

No similar issues encountered testing synergy-v1.8.0-beta-4ff3cdd

Update after further testing

From nightly builds, installed synergy-v1.8.1-stable-257ac01-Windows-x64 (About... dialog still shows Version: 1.7.6!)

Confirmed that same issue exists...

Also in IE11, pressing Alt key to display menus doesn't work.

RESTARTED Synergy Service and issues above went away.

Set Service Startup type: Automatic (Delayed Start), rebooted and seems to be working fine...

Posts: 2
Joined: Wed Apr 20, 2016 7:00 am

Re: Synergy 1.7.6 released

Postby Gavin Paolucci-Kleinow » Wed Apr 20, 2016 7:03 am

Albert Winter wrote:I updated Synergy 1.7.5 to version 1.7.6. After a while (a couple of hours) my AutoHotKey scripts stopped working. Rebooting my Win10x64 computer does not bring AHK scripts to work again. I uninstalled 1.7.6 and everything worked fine again. New install of 1.7.6 showed same behaviour. I repeated this procedure twice with same results.
So I returned to Synergy 1.7.5 and everything is running ok as it was before installing 1.7.6


I am also having problems running Synergy 1.7.6 and AutoHotkey on Windows 8.1. Sometimes if I start AutoHotkey before the Synergy service AutoHotkey will work fine, but other times AutoHotkey just won't work at all if Synergy is running.

Posts: 1
Joined: Mon Apr 25, 2016 7:45 pm

Re: Synergy 1.7.6 released

Postby Vinicius Fiorentino » Mon Apr 25, 2016 7:52 pm

BUG - Mouse Click on Client [Windows 10]

After the last update almost all the time the mouse works on client but the click does not work.

Thanks!

Posts: 1
Joined: Mon Apr 25, 2016 8:28 pm

Re: Synergy 1.7.6 released

Postby Mr.Chris » Mon Apr 25, 2016 8:31 pm

Albert Winter wrote:I updated Synergy 1.7.5 to version 1.7.6. After a while (a couple of hours) my AutoHotKey scripts stopped working. Rebooting my Win10x64 computer does not bring AHK scripts to work again. I uninstalled 1.7.6 and everything worked fine again. New install of 1.7.6 showed same behaviour. I repeated this procedure twice with same results.
So I returned to Synergy 1.7.5 and everything is running ok as it was before installing 1.7.6


I have the same problem. As a work around I set the Synergy service to Automatic (Delayed Start). AutoHotKey seems to work as long as it starts before the Synergy service.

Posts: 1
Joined: Tue May 03, 2016 10:47 am

Re: Synergy 1.7.6 released - Troubles on Ubuntu

Postby Jedidiah Bartlett » Tue May 03, 2016 10:53 am

William Deckert wrote:I am having connectivity issues
Linux Debian synergy server
Windows 7 synergy client
I keep getting the following message
WARNING: failed to connect to server: incompatible client 1.5


Having the same issue, exactly the same setup. (Xenial 16.04 server, Windows 7 Enterprise client, both just updated today).

After installing the 1.7.6 64 bit .deb, my "about Synergy" shows version 1.6.2, copyright 2002-2012
ScreenshotSynergy1.6.2.png
A screenshot of my "About Synergy" page after installing 1.7.6 (clean install, brand-new computer).
ScreenshotSynergy1.6.2.png (34.61 KiB) Viewed 1630 times


Is the 64bit debian on the website correct?

--EDIT--
I tried just running the .deb using the synaptic package manager. It seems to have searched for and installed the open-source version. Actually downloading the .deb and running:
Code: Select all
$ dpkg -i synergy-v1.7.6-stable-bcb9da8-Linux-x86_64.deb

actually installed the correct version and everything now works as expected.

Posts: 2
Joined: Mon May 16, 2016 7:44 pm

Re: Synergy 1.7.6 released

Postby Denis Milette » Mon May 16, 2016 7:52 pm

I'm still having key mapping issues on Mac servers, and even if this seems like a fairly common issue no one seems to address it..? All spacebar inputs come out as "/" (in my case anyway). This has been persistent in the past several versions.

Any way we can help to fix this?

Posts: 1
Joined: Wed May 18, 2016 6:02 am

Re: Synergy 1.7.6 released

Postby John Chalisque Allsup » Wed May 18, 2016 6:03 am

Is there a snow leopard version? 1.7.4 is the latest I can download for osx 10.6.

Posts: 2
Joined: Thu May 26, 2016 10:58 am

Re: Synergy 1.7.6 released

Postby SMIT JAIN » Thu May 26, 2016 11:01 am

I am using synergy 1.7.6 on Ubuntu 14.04 on two machines.

The client is not able to connect to the server and below is the log, kindly assist I am tired of being such softwares.

[2016-05-26T23:25:39] ERROR: server refused client with name "krait-4790"
[2016-05-26T23:25:39] WARNING: failed to connect to server: server refused client with our name
[2016-05-26T23:25:40] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081
[2016-05-26T23:25:40] ERROR: server refused client with name "krait-4790"
[2016-05-26T23:25:40] WARNING: failed to connect to server: server refused client with our name
[2016-05-26T23:25:41] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081
[2016-05-26T23:25:41] ERROR: server refused client with name "krait-4790"
[2016-05-26T23:25:41] WARNING: failed to connect to server: server refused client with our name
[2016-05-26T23:25:42] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081
[2016-05-26T23:25:42] ERROR: server refused client with name "krait-4790"
[2016-05-26T23:25:42] WARNING: failed to connect to server: server refused client with our name
[2016-05-26T23:25:43] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081
[2016-05-26T23:25:43] ERROR: server refused client with name "krait-4790"
[2016-05-26T23:25:43] WARNING: failed to connect to server: server refused client with our name
[2016-05-26T23:25:44] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081
[2016-05-26T23:25:44] ERROR: server refused client with name "krait-4790"
[2016-05-26T23:25:44] WARNING: failed to connect to server: server refused client with our name
[2016-05-26T23:25:45] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081
[2016-05-26T23:25:45] ERROR: server refused client with name "krait-4790"
[2016-05-26T23:25:45] WARNING: failed to connect to server: server refused client with our name
[2016-05-26T23:25:46] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081
[2016-05-26T23:25:46] ERROR: server refused client with name "krait-4790"
[2016-05-26T23:25:46] WARNING: failed to connect to server: server refused client with our name
[2016-05-26T23:25:47] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081
[2016-05-26T23:25:47] ERROR: server refused client with name "krait-4790"
[2016-05-26T23:25:47] WARNING: failed to connect to server: server refused client with our name
[2016-05-26T23:25:48] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081
[2016-05-26T23:25:48] ERROR: server refused client with name "krait-4790"
[2016-05-26T23:25:48] WARNING: failed to connect to server: server refused client with our name
[2016-05-26T23:25:49] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081
[2016-05-26T23:25:49] ERROR: server refused client with name "krait-4790"
[2016-05-26T23:25:49] WARNING: failed to connect to server: server refused client with our name
[2016-05-26T23:25:50] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081
[2016-05-26T23:25:50] ERROR: server refused client with name "krait-4790"
[2016-05-26T23:25:50] WARNING: failed to connect to server: server refused client with our name
[2016-05-26T23:25:51] INFO: service command updated
[2016-05-26T23:25:51] NOTE: connecting to '192.168.0.102': 192.168.0.102:8081
[2016-05-26T23:25:51] ERROR: server refused client with name "krait-4790"
[2016-05-26T23:25:51] WARNING: failed to connect to server: server refused client with our name
[2016-05-26T23:25:52] INFO: process started but command is empty, shutting down
[2016-05-26T23:25:52] INFO: got ipc shutdown message
[2016-05-26T23:25:52] NOTE: stopped client
[2016-05-26T23:25:53] INFO: process 7568 was shutdown gracefully

PreviousNext

Return to Announcements

Who is online

Users browsing this forum: No registered users and 1 guest